MicroStation V8i Essentials
(SELECTseries 3)

Bentley Institute Course Guide
Trademark Notice

Bentley and the "B" Bentley logo are either registered or unregistered trademarks or service marks of Bentley Systems, Incorporated. All other marks are the property of their respective owners.

AccuDraw, MDL, MicroStation, and SmartLine are registered trademarks; PopSet and Raster Manager are trademarks.

AutoCAD is a registered trademark of Autodesk, Inc.

Copyright Notice

Copyright ©2012, Bentley Systems, Incorporated. All Rights Reserved.
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Course Overview</strong></td>
<td>11</td>
</tr>
<tr>
<td>Course Description</td>
<td>11</td>
</tr>
<tr>
<td>Target Audience</td>
<td>11</td>
</tr>
<tr>
<td>Prerequisites</td>
<td>11</td>
</tr>
<tr>
<td>Course Objectives</td>
<td>11</td>
</tr>
<tr>
<td>Getting Help</td>
<td>12</td>
</tr>
<tr>
<td><strong>Welcome to MicroStation</strong></td>
<td>13</td>
</tr>
<tr>
<td>Module Overview</td>
<td>13</td>
</tr>
<tr>
<td>Module Prerequisites</td>
<td>13</td>
</tr>
<tr>
<td>Module Objectives</td>
<td>13</td>
</tr>
<tr>
<td>Introductory Knowledge</td>
<td>13</td>
</tr>
<tr>
<td>Questions</td>
<td>13</td>
</tr>
<tr>
<td>Answers</td>
<td>14</td>
</tr>
<tr>
<td>Launching MicroStation</td>
<td>14</td>
</tr>
<tr>
<td>The File Open Dialog</td>
<td>14</td>
</tr>
<tr>
<td>Workspaces</td>
<td>16</td>
</tr>
<tr>
<td>The Interface</td>
<td>17</td>
</tr>
<tr>
<td>MicroStation’s menus</td>
<td>17</td>
</tr>
<tr>
<td>The Attributes toolbox</td>
<td>18</td>
</tr>
<tr>
<td>The Primary Tools toolbox</td>
<td>18</td>
</tr>
<tr>
<td>The Standard toolbox</td>
<td>18</td>
</tr>
<tr>
<td>The status bar</td>
<td>19</td>
</tr>
<tr>
<td>Main toolbox</td>
<td>19</td>
</tr>
<tr>
<td>Tasks</td>
<td>20</td>
</tr>
<tr>
<td>The most often used tools</td>
<td>21</td>
</tr>
<tr>
<td>The tool settings window</td>
<td>22</td>
</tr>
<tr>
<td>View windows</td>
<td>22</td>
</tr>
<tr>
<td>View controls for each view window</td>
<td>22</td>
</tr>
<tr>
<td>Models</td>
<td>23</td>
</tr>
<tr>
<td>Working with Tools</td>
<td>26</td>
</tr>
<tr>
<td>Starting and stopping tools</td>
<td>26</td>
</tr>
<tr>
<td>The Element Selection tool</td>
<td>27</td>
</tr>
<tr>
<td>Tips and Tricks</td>
<td>31</td>
</tr>
<tr>
<td>Module Assessment</td>
<td>31</td>
</tr>
</tbody>
</table>
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element Creation</td>
<td>33</td>
</tr>
<tr>
<td>Module Overview</td>
<td>33</td>
</tr>
<tr>
<td>Module Prerequisites</td>
<td>33</td>
</tr>
<tr>
<td>Module Objectives</td>
<td>33</td>
</tr>
<tr>
<td>Introductory Knowledge</td>
<td>33</td>
</tr>
<tr>
<td>Questions</td>
<td>34</td>
</tr>
<tr>
<td>Answers</td>
<td>34</td>
</tr>
<tr>
<td>Element Attributes</td>
<td>34</td>
</tr>
<tr>
<td>Active color</td>
<td>34</td>
</tr>
<tr>
<td>Active line style</td>
<td>37</td>
</tr>
<tr>
<td>Active line weight</td>
<td>37</td>
</tr>
<tr>
<td>Active element transparency</td>
<td>38</td>
</tr>
<tr>
<td>Active element display priority</td>
<td>38</td>
</tr>
<tr>
<td>Filled elements</td>
<td>38</td>
</tr>
<tr>
<td>Levels</td>
<td>40</td>
</tr>
<tr>
<td>Creating Elements</td>
<td>43</td>
</tr>
<tr>
<td>Linear Tasks</td>
<td>44</td>
</tr>
<tr>
<td>The Place SmartLine tool</td>
<td>44</td>
</tr>
<tr>
<td>Place Stream Line String</td>
<td>48</td>
</tr>
<tr>
<td>Construct Minimum Distance Line</td>
<td>49</td>
</tr>
<tr>
<td>Construct Line at Active Angle</td>
<td>49</td>
</tr>
<tr>
<td>Place Freehand Sketch</td>
<td>50</td>
</tr>
<tr>
<td>Circles Tasks</td>
<td>50</td>
</tr>
<tr>
<td>The Place Arc tool</td>
<td>50</td>
</tr>
<tr>
<td>The Place Circle tool</td>
<td>52</td>
</tr>
<tr>
<td>Polygons Tasks</td>
<td>53</td>
</tr>
<tr>
<td>The Place Block tool</td>
<td>54</td>
</tr>
<tr>
<td>Place Regular Polygon</td>
<td>55</td>
</tr>
<tr>
<td>Complex Chains, Shapes and Regions</td>
<td>57</td>
</tr>
<tr>
<td>Undo, Redo, and Delete</td>
<td>61</td>
</tr>
<tr>
<td>Element templates</td>
<td>61</td>
</tr>
<tr>
<td>Working with Cells</td>
<td>62</td>
</tr>
<tr>
<td>Placing cells in designs</td>
<td>63</td>
</tr>
<tr>
<td>Placing cells that already exist in a design</td>
<td>65</td>
</tr>
<tr>
<td>True Scale</td>
<td>65</td>
</tr>
<tr>
<td>Creating cells</td>
<td>66</td>
</tr>
<tr>
<td>Replacing cells</td>
<td>67</td>
</tr>
<tr>
<td>Line terminators</td>
<td>68</td>
</tr>
<tr>
<td>Shared cells</td>
<td>68</td>
</tr>
<tr>
<td>Precise Element Placement</td>
<td>69</td>
</tr>
<tr>
<td>AccuSnap</td>
<td>69</td>
</tr>
<tr>
<td>Snap modes</td>
<td>69</td>
</tr>
<tr>
<td>Tips and Tricks</td>
<td>73</td>
</tr>
<tr>
<td>Module Assessment</td>
<td>73</td>
</tr>
<tr>
<td>Using AccuDraw for Precision</td>
<td>75</td>
</tr>
</tbody>
</table>
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Overview</td>
<td>75</td>
</tr>
<tr>
<td>Module Prerequisites</td>
<td>75</td>
</tr>
<tr>
<td>Module Objectives</td>
<td>75</td>
</tr>
<tr>
<td>Introductory Knowledge</td>
<td>75</td>
</tr>
<tr>
<td>Questions</td>
<td>76</td>
</tr>
<tr>
<td>Answers</td>
<td>76</td>
</tr>
<tr>
<td>AccuDraw Basics</td>
<td>76</td>
</tr>
<tr>
<td>The AccuDraw workflow</td>
<td>77</td>
</tr>
<tr>
<td>The input focus</td>
<td>78</td>
</tr>
<tr>
<td>AccuDraw indexing</td>
<td>78</td>
</tr>
<tr>
<td>Drawing with AccuDraw</td>
<td>80</td>
</tr>
<tr>
<td>Locking coordinate values</td>
<td>83</td>
</tr>
<tr>
<td>AccuDraw Shortcuts</td>
<td>84</td>
</tr>
<tr>
<td>The Pop-up Calculator</td>
<td>94</td>
</tr>
<tr>
<td>Using the pop-up calculator</td>
<td>95</td>
</tr>
<tr>
<td>Tips and Tricks</td>
<td>96</td>
</tr>
<tr>
<td>Module Assessment</td>
<td>97</td>
</tr>
<tr>
<td>Working with Existing Elements</td>
<td>99</td>
</tr>
<tr>
<td>Module Overview</td>
<td>99</td>
</tr>
<tr>
<td>Module Prerequisites</td>
<td>99</td>
</tr>
<tr>
<td>Module Objectives</td>
<td>99</td>
</tr>
<tr>
<td>Introductory Knowledge</td>
<td>100</td>
</tr>
<tr>
<td>Questions</td>
<td>100</td>
</tr>
<tr>
<td>Answers</td>
<td>100</td>
</tr>
<tr>
<td>Basic Manipulation Tools</td>
<td>100</td>
</tr>
<tr>
<td>Move Element</td>
<td>101</td>
</tr>
<tr>
<td>Copy</td>
<td>101</td>
</tr>
<tr>
<td>Mirror</td>
<td>102</td>
</tr>
<tr>
<td>Align Elements by Edge</td>
<td>105</td>
</tr>
<tr>
<td>Move to Contact</td>
<td>106</td>
</tr>
<tr>
<td>Rotate</td>
<td>107</td>
</tr>
<tr>
<td>Scale</td>
<td>109</td>
</tr>
<tr>
<td>Move/Copy Parallel</td>
<td>110</td>
</tr>
<tr>
<td>Array</td>
<td>112</td>
</tr>
<tr>
<td>Working with Groups of Elements</td>
<td>114</td>
</tr>
<tr>
<td>The Fence</td>
<td>114</td>
</tr>
<tr>
<td>Named Fences</td>
<td>121</td>
</tr>
<tr>
<td>The Element Selection tool</td>
<td>122</td>
</tr>
<tr>
<td>Graphic groups</td>
<td>125</td>
</tr>
<tr>
<td>Named Groups</td>
<td>126</td>
</tr>
<tr>
<td>Making Measurements</td>
<td>129</td>
</tr>
<tr>
<td>Measuring distance</td>
<td>130</td>
</tr>
<tr>
<td>Measure Length</td>
<td>132</td>
</tr>
<tr>
<td>Measure Radius and Measure Angle</td>
<td>132</td>
</tr>
<tr>
<td>Measure Area</td>
<td>133</td>
</tr>
<tr>
<td>Module</td>
<td>Page</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Using Patterns to Add Definition</td>
<td>134</td>
</tr>
<tr>
<td>Hatch Area</td>
<td>134</td>
</tr>
<tr>
<td>Delete Pattern</td>
<td>136</td>
</tr>
<tr>
<td>Crosshatch Area</td>
<td>136</td>
</tr>
<tr>
<td>Associative patterning</td>
<td>137</td>
</tr>
<tr>
<td>Pattern Area</td>
<td>139</td>
</tr>
<tr>
<td>Tips and Tricks</td>
<td>141</td>
</tr>
<tr>
<td>Module Assessment</td>
<td>142</td>
</tr>
<tr>
<td>Modifying Existing Elements</td>
<td>143</td>
</tr>
<tr>
<td>Module Overview</td>
<td>143</td>
</tr>
<tr>
<td>Module Prerequisites</td>
<td>143</td>
</tr>
<tr>
<td>Module Objectives</td>
<td>143</td>
</tr>
<tr>
<td>Introductory Knowledge</td>
<td>143</td>
</tr>
<tr>
<td>Questions</td>
<td>144</td>
</tr>
<tr>
<td>Answers</td>
<td>144</td>
</tr>
<tr>
<td>Basic Modification tools</td>
<td>144</td>
</tr>
<tr>
<td>Modify Element</td>
<td>145</td>
</tr>
<tr>
<td>Break Element</td>
<td>148</td>
</tr>
<tr>
<td>Extend Line</td>
<td>150</td>
</tr>
<tr>
<td>Trim to Intersection</td>
<td>150</td>
</tr>
<tr>
<td>Trim to Element</td>
<td>151</td>
</tr>
<tr>
<td>Trim Multiple</td>
<td>152</td>
</tr>
<tr>
<td>Construct Circular Fillet</td>
<td>153</td>
</tr>
<tr>
<td>Construct Parabolic Fillet</td>
<td>154</td>
</tr>
<tr>
<td>Construct Chamfer</td>
<td>154</td>
</tr>
<tr>
<td>Changing Element Attributes</td>
<td>158</td>
</tr>
<tr>
<td>Using Element Selection</td>
<td>158</td>
</tr>
<tr>
<td>Using Element Information</td>
<td>159</td>
</tr>
<tr>
<td>Change Attributes toolbox</td>
<td>160</td>
</tr>
<tr>
<td>Tips and Tricks</td>
<td>162</td>
</tr>
<tr>
<td>Module Assessment</td>
<td>163</td>
</tr>
<tr>
<td>Annotating Designs</td>
<td>165</td>
</tr>
<tr>
<td>Module Overview</td>
<td>165</td>
</tr>
<tr>
<td>Module Prerequisites</td>
<td>165</td>
</tr>
<tr>
<td>Module Objectives</td>
<td>165</td>
</tr>
<tr>
<td>Introductory Knowledge</td>
<td>166</td>
</tr>
<tr>
<td>Questions</td>
<td>166</td>
</tr>
<tr>
<td>Answers</td>
<td>166</td>
</tr>
<tr>
<td>Text Attributes</td>
<td>166</td>
</tr>
<tr>
<td>Fonts</td>
<td>166</td>
</tr>
<tr>
<td>Justification</td>
<td>167</td>
</tr>
<tr>
<td>Text size</td>
<td>167</td>
</tr>
<tr>
<td>Line spacing</td>
<td>167</td>
</tr>
<tr>
<td>Setting attributes</td>
<td>167</td>
</tr>
</tbody>
</table>
### Using Text Tools

- Place text __________________________________________________________________________ 168
- Placement methods ___________________________________________________________________ 169
- Other placement options ___________________________________________________________________________ 170
- Annotation scale __________________________________________________________________________ 172
- Place Note __________________________________________________________________________ 173
- Enter data fields __________________________________________________________________________ 175
- Copy/Increment Text __________________________________________________________________________ 176
- Find/Replace Text __________________________________________________________________________ 176

#### Changing Existing Text

- Edit Text __________________________________________________________________________ 177
- Matching and changing text ___________________________________________________________________________ 178

### Text Fields

- The Spell Checker __________________________________________________________________________ 181
- Revision Clouds __________________________________________________________________________ 182

### Dimensions

- Dimensioning tools __________________________________________________________________________ 183
- Element Dimensioning __________________________________________________________________________ 183
- Alignment __________________________________________________________________________ 186
- Association __________________________________________________________________________ 186
- Linear dimensioning __________________________________________________________________________ 188
- Angular dimensioning __________________________________________________________________________ 192
- Ordinate dimensioning __________________________________________________________________________ 192
- Modifying existing dimensions __________________________________________________________________________ 192
- Change Dimension __________________________________________________________________________ 192
- Dimension Audit __________________________________________________________________________ 194

### Tips and Tricks

- Module Assessment __________________________________________________________________________ 195

### MicroStation Design Files

- Module Overview __________________________________________________________________________ 197
- Module Prerequisites __________________________________________________________________________ 197
- Module Objectives __________________________________________________________________________ 197
- Introductory Knowledge
  - Questions __________________________________________________________________________ 198
  - Answers __________________________________________________________________________ 198
- MicroStation Design Files __________________________________________________________________________ 198
  - Closing Files __________________________________________________________________________ 198
  - Saving information __________________________________________________________________________ 199
  - Creating a MicroStation design file __________________________________________________________________________ 199
  - Seed files __________________________________________________________________________ 200
- Working with Files __________________________________________________________________________ 201
  - Setting working units __________________________________________________________________________ 201
  - Compressing files __________________________________________________________________________ 203
- Storing Geometry __________________________________________________________________________ 203
  - Models __________________________________________________________________________ 203
| Saved Views | 203 |
| Ending a MicroStation Session | 207 |
| Save Settings | 207 |
| Tips and Tricks | 207 |
| Module Assessment | 208 |

### Organizing Design Data | 209
- Module Overview | 209
- Module Prerequisites | 209
- Module Objectives | 209
- Introductory Knowledge | 209
  - Questions | 210
  - Answers | 210
- References | 210
  - Attaching references | 210
  - Attachment settings | 212
  - Updating reference elements | 214
  - Manipulating references | 215
  - The Use References Dialog List option | 216
  - Reference exchange and activation | 216
  - Reference levels | 217
  - Transparency and priority settings | 217
  - Detaching references | 218
  - Reference nesting | 219
  - Resolving different working units | 221
- Models | 225
  - Types of models | 226
  - Creating models | 227
- Publishing i-models | 231
- Raster References | 233
  - Attachment settings | 234
  - Attaching PDF documents | 237
- Tips and Tricks | 238
- Module Assessment | 239

### Creating Printed Output | 241
- Module Overview | 241
- Module Prerequisites | 241
- Module Objectives | 241
- Introductory Knowledge | 241
  - Questions | 241
  - Answers | 242
- Printing Basics | 242
  - Selecting the print area | 242
  - Setting the output color mode | 243
  - Selecting a printer | 244
Table of Contents

Setting the printing parameters _______________________ 245
Attaching pen tables ________________________________ 249
Previewing the printed output ________________________ 249
Creating the print __________________________________ 250
Creating Complete Scaled Sheets _________________________ 251
Working with borders _________________________________ 251
Using a 1:1 scale border _____________________________ 252
Scaling a border to fit elements _______________________ 256
Tips and Tricks ______________________________________ 257
Module Assessment____________________________________ 257

Appendix - AccuDraw Shortcuts __________________________ 259

Design Labs _________________________________________ 261
What to Design _______________________________________ 261
Parameters _________________________________________ 262
How to Design _________________________________________ 263
Review the Design____________________________________ 264
What to Design _______________________________________ 264
How to design ________________________________________ 264
Course Overview

Course Description

This course is designed to teach a 2D production drafter how to use MicroStation software to create quality designs. You will learn to use MicroStation’s tools and features to create designs, manipulate and modify elements, assemble data, and create printed output.

Target Audience

This course is recommended for the following audience(s):

• Individuals who are learning how to use MicroStation

Prerequisites

• Fundamental knowledge of the Microsoft Windows operating system

Course Objectives

After completing this course, you will be able to:

• Create and edit files that contain elements such as lines, circles, and polygons
• Manipulate and modify existing elements
• Annotate designs
• Organize data
• Create printed output
Getting Help

There are several ways to get assistance while working in MicroStation. Find options on the Help menu on MicroStation’s main menu bar, which is at the top of the MicroStation application window.

- Select Contents from the Help menu to open the MicroStation Help document. You can browse topics, use the index, and perform keyword searches.
- Help is context-sensitive. Pressing F1 while using a tool or dialog box will open the Help document directly to the topic related to your current task.
- You can turn on the Help Tracking feature to automatically display help for each newly selected tool. To do this, select Tracking from the Help menu on the main menu bar.

Quick Start Guide

Selecting Quick Start Guide from the Help menu opens a PDF document that provides a brief overview of some of the topics and concepts contained in this more detailed course.
Welcome to MicroStation

Module Overview

This module will help a new user become familiar with the tools and features found in the MicroStation design environment.

Module Prerequisites

- Fundamental knowledge of the Microsoft Windows operating system

Module Objectives

After completing this module, you will be able to:

- Identify features in MicroStation’s interface
- Use basic mouse functions with MicroStation
- Save file settings
- End a MicroStation session

Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1. Provide a definition of computer-aided design.
Answers

1. The term CAD defines a system that a designer/drafter/engineer can use for both designing a product and for specifying the construction processes.

2. Lines, circles, arcs, polygons.

3. A border and graphics that make up the design.

Launching MicroStation

You can launch MicroStation using one of the following methods:

- Select the Bentley program group from the Windows Start menu (Start > (All) Programs > Bentley), then select the MicroStation item
- Double click the MicroStation icon on the desktop
- Double click the icon of a file with the extension .dgn in Windows Explorer

The default installation location on Windows XP is \Documents and Settings\All Users\Application Data\bentley\MicroStation.

On Windows Vista, the location is \ProgramData\Bentley\.

On Windows 7, the location is \ProgramData\Bentley\.

The File Open Dialog

When you launch MicroStation, the File Open dialog appears by default. Its primary function is navigating to and opening design files.

To list a specific type of file, click on the arrow next to the ‘Files of type’ field in the lower portion of the dialog. Use these options to make it easier to find a
certain type of file. When you select a specific file type, the files listed above will only contain those that have the selected extension.

The preview window on the right side displays a thumbnail image of the selected file. If the file is from an early MicroStation version, a thumbnail is not displayed. Information about the selected file appears above the preview window. The information indicates whether a DGN file is 2D or 3D, and indicates the MicroStation version with which the file is compatible. The file format version displays for AutoCAD files.

<table>
<thead>
<tr>
<th>Thumbnail</th>
<th>File Association</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="V8 generation DGN files and later revisions of .dwg files show file content if there's a thumbnail." /></td>
<td>V8 generation DGN files and later revisions of .dwg files show file content if there's a thumbnail.</td>
</tr>
<tr>
<td><img src="image" alt="V8 generation DGN files and later revisions of .dwg files, when a thumbnail is not available." /></td>
<td>V8 generation DGN files and later revisions of .dwg files, when a thumbnail is not available.</td>
</tr>
<tr>
<td><img src="image" alt="MicroStation/J and older versions of MicroStation" /></td>
<td>MicroStation/J and older versions of MicroStation</td>
</tr>
<tr>
<td><img src="image" alt="Older DWG versions" /></td>
<td>Older DWG versions</td>
</tr>
</tbody>
</table>

Check the ‘Open as read-only’ check box at the bottom of the dialog so that files will open in a read-only mode for viewing and printing. This protects you from accidentally modifying a file. You can see what’s in it, but can’t modify it.
The File Open Dialog

Workspaces

A workspace is a custom MicroStation configuration that is set up by an administrator. By selecting a workspace, MicroStation can be customized for a specific discipline, project, or job.

When a workspace is active, the files and tools you need to perform a specific job are available. Tools that are not necessary are removed from the interface.

To select a workspace, select the desired User and Project in the File Open dialog. The following exercise shows you how to do this.

➤ Exercise: Select a Workspace

1. Launch MicroStation by clicking the Windows Start menu and selecting (All) Programs > Bentley > MicroStation V8i (SELECTseries), or use the icon on the desktop if there is one.

2. At the lower right of the File Open dialog, change the User option from untitled to examples.

3. Change the Project option to General.

4. Click on the file named MicroStation_Essentials_V8i.dgn.

5. Click Open.

You see the MicroStation application window, containing a visual index of this design file.

Hint: MicroStation is delivered with the ‘examples’ workspace containing files which show many MicroStation features.
The Interface

MicroStation’s menus

The main menu bar is located along the top of the MicroStation application window. It one of the main sources of commands for controlling MicroStation’s operation.

If you are looking for a specific tool to use, select Tools from the main menu bar. The resulting menu shows most tools available in MicroStation.
If you need to adjust design file settings, select Settings from the main menu bar and then look for and select ‘Design File’.

**The Attributes toolbox**

The first toolbox under the main menu bar is the Attributes toolbox. This is where you change settings that affect how elements you will be placing will look. It is discussed in depth later in the course.

**The Primary Tools toolbox**

The Primary Tools toolbox is next and it is a launch point for commonly used tools. Most of them open dialog boxes where you perform routine functions. These tools are also discussed in depth later in the course.

**The Standard toolbox**

The Standard toolbox is hidden by default. It contains tools that give you quick access to commonly used pull-down menu items. Open it by selecting Standard from the Tools menu on the main menu bar. However, most of these tools can be accessed using keyboard shortcuts.

The first tool opens a dialog box where you can create a new file. You could use the tool or press Ctrl + N on the keyboard. The next tool, Open, is Ctrl + O. The Cut, Copy and Paste tools (Ctrl + X, Ctrl + C, Ctrl + V) are in the center of the toolbox. Look at the File menu to see other shortcuts.
 Hint: All tools in a toolbox are not always visible by default. To see all tools, right click in the toolbox and select ‘Show All’ from the menu.

The status bar

The status bar is an important part of the MicroStation user interface since it provides a view into MicroStation’s operation. MicroStation continually displays information about its operation on the left side of the status bar. Messages include the name of the current tool in use and the next step in its use, information about the previous action, or the status of certain features.

The Message Center is in the middle of the status bar. Moving to the right there are icons that let you access different modes. The items are discussed as they become relevant in the course.

Note: The red highlight on the Status bar indicates the presence and status of cached visible edge references.

Main toolbox

The Main toolbox is used to invoke selection, manipulation, modification, and measuring tools.

When you press and hold the mouse’s left button, the data button, on a tool in the Main toolbox, you see a menu that gives you access to all the tools in that toolbox.

You can open an individual toolbox by doing this and selecting Open <name> as ToolBox from the pop-up menu. You can then place, or dock, the toolbox in a convenient location on the screen. The Element Selection and Delete Element tools do not have an associated toolbox.

You can customize MicroStation toolboxes once they are open. Right click on a tool in the box to display a list of the tools available in the toolbox. If you click one that was unchecked, it will appear in the toolbox. Uncheck to remove.
Exercise: Familiarize yourself with the status bar and main toolbox

1. Continuing in MicroStation_Essentials_V8i.dgn, click on different tools in the Main toolbox and watch as the messages on the left side of the status bar change.

   The name of the tool is displayed followed by a prompt that instructs you how to start using the tool.

   Moving to the right in the status bar, you will find the Message Center.

2. Click on the message, or in the blank area if there is no message, to open the Message Center dialog.

   A message about an element type and the level that it was placed on

   It lets you review informational and other types of messages. In certain cases, an icon indicating the message type displays.

Tasks

A task is simply a logical grouping of tools organized by use. Tasks can contain overlapping sets of tools. For example, a Drawing task and Drawing Composition task can both contain the same text placement tools.

Tools found in the Tasks dialog on the left side of the application window are used to put elements into designs. MicroStation provides default task lists for Drawing and Drawing Composition. Click on the word Tasks at the top of the Tasks dialog to see the available tasks. When you select a task from the list, the tasks and tool icons underneath the Main toolbox change.
The most often used tools

The following list separates commonly used MicroStation tools into four basic categories used in 2D drafting.

Element creation tools (from the Tasks dialog)
- Place SmartLine
- Place Circle
- Place Arc
- Place Block
- Place Cell
- Place Text
- Place Dimension
- Hatch/Pattern Area

Manipulation tools (from the Main toolbox)
- Copy/Move
- Scale
- Rotate
- Mirror
- Stretch
- Move Parallel

Modification tools (from the Main toolbox)
- Modify
- Trim to Intersection
- Trim Multiple
- Insert/Delete Vertex

Miscellaneous tools
- Element Selection/Fence for grouping elements (from the Main toolbox)
- Measure (from the Main toolbox or the Tasks dialog)
- Delete (from the Main toolbox)
- Print (from the File menu)
The Interface

The tool settings window

Most tools have options to control their operation. These appear in the tool settings window. This window is open by default upon start-up. If you close the tool settings window, new tool settings will automatically appear when you select the next tool.

![Tool settings for the Place Block tool]

**Hint:** Check the tool settings window and the left side of the status bar to see which tool is active.

View windows

In MicroStation, the space in which you draw is a view window. You can open more than one view window to aid in the design process. View windows are resizable, moveable, and collapsible.

You can open as many as eight views at any time. A view’s number is shown at the upper left of the view window’s title bar. The reason for eight view windows is so you can view more than one portion of a design at one time.

View controls for each view window

To control the content of a view window, each one has its own View toolbox containing view controls. View controls let you change the what you see in one view without affecting the contents of any other view. The View toolbox is located at the upper left of each open view window. There are different icons for 2D and 3D.
Models

MicroStation design files can contain multiple models. A model is a separate working space within a design file. They are equivalent to worksheets in Excel. Worksheets are independent numerical spaces, and models are independent graphical spaces. Models separate geometry within one design file.

Exercise: Open the model for the next exercise

1. Continuing in MicroStation_Essentials_V8i.dgn, click the arrow next to the Models tool in the Primary tools toolbox.

   A pop-up dialog opens.

2. Locate, and then double click on, the model named Welcome to MicroStation.

   You see elements representing the Earth.

Note: You can also open models in this file by placing the cursor on the frame around each image, where a description of the Link appears, then right clicking and clicking Open Link on the pop-up menu. Select “Essential_MicroStation_V8i, <Model Name>” to open the model. Select “ustnkeyin:help topic” to go to the topic in the Help file.
The Interface

➔ **Exercise: Open and close views**

1. Continuing in the Welcome model, click the word Window on the main menu bar.

2. Hold the pointer over the Views item.

3. Move the pointer to the right and select 2 from the sub-menu (Window > Views > 2).

   This opens a new view window named View 2.

   You can also open view windows using the numbered buttons in the View Groups dialog, which is at the lower left of the application window.

4. Click the 8 button in the View Groups dialog at the lower left of the application window.

   This opens View 8.

5. Click the 2 and 8 buttons to close the views.

Closing all the view windows in a file is not the same as closing the file. You have closed all of the design windows, but the file is still open. The title bar at the top of the MicroStation application window displays the name of the open file. Each view window’s title bar displays the name of the model you are in.

➔ **Exercise: Use the view controls**

1. From the top of View 1, select Zoom In.

   The shape of the zoom rectangle is proportional to the view window from which the tool was selected.

2. Move the zoom rectangle to center on the Southern tip of South America and enter a data point.

3. Change the Zoom Ratio by typing 4.0 in the Zoom Ratio field in the tool settings.

   Now you will zoom further in or out each time you click. You can change this ratio any time you use the Zoom tools.
4. Zoom in again by entering another data point at the Southern tip of South America.

5. Keep zooming in on the dot just visible off the tip of South America until you can see what it is.

6. Press the right mouse button to end the Zoom In command.

7. Click the 2 button in the View Groups dialog to open that view again. You can use view controls from one view in another view.

8. Select Fit View from View 2’s View toolbox.

   ![Fit View icon]

   Now you can see all the elements in the file.

9. Enter a data point in View 1.

   You see all the elements in the view again.

10. Click the 2 button in the View Groups dialog to close the view.

11. Save Settings from the File menu on the main menu bar.

**Note:** In this course, this type of selection is shown as “select File > Save Settings.”
Working with Tools

You must explicitly save the arrangement of views on the screen and the portion of the design they display. To do this, select ‘Save Settings’ from the File menu on the main menu bar, or press Ctrl + F. When you make changes to many settings that you want to permanently store, you must save them this way.

Working with Tools

Working with most MicroStation tools consists of the following steps:

1. Select a tool.
2. Adjust the tool settings.
3. Follow the status bar prompts to use the tool.

Starting and stopping tools

The mouse is the primary input device for MicroStation’s graphic user interface.

Data points to confirm

When working with MicroStation’s tools, a left mouse button, or data button, click is referred to as entering a data point. The data button is used to select tools and menu items. It is also used to enter points, to place or manipulate elements in the design, and to confirm input. Consider this the Yes button. “Yes, I want to use this tool” or “Yes, I want to enter a point here”.

Reset functions

When working with MicroStation’s tools, a right mouse click is called a reset. You use a reset to back up a step during an operation or to end an operation. You can consider this the “No” button.

The reset button is used to perform the following functions:

- It returns you to the previous operational step
- It resumes the last drawing or editing operation after using a view control
- It rejects the currently selected element and cycles between eligible elements within the location tolerance of the pointer
The Element Selection tool

Element Selection is a tool for selecting objects in a design file. MicroStation defaults to the Element Selection tool whenever no other tool has been chosen. It is the first tool in the Main toolbox.

Element Selection is a very versatile tool. Not only can you use it to select elements, you can also use it to modify and group elements. You will learn more about it in a future module.

→ Exercise: Get information about elements

1 Continuing in the Welcome model, click the Element Selection tool in the Main toolbox.

2 Set the following tool settings (these are the defaults):
   Method (upper row of icons): Individual
   Mode (lower row of icons): New

3 Move the pointer over elements in the design.
   The highlighting turns off as you move the pointer away from an element. As you move over elements, they highlight. If you enter a data point when an element is highlighted, it will be selected. The pop-up information that displays will help you to identify the type of element.

AccuSnap

The pop-up information is a feature of AccuSnap. When this feature is on, and the pointer is near an element, AccuSnap displays information about the element.

AccuSnap’s main function is to help you select precise locations in a design, such as the end of a line or the center of a circle. This operation is called snapping.

With AccuSnap all you do is move the pointer close enough to the point to which you wish to snap. AccuSnap moves to the snap point and stays there until you
move away. A successful snap using AccuSnap places a bold, yellow X on the snap point. The next data point you enter will be placed at precisely that spot.

AccuSnap snapped to the center of the circle

In the next exercises, you will use tools and the mouse to experiment with the way the African and South American continents may have looked during the Jurassic period.

Exercise: The reset button’s first function, confirming input

1. Continuing in the Welcome model, move the pointer until it touches a portion of the African continent, press the data point button, and continue to hold it down.

MicroStation responds by displaying handles around the continent.

2. While holding the data point button down, drag the continent over until it touches South America.

You see that it must be rotated to fit better. To do this, you’ll need to choose a manipulation tool.

3. In the Main toolbox, click the Copy tool, press until the menu opens, and then select Rotate.

4. In the tool settings, click the downward arrow next to Method and select 2 Points.
5 In the tool settings, make sure the Copies check box is not checked.

![Tool settings screenshot]

You want to rotate the original element, not a copy.

6 Returning to the map, move the pointer between the South American east coast and the newly relocated Africa. Enter a data point.

This is the pivot point of rotation. MicroStation responds by putting the element into a dynamic rotation mode. As you move the pointer, the continent spins to follow it.

![Map with pointer and data points]

7 Spin Africa around until it fits against South America.

8 Enter a data point to lock the spun continent into place.

The data point confirms that this location in which you want to place the element.

If you move the pointer, you see that MicroStation keeps Africa in its spin mode so you can still change the rotation.

9 Press the Reset button on the mouse.

Even though the element no longer spins, the tool settings still indicate that the Rotate tool is active. Reset does not cancel a tool; it resets it to the previous operational step.

In MicroStation, once a tool has been selected it is active until another tool is selected or you reset out of it.

10 Reset again.

You return to the Element Selection tool.
11 Click Clear in the tool settings to release the continent.

→ Exercise: The reset button’s second and third functions

1 Note the direction indicator at the bottom of the design.
   The North marker must be rotated.
2 Select Rotate from the Main toolbox.
3 In the Rotate tool settings, set the Method to Active Angle.
4 In the field below that, replace the zeros with 45 and press Enter.
   You are ready to rotate, but it will be easier to see if you are closer.
5 Select Zoom In from the view controls and zoom in on the direction indicator.
6 Reset.
   You return to the Rotate tool. Returning to the original drawing tool after
   using a view control is the second reset function. When you select and use
   a view control tool, just remember to click the reset button after you finish
   adjusting the view.
7 Place the pointer in the center of the direction indicator.
   One of the indicators highlights. It was placed in the file last. However, you
   don’t want this one.
8 Reset until the N indicator highlights.
9 Enter a data point.
MicroStation cycles through the elements inside of the locate tolerance. The locate tolerance is how close the pointer must be to an element in order to recognize it. No matter how many elements are within the locate tolerance, MicroStation will cycle through them all until you select one or until you stop the command. This is the reset button's third function.

**Tips and Tricks**

- To adjust width of Message Center in the status bar, just click bar to the left of the icon (or the area if no icon is displayed) and drag.

  ![Icon](image)

- The tool settings automatically hide when the pointer gets too close. To make them hide sooner, right click the PopSet tool, which is the last one in the Primary Tools toolbox, and select Settings. Then, set the Hide Border option to a higher number. If you don’t want the tool settings to hide at all, set it to 0. Now click the PopSet icon so it turns green and does not have the slash mark through it to turn it on.

  ![Toolbox](image)

- If tools are displayed in a toolbox and you don’t use them, just right click in the toolbox and uncheck the tool name so it will no longer display.

- If a dialog gets stuck in the corner of a view window, or under the main menu bar, simply hold down the Shift key, grab the dialog as close to the one edge as possible, and drag it away.

**Module Assessment**

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

[Welcome to MicroStation Assessment](#)
Element Creation

Module Overview

This module presents frequently used element creation tools, and provides instructions for their use in adding elements to your designs.

Module Prerequisites

- Knowledge of MicroStation’s interface
- Knowledge about viewing in MicroStation
- Knowledge about AccuDraw
- Knowledge about element attributes

Module Objectives

After completing this module, you will be able to:

- Add elements to designs
- Determine which tool is best for a particular task
- Apply knowledge about familiar tools to new tools

Introductory Knowledge

Before you begin this module, let's define what you already know.
Element Attributes

Questions

1. What is snapping?
2. Working with most MicroStation tools consists of a series of steps. What are they?

Answers

1. Snapping let you select specific points, such as an end point, mid point, center point or intersection with precision.
2. Select a tool.
   - Adjust the tool settings.
   - Follow the status bar prompts and use the tool.

Element Attributes

When placing new elements in a design file, they are assigned specific attributes that control their appearance and display properties. These attributes are typically set prior to placing the element in the design. They can also be changed later.

Common element attributes are Level, Color, Line Style, Weight, Transparency and Display Priority. All of these are set in the Attributes toolbox.

Active color

The active color specifies the color with which new elements will be placed.
When you select the color tool in the Attributes toolbox you see a dialog that has three tabs; Indexed, True Color and Color Book.

- The first tab is the Indexed Color tab. It lets you select a color from a table of 256 colors. Each color in the table can be modified, or you can change the available colors by attaching a different color table to the design file. These colors are not named. They are identified by number.
- The second tab lets you select a color based upon true color values.
- The third tab is the Color Book tab. Color books are used to contain a collection of named, true (RGB) colors. Naming and categorizing the colors allows you to select colors by name rather than by number triplets. When a color from a book is assigned to an element, the book and color name are stored in the element and can be easily reviewed.
- A fourth tab is available when using a tool that creates a closed element because they can be filled with color. This tab becomes usable when the Fill Color option is set in a tool’s tool settings.

**Identifying an existing element’s color**

There are several ways to do this, just as there are different ways of obtaining information about elements.

**Exercise: Methods to identify element color**

1. Continuing in MicroStation_Essentials_V8i.dgn, click the Models tool in the Primary tools toolbox to open the Models dialog.
2 Double click on the model named “Element Creation”, with the description “Essentials geometry”.

![Model names and descriptions]

The model opens and you see the geometry contained in it.

**Note**: You can click the Name column's header to sort the models by name. For this course, remember to check for the correct description.

3 Select the Element Selection tool from the Main toolbox.

![The boundary highlights]

4 Click on the dashed (yellow) boundary around the geography to select it.

5 Click the arrow at the bottom right of the Element Selection tool settings to expand them.

6 Click the color tab.

![The color tab]

The color that is highlighted at the top of the tab is the color of the selected element. If multiple elements are selected, all their colors are highlighted at the top.

7 Click the Element Information tool in the Primary Tools toolbox.
The word Selection is highlighted at the top.

Since there is only one element selected, you see its properties in the General section. The element color is on the Color line. If multiple elements are selected, click the individual entries under Selection (Complex Shape in this case) to see information about that specific element. The element will highlight in the view when you click the entry.

8. Expand Complex Shape by clicking the +, and click on each component of the complex shape that is listed underneath.


10. In the Element Selection tool settings, click the Clear icon to release the boundary.

**Active line style**

The active line style is the line style (solid, dashed, dotted) with which new elements will be placed.

MicroStation has two classifications of line styles. The eight standard line styles are numbered 0 - 7. There are also custom line styles for railroads, gas lines, etc. It is possible for an administrator to define your own custom line styles.

- The standard line styles range from solid to dot-dash combinations. These line styles are cosmetic, and are defined in screen units. They do not change size when you Zoom In or Zoom Out, so no scale is associated with them.
- Custom line styles are defined in design units. These line styles are physical, and are scalable. They become larger or smaller when you Zoom In or Zoom Out.

**Note:** There is also support for DWG based line styles, or Linetypes.

**Active line weight**

The active line weight specifies the line weight with which new elements will be placed.
Element Attributes

The active line weight is a value between 0 - 31 that is assigned to an element to define its thickness. MicroStation's line weights are defined in screen units, and remain static as the zoom factor changes.

**Active element transparency**

Transparency is also an element attribute that can be set for elements in the Attributes toolbox, just like color, style, or weight.

![Transparency Options]

Set transparency for elements from 0, fully visible, to 100, not visible. The display of transparency in a view is controlled in the View Attributes dialog.

**Active element display priority**

Another element attribute that can be set in the Attributes toolbox is display priority.

![Display Priority Options]

Display priority is a pre-set value, between -500 and 500, that determines how an element is displayed relative to other elements.

The elements with the highest values are placed in front while those with lower priorities are placed in the back. Element priority is only available in 2D models. Priority is for 2D, since priority corresponds to the Z value in a 3D model.

**Filled elements**

A filled element is an element that has color within its boundaries, as opposed to being displayed as just an outline.

The Fill attribute applies only to closed elements such as circles, ellipses, and shapes. By default, a closed element has lines that define the area occupied by
the element and the area inside the outline is transparent. A closed element is filled when the area within the outline is a solid color.

![Unfilled and Filled elements](image)

Creating fill

The element’s fill color is determined by the Fill Color set in the tool settings at time of an element’s placement.

The Fill Type option determines the kind of fill.
- When an element’s Fill Type is Opaque, you see a solid shape. In this case, the lines defining the element are not discernible since the fill has the same color.
- When an element’s Fill Type is Outlined you can select a fill color that is different from the outline color.

Toggle fill display, just like transparency, in the View Attributes dialog.

**Exercise: Toggle fill display**

1. Continuing in the Element Creation model, press Ctrl + B.
2. In the View Attributes dialog, click the Fill icon.

The shading inside the parks and waterways disappears.

You must select File > Save Settings before leaving a file to preserve the status of the display.

4. Close the View Attributes dialog.
The View Attributes dialog

Use View Attributes to change the way you view a design by selecting the types of elements that are displayed or how some elements appear. To open the View Attributes dialog, either select Settings > View Attributes, click the first tool in the view toolbox at the top of the view window, or press Ctrl + B.

**Hint:** Remember, press Ctrl + B for better viewing. When you do this, the dialog will open with the view number set to the view window that has the focus.

Levels

You need to place the correct types of elements on the correct level, as determined by your organization’s standards. For example, in mapping, levels would be named to describe common features such as boundaries or lot lines. Elements that represent these features would then be placed on the respective level.

The active level is the level on which new elements will be placed. You can change the active level in the Attributes toolbox and in dialogs for working with levels.

The display of elements residing on particular levels can be turned on and off so you can see only the information you want to see. Turning levels on or off only changes the display status of the elements that reside on the levels.

**Note:** You must select File > Save Settings before leaving a file to retain the active level.

**Exercise: Set the active level and toggle level display**

1. Continuing in the Element Creation model, click the Level Display tool in the Primary Tools toolbox.

Like the view attributes, level display is per view. The view to which any changes will be applied is noted in the dialog’s title bar.
Element Attributes

The active, or current, level is has a different background. Any new element you place will be placed on the active level.

2 Change the Active Level by double clicking another level.
   
   You see the level name change up in the Attributes toolbox.

3 Click the Name column’s heading to sort the levels by name.

4 Click the level named Boundary.
   
   Display of elements on the level turns off. Only the active level cannot be turned off.

5 Click the name again to turn display of elements on the level back on.
   
   **Hint:** You can make a level whose elements you want to see the active level and then right click in the list of levels and select All Off so you only see the desired elements. Use the Invert command to turn undisplayed levels on and displayed levels off.

In the Level Display dialog, click the column headings to sort the levels by name. The used column contains a dot if there are elements in it. Click that column to sort the levels by use.

**Moving elements between levels**

You may find that you don’t always create elements on the right level, so you may spend time moving elements between levels. Just as you might change an element’s color or weight, you can also change its assigned level.

**Exercise: Move elements to another level**

1 Continuing in the Element Creation model, move the pointer over the North Arrow at the bottom of the view.
   
   The pop-up information indicates that the elements that comprise it are on the level named Title.
2 Select Element Selection, with the following tool settings:

*Method* (upper row of icons): Block

*Mode* (lower row of icons): Add

3 Drag a block around the North arrow.

4 In the Attributes toolbox, select Direction from the list of levels to make it the active level.

*Hint:* Press the first letter of the level name on the keyboard to skip to those levels.

5 In the Element Selection tool settings, click the Clear icon to release the elements.

6 Change the Element Selection tool settings to the following:

*Method:* Individual

*Mode:* New

7 Move the pointer over the North Arrow and note the level the elements are on now.

*Hint:* You can use the Level tab in the Element Selection tool settings to select elements on a level and then make the level that you want to move them to active in the Attributes toolbox.

**ByLevel symbology**

Rather than placing design elements with the active element attributes, you can place them with symbology settings inherited from the level upon which they are placed. This is called ByLevel symbology.

When elements are placed with the ByLevel attributes and the level symbology definitions are changed, the elements reflect the changes. These symbology settings are managed by an administrator in the Level Manager dialog.
Placing elements in the design file with ByLevel symbology requires the active color, weight and style to be set to ByLevel in the Attributes toolbox. To set the active color, weight or style to ByLevel, select the ByLevel option when you click the attribute’s tool.

![ByLevel options for color and line style](image)

Creating Elements

Most of the tools in the Tasks dialog add new elements to a model. Although elements may vary, the placement tools generally require the usual series of steps.

1. Select a tool.
2. Adjust the tool settings.
3. Follow the status bar prompts and use the tool.
Linear Tasks

These tools are used to place linear elements. Open the Linear toolbox from the Tasks dialog’s Drawing tasks by right clicking the tools and selecting “Open Linear as Toolbox”.

The Place SmartLine tool

The most versatile of the linear tools is the Place SmartLine tool. Found in the Linear tasks, use this tool to place a chain of connected line and arc segments as individual elements or as a single line string, shape, circle, complex chain, or complex shape element.

Place SmartLine lets you create six different element types.

Line, Line String, Shape, Arc, Complex chain, Complex shape
Exercise: Use Place SmartLine to extend a limestone trail

1. Continuing in the Element Creation model, click the arrow next to Tasks (above the Main toolbox) and click on the Drawing task.

2. Select the Trail-Limestone level in the Attributes toolbox.

   **Hint:** Press the first letter of the level name on the keyboard to skip to those levels.

   Make sure the color, style, and weight attributes are set to ByLevel (the default), and you’ll see they change to match the ByLevel attributes.

3. Window Area around the area indicated.

4. Select Place SmartLine with the following tool settings:

   - **Segment Type:** Lines
   - **Vertex Type:** Sharp
   - **Join Elements:** Checked

   When Join Elements is unchecked, an independent line segment is formed every time you enter a data point.
5 Snap to the end of the limestone trail and, following the status bar prompt, enter a data point to start the line.

6 Enter data points, following the river, down to the bridge.

Hint: If you enter a data point and place an incorrect vertex, press Ctrl + Z or select Edit > Undo and then resume entering data points.
7  Reset.

In the next exercise you will connect two roadways.

➤ **Exercise: Use Place SmartLine to connect roads**

1  Continuing in the Element Creation model, make the level Arterials the active level in the Attributes toolbox.

2  Pan to the left and down a bit to the area shown.

3  Set the following Place SmartLine tool settings:
Linear Tasks

Segment Type: Arcs

Vertex Type: Rounded

4 Snap to the end of the existing road on the right (1) and enter a data point.

5 Noting the status bar prompt, move the pointer to the left, and enter a data point half way between the two roads (2).

This is the arc’s center. For precision you can snap to the (yellow) boundary line that runs between the roads.

6 Sweep the arc around counter clockwise, snap to the road on the left (3) and enter a data point to connect.

7 Reset.

Place Stream Line String

Use this tool to trace images when digitizing. You can define many vertices without entering many individual data points.

To use it, select the tool, enter a data point to define the origin, and then move the pointer. A stream of data points is placed without entering a data point. Reset to end the line string.

Canal extended using Place Stream Line String
Construct Minimum Distance Line

Use this tool to construct a line between two elements at their closest points.

To use it, select the tool, enter a data point to identify the first element and then another to identify the second element. Enter a data point to accept.

Construct Line at Active Angle

The active angle is used with tools that require an angle specification, including Place Line, Place Active Cell, Place Text, Rotate, and Construct Array. So, if you place a line at 90 degrees, any other element that has Active Angle in its tool settings will be placed at a 90 degree angle unless you change the Active Angle again.

Use this tool to construct a line, at the angle that is active in the file, that intersects another line segment or a shape.

There are two methods. Using from Point, the intersection is defined when the element being intersected is selected (first data point). Using To Point, the intersection is defined by the second data point.

AA indicates the active angle, 1 is the first data point and 2 is the second
On the left, you see From Point, on the right you see To Point
Place Freehand Sketch

If you open the Linear Elements or Linear Elements Classic toolbox by selecting Tools > Base Geometry > Linear Elements, you will find this tool. Use it to draw a freehand line.

To use it, select the tool, enter a data point to define the origin, and then move the pointer with the data button pressed. Release the mouse button when you are done.

Circles Tasks

Use these tools to place ellipses, including circles and arcs. Open the Circles toolbox from the Tasks dialog by right clicking the tools and selecting “Open Circles as Toolbox”.

The Place Arc tool

The Place Arc tool is used to place a circular arc in either a clockwise or counterclockwise direction.

There are three methods by which to place arcs.

- Using Start, Center the arc is constructed by identifying its start point, identifying a center point, and then the sweep angle and direction.
- Using Center, Start the arc is constructed by identifying the point you want at the center, then its start point, and then the sweep angle and direction.

- Using Start, Mid, End the arc is constructed by entering three data points defining its start, a middle, and end.

- Using Start, End, Mid the arc is constructed by entering three data points defining its start, end, and the middle.

**Exercise: Use Place Arc to connect roads**

1. Continuing in the Element Creation model, Pan down to the area shown.

2. Select Place Arc.

3. Select the Start, Mid, End method.

4. Following the status bar prompts, AccuSnap to the end of the upper roadway (1), enter a data point midway between the two roadways (2), and then AccuSnap to the end of the lower roadway (3).
The Place Circle tool

Circles can be placed using different methods. Since a circle is a closed object, it can be filled with a solid color or a gradient of colors.

There are three methods by which to place circles.

- Position them by defining their Center and then create the circle dynamically. When you do this, you can see the diameter change dynamically in the tool settings’ Diameter field.

- Position them by Edge, defining three points on the circumference. After you enter the second data point, a guide line appears and you can see the size dynamically. You can also see the diameter change dynamically in the tool settings’ Diameter field.

- Using the Diameter Method, you use two data points to establish the diameter dynamically.

You can place a circle by diameter another way. Check the Diameter check box and type the diameter into the input field. Use the Center Method and enter one data point to place the circle, o, use the Edge Method and two data points.
Polygons Tasks

These tools let you create a variety of planar shapes. Open the Polygons toolbox from the Tasks dialog by right clicking the tools and selecting “Open Polygons as Toolbox”.

Place Block and Place Regular Polygon are the most useful of these tools as the Place SmartLine tool can produce the same geometry as Place Shape and Place Orthogonal Shape. Since polygons are closed elements, they can be filled with color.

⇒ Exercise: Turn on levels and rotate the view for easier element placement

1. Continuing in the Element Creation model, turn Fill back on in the Attributes dialog.

   Press Ctrl + B or select the tool from the View ToolBox.

2. Select Fit View from the View toolbox, and then select File > Save Settings from the main menu bar so the fill will be on the next time you enter the model.

3. Zoom In to the area indicated.

4. Select Rotate View, with the following tool setting:
Circles Tasks

**Method: 2 Points**

5 AccuSnap to the upper right corner of the golf club and enter a data point.

![Diagram 1](image1)

6 AccuSnap to the lower right corner and enter a data point.

![Diagram 2](image2)

The view rotates so that it is aligned with the golf club.

The Place Block tool

Place Block places a square or rectangular shape.

![Place Block icons](image3)

Using the Orthogonal method, the block is orthogonal to the view in which the first data point is entered. Using the Rotated method, orientation is defined with a data point.

→ **Exercise: Use Place Block to enlarge the golf club**

1 Continuing in the Element Creation model, with the pointer over the golf club, press and hold the Alt key on the keyboard, and then left click to set the active attributes to those of the element.
Note the change in the Attributes toolbox.

2 Select Place Block from the Tasks dialog.

You see that the attributes in the tool settings are set correctly from the match operation.

3 Set the following tool setting:

   Method: Orthogonal

4 Following the status bar prompt, AccuSnap to the upper left corner of the golf club and enter a data point.

5 Move the pointer upward and note the AccuDraw window at the bottom of the application window.

   As the pointer moves, the values in the X and Y fields changes.

6 Type 300 into the Y field.

7 Move the pointer to the right, type 200 in the AccuDraw window, and enter a data point.

8 Accept with a data point.

**Place Regular Polygon**

This tool is used to place a regular polygon, a shape with equal length sides and equal angles at each vertex. For example, a square is a four-sided regular polygon.
Exercise: Use Place Regular Polygon to add a school

1. Continuing in the Element Creation model, select Place Regular Polygon from the Tasks dialog.

2. Set the following tool settings:
   - **Method**: Inscribed
   - **Edges**: 6
   - **Radius**: 0
   - **Area**: Solid
   - **Fill Type**: Opaque
   - **Fill Color**: 127

3. Set the following in the Attributes toolbox:
   - **Level**: Sch prop__Sep
   - Style and Weight remain the same

4. Following the status bar prompt, enter a data point to place the center point of the regular polygon, as indicated.

   As you move the pointer, the polygon spins.

5. Rotate the polygon so that an edge is parallel with the street and size it so it fits in the area.

6. Enter a data point to complete.

7. Select Rotate View, with the following tool setting:
   - **Method**: Unrotated

   **Hint**: View Previous can also be used to return to the view to its original orientation.
Complex Chains, Shapes and Regions

Some groupings in MicroStation, such as a set of selected elements, are temporary. Other groupings are more persistent.

The Groups toolbox contains tools that are used to create and manipulate more permanent element groups.

Groups tools from the Main toolbox and the Groups toolbox

The Create Complex Shape tool

The Create Complex Shape tool is similar to Create Complex Chain, except the resulting element is closed rather than open. The same tool options are available for both tools, but Create Complex Shape also has options for controlling the fill attributes of the closed shape.

In the next exercise, you will use the boundaries of existing areas to create a complex shape.

=> Exercise: Create a park using a complex shape

1  Continuing in the Element Creation model, Fit View and then Zoom In to the area indicated.

2  Set the following in the Attributes toolbox:

   Level: park - outside
Circles Tasks

*Color, Style and Weight: ByLevel*

3 Select Create Complex Shape, with the following tool settings:

*Method*: Manual

*Area*: Solid

*Fill Type*: Opaque

4 Following the status bar prompt, click on the roadway as indicated, and accept with a data point.

5 Continue entering data points to add the next elements, working around the area enclosed by the roads.

6 Enter a data point to complete the complex shape.

You have created the park, but there is another way to do this.

7 Select *Edit > Undo*. 
8 Change the following tool setting:

   Method: Automatic

   Max gap: 0

   The Max Gap option sets the largest distance allowed between consecutive elements, if Method is Automatic. If it is set to zero, only elements that connect can be added.

9 Enter a data point on the roadway where you began previously, and then enter a data point inside the area.

   Note the status bar. A road segment highlights, but it is the wrong one.

10 Reset.

11 Enter data points inside the area enclosed by the roads until the complex shape is formed. Reset every time you encounter a fork and an undesired element is highlighted.

The Complex Chain tool

   Similar to the Create Complex Shape tool, use the Create Complex Chain tool to combine existing elements into a continuous open ended element.

The Create Region tool

   Create Region creates a complex shape from two or more existing elements. It generates a shape by comparing the relationship between the elements. You can create regions from the difference between elements, the intersection of elements, the area that is the union of elements, or by identifying an enclosed area, which is called by flood.
When Keep Original is checked in the tool settings, you create a new shape and leave the original elements in place. When unchecked, the elements used as components in creating the new shape are deleted.

In the next exercise redline modifications require you to create a new park.

**Exercise: Create a region to extend the park**

1. Continuing in the Element Creation model, select Create Region, with the following tool settings:

   ![Tool Settings](image)

   - **Method** (icon): Flood
   - **Fill Type**: Opaque
   - **Ignore Interior Shapes** (icon): Enabled

2. Enter a data point in the area above the new park.

   The shape boundary highlights.

3. Enter another data point to accept the shape.

4. Fit View.
Undo, Redo, and Delete

You can eliminate a design error by returning to the state in which the design existed before you made it. The Undo command lets you reverse the last design or modification action.

MicroStation provides a sequential unlimited undo buffer that lets you recover from a graphical mistake, such as drawing a line in the wrong location. There is no limit to the number of undo operations you can perform within a design session. However, if the file is closed or compressed, the undo buffer is cleared.

To undo the last design operation, press Ctrl + Z, select Undo from the Edit menu, or open the Tools > Standard toolbox and click the Undo tool.

One way to address a mistake is to reverse it, another is to delete it. The Delete tool lets you remove an element from the file. Click the tool; it has no tool settings, and then click the element you want to delete.

Element templates

Another way to apply element attributes is by using an element template.

An element template defines properties of elements. It stores multiple element properties. You can set general properties such as level, color, line style, and line weight; closed element properties such as area and fill color; and many other properties. Once an administrator sets up templates, you can apply them to existing elements or use them to create elements.

The first tool in the Attributes toolbox is the Active Element Template tool. Selecting an element template will activate the settings stored in the template. The tool tip shows you the active template.

When attributes are set this way you have the ability to link the attributes to the elements that are placed using them. If you do this the elements’ attributes will update if the template definition is updated.
Working with Cells

Exercise: Change the active attributes using an element template

1. Continuing in the Element Creation model, take note of the attributes that are currently active in the Attributes toolbox.
2. In the Attributes toolbox, click the arrow next to the Active Element Template tool.
3. Expand “Example Template Group” by clicking the +. The available element templates are listed in a hierarchy.
4. Click on Template A. The template is set and the active attributes change.
5. Click on Template B. The attributes change once again.

Working with Cells

Cells are complex elements that group multiple elements permanently. You save these groupings to represent symbols that are used often. You can then place them into designs without recreating the symbol each time. Cells can be made from any element or combination of elements.

A specific series of steps is required to use cells in a design file. First, you must attach the file in which the cells are saved, and then you can place the available cells.
Exercise: Attach a cell library

1. Continuing in the Element Creation model, select Element > Cells from the main menu bar.
2. From the Cell Library dialog’s File menu, select Attach File.
   You can attach a single file containing cells or you can attach an entire folder that contains files that have cells in them.
3. In the Attach dialog, click the “Look in” field and navigate to \Projects\Examples\Geospatial\cell, select Geospatial.CEL, and then click Open.

The cells in the library populate the dialog.

Placing cells in designs

The cell library is now attached to the design file. You can place any of the cells stored in this library in the design using tools in the Cells toolbox. Access the tools or open the toolbox from the Tasks dialog.

Exercise: Placing a cell that represents a boat ramp

1. Continuing in the Element Creation model, Zoom In to the area indicated.

2. In the Cells dialog, click on the cell named BOAT in the list of cells.
   Above the preview window, change the Display option to Smooth Shading. Note the preview of the cell.
3  Click the Placement button.
   This makes the selected cell active.
4  Close the Cell Library dialog.
5  Select Place Active Cell from the Tasks dialog.

6  Extend the tool settings by clicking the arrow at the lower right, and then
    set the following tool settings:

    * **Active Angle**: (type in) 70
    * **X and Y Scale**: 1.0
    * **True Scale**: Checked

    **Hint**: You can use the arrows next to the tool settings Active Angle field to set
    the angle to predefined values.

7  Enter a data point on the side of the lake to place the cell, and then Reset.

8  Select Element Selection and set the following tool settings:

    * **Method**: Individual
    * **Mode**: New

9  Click on the cell to select it, and, in the Attributes toolbox, change the
    color to 6 (orange).

10 Click in the view to release the cell.
Placing cells that already exist in a design

Use Select And Place Cell to identify a cell in the DGN file and place an additional instance of that cell.

Exercise: Place a shop near the boat ramp

1. Continuing in the Element Creation model, select Select and Place Cell from the Tasks dialog.

2. Set the following tool settings:
   - Active Angle: 0
   - X and Y Scale: 1.0

3. Enter a data point on the cell named SHOP at Market Plaza.
   Hint: AccuSnap’s pop-up information shows the name of a cell.

4. Enter a data point above the boat ramp to place a second instance.

5. Reset.

6. Select the new cell using Element Selection.

7. In the Attributes toolbox, change the color to 6 (orange).

8. Click in the view to release the element.

True Scale

MicroStation uses working units to accommodate different systems of measurement. When working units differ between files, the relationships must be determined and then cells scaled accordingly.

When placing a cell that was created in a file that has different working units than the active file, you can make the cell scale properly at the time of placement by enabling True Scale in the tool settings. True Scale aligns the units in the cell, one to one, with the units in the active design.
For example, if a cell was created using feet and inches, but the working units in the active file are Metric, the cell will be the wrong size. True Scale reads the units in which the cell was created and adjusts the scale based on the active design’s working units.

It is a best practice to have True Scale on when placing cells. If there is any question, consult your administrator.

Creating cells

When administrators create a cell, they define an origin for the cell. This is the location by which the cell is placed. They also set the cell type; graphic, point, or menu.

Graphic cells

The color, line style, and line weight of a graphic cell are determined when it is created. A graphic cell rotates when a view is rotated. A graphic cell is always placed using the color, weight and style with which it was created. You can also snap to any element in the cell once it has been placed.

However, if cells are created using ByLevel attributes and then placed into a design that has the same level name but that level has different attributes assigned to it, the cell will reflect those attributes. The cell will not look the same as it was originally created.

Point cells

An active point is used as a reference, or monument, point in a design. It can consist of a cell from the attached cell library, a text character, a symbol, or a line with no length.

Point cells take on the attributes that are active when the cell is placed. If color 6 is the active color, the cell is placed using color 6, as well as the currently active line style, weight, and level. A point cell includes only one point that you can snap to, the cell’s origin. Point cells do not rotate when a view is rotated. A point cell can be especially useful for adding text that you want to remain stationary in a design. To place a point cell, select the Place Active Point tool from the Linear tasks. Click the magnifying glass next to the Cell field to open the Cell Library dialog. Select a cell and click the Point button. Enter a data point to place the cell.
A DGN file can also be attached as a cell library. Each model in the file that was created with the “Can be placed as a cell” check box checked will be listed in the Cell Library dialog.

**Exercise: Create a cell**

2. Select Element Selection and select the elements that make up the North arrow.
4. Enter a data point on the selected elements.
5. In the Cell Library dialog, click the Create button and type the following, and then click Create:
   
   Name: North Arrow
   
   The cell is added to the library.
6. Select Define Cell Origin to remove the origin point.
7. Reset and click the Clear icon to release the elements.
8. Fit View.
9. Select File > Save Settings from the main menu bar so the view will be the same the next time you enter the model.

**Replacing cells**

The Replace Cells tool replaces cells using a designated replacement, or updates cells having the same name, using cells from the active cell library.
Working with Cells

It places the origin of the new cell at the same location as the old one, maintaining the original scale and rotation.

To update cells from the active cell library, select the tool and set the Method to Update in the tool settings. Identify the cell to update and accept it. To replace cells individually or globally, select the desired Mode and set the Method to Replace in the tool settings. Identify the cell to replace, identify the replacement cell, and accept.

**Line terminators**

The Place Active Line Terminator tool places a cell at the end of the selected element, rotating the cell to match the angle of the element. It is good for placing arrowheads.

To use it, select the cell, click the Terminate button in the Cell Library dialog, select the tool, and then identify the element.

**Note:** Do not snap to the elements you want to terminate. The tool will find the end point.

**Shared cells**

The first time you place a cell with “Use Shared Cells” checked in the Cell Library dialog, its definition, the elements comprising the cell, are stored in the DGN file one time and if additional instances of the cell are placed the definition is referenced. With an unshared cell, its definition is stored in the DGN file each time the cell is placed.

A cell library does not need to be attached to place more instances of a shared cell. A shared cell can have many instances in a DGN file, but has only one definition. This keeps the size of the file smaller. When a shared cell instance is replaced using the Replace Cells tool, all instances of the cell will be replaced.
Precise Element Placement

All engineering drawing applications include tools to help a user select precise coordinate locations in a design, such as the end point of a line or the center of a circle. This operation is called snapping.

AccuSnap

As you have been working, you have seen pop-up information that displays. It is a feature of AccuSnap. When this feature is on, and the pointer is near an element, AccuSnap displays information about the element.

AccuSnap’s main function is to help you select precise locations in a design, such as the end of a line or the center of a circle. This operation is called snapping.

With AccuSnap all you need to do is move the pointer close enough to the point to which you wish to snap. AccuSnap moves to the snap point and stays there until you move the mouse away. A successful snap using AccuSnap displays a bold, yellow X on the snap point. The next data point you enter will be placed at precisely that spot.

Snap modes

You snap to elements to locate the exact point at which you want to place an element, or interact with the element. Snap modes help you get the point you want. The most common snap is the Keypoint snap. It snaps to key points on an element, like the ends of a line or the center of a circle.

With the Keypoint snap mode active, snap points are located using mathematically derived key points. MicroStation uses a keypoint divisor to divide an element into equal parts. For example, a divisor of 2 means that an element is divided into two equal parts, creating three key points; the two end points and the mid point.
Precise Element Placement

Snap modes can be accessed most easily from the Snap Mode button bar, which can be opened by selecting Settings > Snaps > Button Bar or by clicking the snap mode icon in the status bar and selecting Button Bar from the pop-up menu. To set the default snap mode, double click on any available button.

AccuSnap is enabled and Keypoint is the default snap mode

To set a snap mode override for one operation only, single click any available button once. The override snap mode overrides the default snap mode for one snap operation only. When complete, MicroStation returns to the default snap mode.

Keypoint is the default snap, but Center is the override

➔ Exercise: The keypoint snap

1 Open the Snap Modes model.

Hint: Remember, you can always use the view controls to adjust what you see on the screen.

Keypoint lets you snap to element key points like vertices, the center, or the end of a line.

2 Select Place SmartLine.

3 Move the pointer over the (blue) dash-dot line string at the upper left of the design.

As you approach a keypoint, the tentative hint crosshair appears, along with the keypoint snap icon.

The AccuSnap x will appear when the pointer is on the keypoint.

4 Move the pointer to the upper right end of the line string.

5 When the AccuSnap x appears, enter a data point to snap to the location and enter the first vertex.

6 Move the pointer to the intersection of a horizontal and a vertical segment.

7 When the AccuSnap x appears, enter a data point to snap to the location and enter the next vertex.
8. Move the pointer to another intersection of a horizontal and a vertical segment.

9. When the AccuSnap x appears, enter a data point to snap to the location and enter the next vertex.

10. Reset.

**Exercise: Make the midpoint snap the override snap**

1. Continuing in the Snap Modes model, click the Active Snap icon in the status bar and select Button Bar from the menu.

2. Dock the Button Bar at the bottom of the application window.

3. Select Place Block.

4. Click the Mid Point snap once in the Snap Mode button bar to override the active keypoint snap mode.

   ![Snap Mode Button Bar](image)

   This mode snaps to the midpoint of the segment closest to the pointer.

5. Move the pointer over the second element, the line.

   The tentative crosshair appears at the line’s midpoint along with the midpoint snap icon. As the pointer approaches the midpoint, the AccuSnap x appears.

   ![Line Element with Midpoint Snap](image)
Precise Element Placement

6 Enter a data point to snap to the point and start the block.
   You can see in the Button Bar that the midpoint snap override is no longer
   active and the keypoint snap is the active snap mode again.

7 Reset.

8 Click the midpoint snap once.

9 Move the pointer to the next element, the arc.

10 When AccuSnap identifies the midpoint of the arc, enter a data point.
    You can see on the Button Bar that the snap mode returns to keypoint.

11 Reset.

→ Exercise: AccuSnap and the center snap

1 Continuing in the Snap Modes model, set the center snap as the override
   snap.

2 Move the pointer over the next element, the circle.
   AccuSnap snaps to the center point of the circle.

3 Enter a data point.

Note: If you were still in keypoint snap mode, AccuSnap would still find the
   center of the circle. The center of a circle is also a keypoint.

4 Set the center snap as the override snap by clicking twice.
   Center snap is useful for finding the center point of an arc.

5 Move the pointer to the arc.
   The AccuSnap x moves to the center of the arc.

6 Enter a data point.

7 Reset.

→ Exercise: AccuSnap and the intersection snap

1 Continuing in the Snap Modes model, select Place Circle, with the
   following tool settings:

   Method: Center
   Diameter: Unchecked

2 Change the active snap mode to intersection.
Intersection snap calculates the intersection of elements.

3 Move the pointer over the point where the two lines intersect.

The two intersecting lines are highlighted and one is dashed. The dashed element is the one to which you will snap.

4 Enter a data point to accept the intersection as the center point of the circle.

5 Enter a data point to place a circle.

6 Reset.

**Tips and Tricks**

- You can match any color anywhere with the eye dropper tool. Find it on the True Color (second) tab of the color picker, opened from the Attributes toolbox. Match any color anywhere on your desktop by simply dragging it over the item.

- You can change the color that elements highlight on a per-design file basis. Select *Settings > Design File* and select the Color category in the Design File Settings dialog. Set Element Highlight Color or Selection Set Color to whatever you want. Drawing Pointer Color affects the color of the Element Selection arrow circle.

- You can also set the Active Angle by selecting *Utilities > Key-in*, typing ACTIVE ANGLE PT2 in the field at the top, and then entering two data points to define the angle. Use ACTIVE ANGLE PT3 to set by 3 points.

- If you want to change regular cells in a DGN file to shared cells, save the file to the DWG format. To do this, just select *File > Save As* and set the Save as type to Autodesk(R) DWG Files (*.dwg). Click Save.

**Module Assessment**

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.
Module Assessment

Complete the assessment to see what you have gained from reviewing this module.

Element Creation Assessment
Using AccuDraw for Precision

Module Overview

AccuDraw is more than a precise way to create element geometry. It lets you produce complex geometry quickly.

Module Prerequisites

- Fundamental knowledge of the Microsoft Windows operating system
- Knowledge of MicroStation’s interface
- Some knowledge about MicroStation design elements
- Knowledge about viewing in MicroStation

Module Objectives

After completing this module, you will be able to:

- Draw with more accuracy and speed
- Use AccuDraw shortcuts and interface components
- Use the calculator to increase design accuracy

Introductory Knowledge

Before you begin this module, let's define what you already know.
Questions

1. List the steps needed to use a MicroStation tool.
2. Name three element creation tools.
3. When do you use the tool settings window?

Answers

1. Select a tool.
   - Adjust the tool settings.
   - Follow the status bar prompts and use the tool.
2. Place SmartLine, Place Circle, Place Block.
3. When you need to change the current tool's operational parameters.

AccuDraw Basics

AccuDraw does not create or manipulate elements, it assists in their creation and manipulation. AccuDraw improves quality and speed by reducing keystrokes and mouse clicks.

Drawing presents graphic problems using a graphic application, but you are traditionally taught to use numeric solutions. AccuDraw is a graphic solution to graphic problems.

Toggle AccuDraw using the AccuDraw icon in the Primary Tools toolbox.

When enabled, AccuDraw has two components, the AccuDraw window, which is docked at the bottom of the application window, and the AccuDraw compass. These two interface elements work with each other.

AccuDraw window and the AccuDraw compass in rectangular mode
The AccuDraw window has two modes that can be toggled using the space bar when AccuDraw is active and has the focus. Rectangular mode lets you enter X and Y distances from AccuDraw's origin. Polar mode lets you enter the distance and angle from the origin.

The compass consists of three components that are visible in either Rectangular or Polar mode.

The origin is the center of the compass and is always location 0,0 regardless of where the compass is in the design (a relative origin).

The rectangle or circle is referred to as the drawing plane indicator and it shows you the drawing plane that AccuDraw is on; Rectangular or Polar.

The heavier weight green and red ticks are AccuDraw's axis markers and are completely independent of both the drawing axis and the view axis.

The AccuDraw workflow

AccuDraw considers the location of the pointer with respect to its origin. As you move the pointer around the compass, AccuDraw updates the X and Y values in the AccuDraw window’s key-in fields to reflect the distance the pointer is from its origin.

AccuDraw considers and interprets keyboard shortcuts. These are keyboard character key-ins to drive its behavior. An example is using the space bar to toggle between the Rectangular and Polar modes.

When the mouse moves, AccuDraw tracks the pointer's location in relationship to the AccuDraw compass. The operational steps for AccuDraw are as follows.

1. Enter a data point to fix the location of the compass.

2. Move the pointer in the direction in which you wish to draw.

3. Without using the pointer to put focus into the AccuDraw window’s key-in fields, enter the desired distance value.

4. <Optional> Move in another direction.

5. <Optional> Enter another distance value.
6. Enter a data point to accept.

7. Repeat from step 2 to continue drawing.

You know the direction in which you need to draw by looking at your notes and plans. Focus on the direction in which you want to draw, not the X or Y dimension. The X and Y dimensions are useful, but when drawing they should not be the focus.

**The input focus**

As you move the pointer, AccuDraw continually updates the field that is currently active in the AccuDraw window. It is indicated by the highlighted field title. AccuDraw’s input focus lets you enter values wherever the insertion bar is highlighted.

If the pointer’s movement away from the previous data point includes a higher X value than the Y value, the X field will have the input focus. If the pointer’s movement away from the previous data point includes a higher Y value than the X value, the Y field will have the input focus.

Once a field has input focus, the input field becomes auto-overwrite and auto-enter. You do not have to highlight or click in the fields, or press the Enter key.

**AccuDraw indexing**

AccuDraw can index to axes, the origin, and the previous distance. The indexing feature works like AccuSnap. When you get close to an indexing state, the pointer temporarily locks on to that state. For example, when the pointer nears a 90 degree angle to the origin of the compass it will index to that angle.
Exercise: Observe AccuDraw indexing

1. Open the Precision Input with AccuDraw, description, Essentials geometry, model.

2. Select Place SmartLine from the Tasks dialog, with the following tool settings:
   - **Segment Type**: Lines
   - **Vertex Type**: Sharp

3. Following the status bar prompt, enter a data point to start the first vertex.

   ![Not indexed to the axis](image)

4. Move the pointer slowly toward the X-axis.
   Once you are within 10 pixels, the line will move to, and stay on, the X-axis.

5. Move the pointer toward the Y-axis.

6. Move the pointer near the AccuDraw origin.

   ![Not indexed to the AccuDraw Origin](image)

   ![Indexed to the AccuDraw Origin. Note X & Y=0](image)
7 Enter a data point and move perpendicular until you are close to the distance of the first segment.

---

**First segment drawn**

---

The second segment shows the previous distance with a short T-line

Note that distances are equal for both segments

---

**Drawing with AccuDraw**

Your next task is to draw the following object using AccuDraw and the Place SmartLine tool. You will start at the lower left and move in a counter-clockwise direction.

---

**Exercise: Draw the shape using AccuDraw**

1 Continuing in the Precision Input with AccuDraw model, select Place SmartLine, with the following tool setting:
Join Elements: Checked

2 Following the status bar prompt, enter a data point anywhere to start.
This is the first vertex of the element and the AccuDraw compass appears at the data point location.

3 Move the pointer to the right, lining up with the X-axis.

This is called indexing. When you type in a value it will automatically appear in the AccuDraw window’s X field.

4 Without moving the pointer into the AccuDraw window, type 2000 on the keyboard.

5 Enter a data point to accept the value.
Note that the compass moves to the last data point.

6 Move the pointer upward and line up with, or index to, the Y-axis.
7  Type 1500 and accept with a data point.

8  Move the pointer to the left and index to the X-axis.

9  Type 1000 and accept with a data point.

10 Move the pointer downward and index to the Y-axis.
11. Type 750 and enter a data point to accept.

12. Move the pointer to the left, index to the X-axis, type 1000, and accept with a data point.

13. Move the pointer downward, index to the Y-axis, type 750, and accept with a data point to close the shape.

Note: Keep the mouse steady. If you move the mouse around too much indexing is lost.

**Locking coordinate values**

When you type a value on the keyboard, AccuDraw locks the current input field and immediately affects the pointer’s motion because it knows you are entering coordinate data.
AccuDraw Shortcuts

After typing a value in the first field, move the pointer until the input focus changes to the other field and you can type the other value. The coordinates you have entered establish a point for the placement of the element.

AccuDraw Shortcuts

AccuDraw’s behavior is influenced by the current tool, the location of the pointer, and keyboard shortcuts. AccuDraw anticipates your next move. Sometimes, however, you will want to direct AccuDraw, so there are a variety of single and double character command directives known as the shortcut key-ins. By pressing the appropriate key while focus is in the AccuDraw window you can direct AccuDraw to perform a specific task.

In MicroStation, different dialog boxes have the focus at different times. Which one has it is indicated by an icon at the extreme right of the status bar.

- When the focus is home, you don’t need the mouse to navigate toolboxes, tasks, and the tool settings window: You can select tools by pressing keys on your keyboard. This technique is called positional keyboard navigation. To move focus Home, press the Esc key. The home icon will display.

See the Help topics “Getting Started -> Keyboard Input -> Controlling the focus” and “Getting Started -> Keyboard Input -> Using positional keyboard navigation” if you want to use this method.

- When you see this icon, the tool settings window has the focus.
• When you see this icon, the key-in window has the focus.

The AccuDraw shortcuts only work when the AccuDraw window has the focus. When it does, the AccuDraw symbol is displayed. Press the Esc key and then the space bar, or click in the AccuDraw window to move the focus there. If you are using the default function key menu delivered with MicroStation, you can press the F11 key.

Finding the shortcuts

To open a window showing a list of all AccuDraw shortcuts, press the ? key. This is the only shortcut you need to memorize, since it will show you all the rest.

→ Exercise: Focus and the ? shortcut

1 Continuing in the Precision Input with AccuDraw model, select Place SmartLine.
   
   Check the status bar and note that focus remains at home.

2 Press F11 to shift the focus to AccuDraw.

3 Press the ? key and expand the AccuDraw Shortcuts window.

4 Return focus to the AccuDraw window by pressing F11.

5 Press G then T, <GT>, to move focus to the tool settings window.

Note: The focus can be moved to the tool settings window by pressing F10.

Often used shortcuts

Get familiar with the following shortcuts as they are used regularly.

Space Bar = Change display mode

The space bar toggles between Rectangular and Polar mode.
X = toggle X lock, Y = toggle Y lock

The <X> or <Y> keys can be selected at any time to lock or unlock the present X or Y values when in Rectangular mode. A field is locked when its icon label is depressed.

D = toggle Distance lock, A = toggle Angle lock

<D> or <A> can be selected to lock or unlock the Distance or Angle values in Polar mode.

Enter = Smart Lock

Smart Lock will index to the closest axis and lock the opposite field value. For example, if the X value is indexed, the Y value will be locked at 0. This lets you draw in one direction but snap to objects in the other direction. In Polar mode, if Distance is active, the Angle will be locked.

Q = Quit

Press <Q> to quit AccuDraw.

V = View rotation

Press <V> to rotate the compass to align with the view axis. This is especially useful when working with rotated views.

O = Set Origin

Pressing <O> moves the compass to the current pointer position or a tentative point. This is very helpful when combined with AccuSnap.

You can place the AccuDraw origin at a tentative point. By snapping to a point and then pressing <O>, you can place the AccuDraw origin at that point. Do not accept the tentative point, just tentative snap and press <O>. When using this technique it is important NOT to accept the tentative snap.

RQ = Rotate Quick

<R><Q> temporarily changes the rotation of the compass to a user defined angle. Once a data point has been entered, the compass resumes its normal orientation.
I = Intersect Snap

Activates Intersect snap mode.

C = Center Snap

Activates Center snap mode.

In the following exercise you will place a rotated block at the same angle as an existing line. You will draw the rotated block based on the line.

Without using AccuDraw, you would measure the angle, create a construction line for the offset distance, and then place the block. AccuDraw provides shortcuts such as the <O> and <R><Q> shortcuts, which can save time.

**Exercise: Place a rotated block using AccuDraw**

1. Continuing in the AccuDraw model, select Place SmartLine.
2. Place a line at any angle. The length of the line is not important.
3. Select the Place Block tool from the Tasks dialog with the following tool settings:
   
   *Method*: Orthogonal
   
   *Area*: Solid
   
   *Fill Type*: None

4. Snap to the upper right end of the line and, with focus in the AccuDraw window, press <O> for Origin. DO NOT enter a data point to accept the snap point.

![AccuDraw Origin placed at snap point](image-url)
AccuDraw Shortcuts

5. Press <RQ> to Rotate Quick.

6. Note the prompt in the status bar.
   The Rotate Quick shortcut requires you to define the X-axis.

7. Move the pointer towards the other end of the line and AccuSnap to the end. Enter a data point at this location.

   The compass has rotated to the angle of the line.

8. Note that you have returned to the Place Block tool.

9. Move the pointer along the X-axis and toward the right and index to the negative X-axis, while keeping the Y value zero. Type a value of 1000 units.

10. Accept with a data point.
Note that the direction, up and to the right, not the dimension, -X, is the important thing to think about in the previous step.

You have now placed the first corner point of the block. It is rotated even though the Method was set to Orthogonal.

11 Move in the X direction and type a value of 750.

12 Move in the Y direction and type a value of 1000.

13 Enter a data point to accept the 750mm by 1000mm block.

Note: Remember that you want to establish direction, and then distance.

In the next exercise, you will draw an oval shaped element around a rectangle. The only information you have is the minimum clearance distance from the rectangle.
AccuDraw Shortcuts

➤ Exercise: Place the rectangle

1. Continuing in the Precision Input with AccuDraw model, select the Place Block, with the following tool settings:

   Method: Orthogonal
   Area: Solid
   Fill Type: None

2. Following the status bar prompt, place a vertical block of any size.

➤ Exercise: Place the oval using AccuDraw

1. Select Place SmartLine.

   Read the status bar prompt and note that MicroStation requires a data point to define the first vertex. The first vertex will be offset from the top right corner of the block.

2. Move the pointer to the top right corner until you see the AccuSnap X.

3. With the focus in the AccuDraw window, press <O> to move the AccuDraw compass to this location.

4. Index along the X-axis and type a distance that is appropriate for the current zoom level.
5. Following the status bar prompt, enter a data point to place the first vertex of the SmartLine.

![Diagram of SmartLine setup]

6. Move the pointer downward and press Enter to lock the axis.

   \[\text{SmartLock indexed to the nearest axis and locked } X \text{ at 0}\]

7. Snap to the lower right corner of the block and enter a data point.

   This establishes the length of the line segment.

   \[\text{Dashed line indicates that } X \text{ is locked at 0}\]

You graphically found the length of the rectangle.
8 With focus in the AccuDraw window, press the <~> key to change the Segment Type from Lines to Arcs.

The status bar indicates that you need to define the location of the arc center.

9 Move the pointer to the midpoint of the block’s lower edge and enter a data point when you see the AccuSnap X.

This becomes the center of the arc.

Next, you need to define the sweep angle of the arc.

10 Move the pointer clockwise and sweep through 180 degrees. Enter a data point to accept the sweep.

*AccuDraw indexing makes 90 degree increments easy to draw*
11 Press the <~> key to change the Segment Type to Lines.

12 Move the pointer up to the top of the view and press <Enter> to 
SmartLock.

13 Snap to the upper left corner of the rectangle and enter a data point to fix 
the length of the line segment.

14 With focus on the AccuDraw window, press <~>to change the Segment 
Type to Arc.

15 Following the status bar prompt, snap to the mid-point of the top of the 
rectangle.
16 Enter a data point to accept this as the location for the center of the arc.

17 Move the pointer clockwise to draw the 180 degree arc and complete the oval.

The Pop-up Calculator

The pop-up calculator lets you perform mathematical operations. Activated it by pressing +, -, *, /, = in AccuDraw’s key-in fields and fields such as Angle or Scale.
Using the pop-up calculator

You can invoke the pop-up calculator in two different modes. The first method applies the mathematical expression to the existing value displayed in the field with focus. To activate this mode, press either <+>,< ->, <*> or </>.

The second mode is activated by the <=> key and replaces the existing value with the results of a keyed expression or calculation. In this mode, the result dynamically updates in the original field, rather than having a field of its own in the pop-up. This feature is usually used for expressions that are more complex.

Let’s see how you might use MicroStation’s pop-up calculator in everyday drawing tasks.

**Optional Exercise: Use the pop-up calculator**

1. Continuing in the Precision Input with AccuDraw model, select Place SmartLine, with the following tool setting:
   
   **Segment Type**: Lines

2. Following the status bar prompt, place the first vertex anywhere in the view.

3. Index to the X-axis and press <Enter> to SmartLock.

4. Type 1500 in the X field.

5. Press the / key to open the pop-up calculator in the division function.
Tips and Tricks

6  Type 7 into the calculator field.

7  Enter a data point to accept the second vertex.

8  Index to the Y-axis.

9  Type 750 into the Y field.

10 Press the <*> key to open the pop-up calculator in the multiplication function.

11 Type 1.375 into the calculator field and accept the resulting value with a data point.

Tips and Tricks

You can change AccuDraw to use N and E (Northing/Easting). Select Utilities > Key-in to open the Key-in browser. Type ACCUDRAW SETTINGS NORTHEAST and press Enter. To switch back to X/Y, type ACCUDRAW SETTINGS XY.

Remember that there is more than one way to move the focus to the AccuDraw window. You can move the focus by pressing the space bar, or if you are using the default function key menu delivered with MicroStation, you can press the F11 key.
Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

Using AccuDraw for Precision Assessment

- Mastery Exercise: Use AccuDraw to create shapes
  1. Draw the following figures using AccuDraw and the Place SmartLine tool.
  2. Close the file when you are done.
Working with Existing Elements

Module Overview

Existing elements often need to be modified. You may need to move or copy them, or you may need to extend or trim. MicroStation provides many tools to help you manipulate and modify existing elements. You can group multiple elements for manipulation and modification.

Module Prerequisites

- Knowledge of MicroStation’s interface
- Some knowledge about MicroStation design elements
- Knowledge about viewing in MicroStation
- Knowledge about AccuDraw
- Knowledge about element attributes
- Knowledge about MicroStation tool usage

Module Objectives

After completing this module, you will be able to:

- Use manipulation and modification tools to change a design
- Use Element Selection to work with multiple elements and obtain information about those elements
- Make measurements
- Use patterns to add definition to elements
Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1. In the Level Display dialog, how can you tell which is the active level?
2. Name two ways to change the active level.
3. Which toolbox is used to select general usage element selection, manipulation, and modification tools?

Answers

1. It is highlighted with a different color.
2. In the Attributes toolbox, or double click on the level name in the Level Manager or Level Display dialog.
3. The Main toolbox.

Basic Manipulation Tools

The tools in the Manipulate toolbox are used to copy, move, resize, and otherwise manipulate existing elements. The Manipulate toolbox can be accessed from the Main toolbox.

Manipulate tools from the Main toolbox and the Manipulate toolbox
In addition, several manipulation tools are available from the reset menu that opens when you press and hold the right mouse button.

**Move Element**

The Move Element tool is used to move elements from one location to another. After you select the tool, you use two data points. One to select the element, and a second to identify the new location.

**Copy**

This tool requires one data point to select the element and a second one that defines both the distance and direction to copy. The Copies option in the tool settings lets you specify how many copies to make. Using this method, one data point will result in multiple copies, similar to an array. The copies will be placed in the direction of the data point and the same distance from it.

**Hint:** For precise placement snap a specific point, such as a center point, on the original element. AccuDraw can be used to space the copies accurately.

**Exercise: Copy a chair**

1. Open the model named Work with Existing Elements, description, Essentials geometry.
2. Open View 2.
3. Select Copy from the Main toolbox or Manipulate toolbox, with the following tool setting:
   
   **Copies:** 2

4. Identify the chair on the left side of the table with a data point. A dynamic copy is attached to the pointer.
5. Place a second chair next to the first. The third chair is added automatically.
When you create multiple copies, they are spaced using the distance from the original element to the data point. They are placed in the direction in which the data point is entered.

6  Reset.

**Mirror**

The Mirror tool is used when you want to mirror elements about the horizontal, the vertical, or a user-defined line. The tool settings offer additional options so you can make a copy of the original element or mirror the elements about their own centers.

Let’s take a look at the mirror options.
• Mirror About Horizontal mirrors the element with respect to the X-axis. The mirrored element changes vertically, top to bottom or bottom to top.

• Mirror About Vertical mirrors the element with respect to the y-axis. The mirrored element changes horizontally, left to right or right to left.

• Mirror About Line mirrors the element around a user-defined axis. The mirrored element changes around the defined axis line.

The Mirror tool also has an option to make copies.

⇒ Exercise: Use the mirror tool to add chairs

1  Continuing in the Work with Existing Elements model, select Mirror with the following tool settings:

  Mirror About: Vertical
  Make Copy: Checked
Using this method, the element mirrors with respect to the y-axis, changing horizontally left to right or right to left.

2 Enter a data point on the last chair placed.
   A mirrored copy is attached to the pointer.

3 Enter a data point to place the chair on the other side of the table.

4 Reset.

5 Select Element Selection.

6 Set the following tool settings:
   
   Method (upper icons): Line
   Mode (lower icons): Add

7 Draw a line through the first and second chairs.

8 Right click, press and hold the right mouse button and select Mirror from the pop-up menu.

   Hint: When a toolbox is active, its tools appear at the top of the right click menu.

9 Position the chairs on the other side of the table, enter a data point, and then reset.

10 Click Clear in the Element Selection tool settings.

11 Right click and press on the chair at the head of the table, and select Mirror from the pop-up menu.
12 In the tool settings, change the following:

*Mirror About:* Horizontal

Using this method, the Element mirrors with respect to the x-axis, changing vertically, top to bottom or bottom to top.

13 Enter a data point to copy the chair to the other end of the table, and then reset.

14 Click Clear in the Element Selection tool settings.

**Align Elements by Edge**

This tool makes it easy when you want to align elements to a common edge on another element. A variety of tool settings are available to determine how to align the element and whether the original elements should be copied. Status bar prompts provide instructions about the selection order required to align the elements.

* Exercise: Align misplaced chairs

1 Continuing in the Work with Existing Elements model, select the Move tool.
Basic Manipulation Tools

2 Move two of the three chairs on the left side of the table so they are each a different distance from the table.

3 Select Align Elements by Edge (Align Edges) with the following tool setting:
   Align: Right

4 Following the status bar prompt, enter a data point on the chair that has not been moved.
5 Enter a data point on each moved chair.
6 Enter a data point to accept.
7 Reset.

Move to Contact

The Move to Contact tool is used when you want to move one or more elements in a defined direction until they make contact with another element.
To use it, select the tool and click the element you want to move on the point you want contact to occur. Enter a data point to define the direction you want the element to move.

**Rotate**

The Rotate tool rotates one or more elements based upon options set in the tool settings. For example, elements can be rotated about an active angle, or dynamically by entering either two or three points. The elements can also be copied and rotated about their center, simultaneously.

To use it, select the tool and select a method. If the method is Active Angle, set the angle in the input field. For any method, enter a data point on the element you want to rotate. Enter a data point at the location you want to use as a pivot point. If you are using a by points method, follow the status bar prompt to define the amount of rotation.

➔ **Exercise: Use the rotate tool to position a building**

   
   You must rotate the building to fit it into the site.

2. Select Rotate with the following tool settings:

   ![Tool settings](image)

   - **Method:** Active Angle set to 75.00
   - **Copies:** Unchecked
   - **About Element Center:** Checked

3. Enter a data point on the building.
The building rotates.

4 Enter a data point to accept, and then reset.

5 Select the Move tool.

6 Enter a data point on the building.

7 Move the pointer to the center of the site.

8 Enter a data point to accept, and then reset.

Using the 2 Points method, the angle of rotation is defined by entering two data points; a pivot point and a point to define rotation.
With 3 points, the angle of rotation is defined by three data points; a pivot point, a point to define the angle to start the rotation at, and a point to define the rotation, similar to mirroring about a line.

Check the About Element Center option so that elements are rotated about their center instead of the point where you selected the element.

**Scale**

This tool scales selected elements by an active scale value, or interactively when you enter data points. You can make a copy of the original element during the process. You can scale an element around its center point, or the point at which you select it.

There is a padlock icon to the right of the X Scale and Y Scale fields in the tool settings. If the padlock is unlocked, or open, you can adjust the X Scale and Y Scale factors independently of each other. When the padlock is locked, or closed, adjusting one scale value will adjust the other when you press Tab. The padlock can be locked and unlocked by clicking on it. Many tools have this feature.

**Exercise: Scale and copy trees**

1. Continuing in the Work with Existing Elements model, Zoom In on the tree at the right side of the site.
2. Select Scale, with the following tool settings:
   - **Method:** Active Scale
   - **X and Y Scale:** 0.6667
   - **About Element Center:** Unchecked
   - **Copies:** Checked and set to 1
3. Enter a data point on the tree.
4. Move the pointer downward until the dynamic copy is located below the first tree and enter a data point.
   - A smaller tree is placed.
5 Move the pointer downward again and enter a data point to place a smaller tree.

6 Reset.

Move/Copy Parallel

Use this tool when you want to move or copy an element parallel to the original.

- Modes determine how the gap that is created when you move the element is filled.
  - Miter extends or shortens the element's segments
  - Rounded fills the gaps with arcs
  - Original makes an exact copy

- Element Mode copies entire element.
- Segment of Element copies a continuous line or arc segment.
- Portion of Element copies a user definable section by selecting first and second points on a segment.
• You can check the Keep Original option to keep the original element in place, or uncheck it so you just affect the original.

• When Use Active Attributes is checked, the moved or copied element inherits the file’s active color, weight, and style attributes.

**Exercise: Finish the parking layout**

1. Continuing in the Work with Existing Elements model, pan left to the unfinished area of the parking lot.

Next you will change a design file setting that affects the number of decimal places numbers are displayed with, and then save the setting.

2. Select **Settings > Design File** and, in the Design File Settings dialog, click on the Working Units category on the left.

3. Change the Accuracy option from 0 to 0.1234 and click OK.

4. Now to save this change select **File > Save Settings**.

5. Select Move Parallel, with the following tool settings:

   - **Distance**: Checked
   - **Use Active Attributes**: Unchecked
   - **Keep Original**: Checked

   If Use Active Attributes is checked, the element takes on the attributes that are active in the file. If not, it retains the existing attributes.
In the tool settings, click the Define Dist icon, to the right of the Distance field.

Enter a data point on the last parking stripe, and then on the one next to it.

This calculates the distance between existing elements. You can also key in the distance if you know the value.

Enter a data point on the last parking stripe again.

Now move the pointer upward, entering data points to place additional stripes.

Continue moving the pointer up and entering data points until the last line is placed.

Reset.

The Define Distance icon lets you measure a distance by entering start and end data points. Click the icon and then enter the start and end data points.

**Array**

Use Construct Array when you want to create multiple copies of elements and place them in rectangular, polar, or path based patterns at regularly spaced intervals.

A rectangular array copies elements into a specified number of columns and rows. The spacing between elements can be different for each direction. The amount of spacing is the distance from the center of one element to the center of the next element.

**Exercise: Create an array of seats**

2 Select the Array tool, with the following tool settings:

- **Array Type**: Rectangular
- **Active Angle**: 0
- **Rows**: 4
- **Columns**: 5
- **Row Spacing**: 1
- **Column Spacing**: 2

3 Identify the seat as the element to be arrayed.

4 Enter a data point to accept.

The seats fill the auditorium.

⇒ **Exercise: Create a polar array of spokes**

1 Select Construct Array with the following tool settings:

- **Array Type**: Polar
- **Items**: 12
- **Delta Angle**: 30
- **Rotate Items**: Checked

2 Enter a data point on the spoke in the wheel at the bottom of the view.

3 Select the array center point by snapping to the center of the wheel.

4 Enter a data point to accept.
The Rotate Items check box lets you rotate the elements around the center of the array.

![Image of rotated elements]

The original element is shown first. Next it is shown as an unrotated array, left, and then shown arrayed rotated around the array’s center.

**Note:** A pop-up calculator is built into the Delta Angle field. This lets you, for instance, type in 360/12 to obtain the 30 degree delta angle.

---

**Working with Groups of Elements**

Elements can be manipulated individually or in groups. There are several ways to group elements.

**The Fence**

One method of manipulating multiple elements is to gather them with a fence. This temporary outline around the elements lets you manipulate them together.

The Fence toolbox can be accessed from the Main toolbox or by pressing 2 when the focus is at home.

![Image of Fence toolbox]

*The Fence tools from the Main toolbox and the Fence toolbox*
The Place Fence tool has a variety of options, including the type of fence to place, and controls that determine which elements will be manipulated.

Once a fence has been defined, it can be used with many tools by simply enabling the Use Fence option in the tool settings. The Fence toolbox also contains tools that use a fence once it is defined.

If there is a fence in a file, the fence will be used to process elements; the Use Fence option in various tool settings will be enabled automatically. To dismiss a fence, select the Place Fence tool again or click in an empty area of the view.

**Fence modes**

The Fence Mode option determines whether elements or parts of elements are to be processed by a manipulation tool such as Copy, Move, Rotate and Mirror.

- Inside will process only elements that are completely within the boundary of the fence.

- Overlap processes all elements that either overlap the fence, or those completely within the fence boundary.
Working with Groups of Elements

- Clip processes elements completely within the fence, and portions of elements that overlap the fence.

- Void processes only those elements that are completely outside of the fence boundary.

- Void-Overlap will process those elements that are completely outside or overlapping the fence boundary.

- Void-Clip processes those elements that are completely outside the fence as well as the outside portions of elements that cross or overlap the fence boundary.

⇒ Exercise: Place a fence block around elements

1. Continuing in the Work with Existing Elements model, open View 5.
2. Select Place Fence, with the following tool settings:

   - Fence Type: Block
   - Fence Mode: Inside

This mode affects elements located entirely inside the fence outline.
3 Enter a data point at location 1, at the upper left of the (blue) shaft.
4 Enter a data point at location 2.
   The shaft is enclosed in a fence block.

Fence types

You can draw different types of fences to accommodate the types of elements you are fencing.

- When the Fence Type is Block, Shape, or Circle the fence you draw will be that shape. Using the Circle type, start the circle at the point you want to be the center.

- When the Fence Type is Element you create the fence by identifying a (closed) element.

- When the Fence Type is From View you create the fence by entering a data point in the desired view. All elements visible in it are in the fence.

- When the Fence Type is From File you create a fence that includes the contents of the DGN file.

- When the Fence Type is From Flood you create a fence that includes the area enclosed by elements that you click inside.

Manipulate Fence Contents

This tool lets you manipulate the elements gathered by a fence. The Fence Mode can be set in the tool settings.

Remember though, you can simply enable the Use Fence option with most all manipulation tools.

Exercise: Manipulate the fence contents

1 Select Manipulate Fence Contents, with the following tool settings:

   Operation: Copy (first icon - it looks like the Copy tool)
**Working with Groups of Elements**

*Copies: 1*

*Fence Mode: Inside*

2. Snap to the lower left corner of the (blue) shaft and enter a data point.

This is the origin. An outline of the fenced area moves dynamically with the pointer while the original fence remains in place.

3. Move to the left and enter a data point in an empty area.

4. Reset.

The shaft is the only element copied because it was the only element located completely inside of the fence.

**Exercise: Manipulate elements in a fence shape**

1. Continuing in the Work with Existing Elements model, in View 4, select Place Fence with the following tool settings:

   Fence Type: Shape

   Fence Mode: Overlap

   This mode affects elements entirely inside the fence and also those that are touching the fence outline.

2. Enter a data point at location 3.

3. Enter a data point at location 4, location 5 and location 6.

   No matter what the shape, using this method you can select all the points you want.
4 Click Close in the tool settings.

5 Select Manipulate Fence Contents with the following tool settings:

   ![Tool settings]

   *Operation*: Copy
   *Copies*: 1
   *Fence Mode*: Overlap

6 Snap to the right end of the bottom magenta line on the shaft’s left side.

   ![Diagram showing Snap to right end]

   This point is outside of the fence, but you are working in overlap mode.

7 Snap to the upper part of the corresponding thread in the shaft you copied.

   ![Diagram showing Snap to upper part]
Portions of the thread that overlapped the fence, as well as those inside, were manipulated.

8 Reset.
9 Select Place Fence to dismiss the fence.

→ **Exercise: Scaling a fence circle to create a detail**

1 Continuing in the Work with Existing Elements model, select Place Fence with the following tool settings:

- **Fence Type:** Circle
- **Fence Mode:** Clip

This mode affects elements entirely inside and portions of elements inside the fence outline.

2 Enter a data point at location 1 on the model on the right.

   A circular fence outline appears and moves with the pointer.

3 Enter a data point at location 2.

4 Select Manipulate Fence Contents with the following tool settings:

- **Operation:** Scale (Third icon - looks like the Scale tool)
- **X and Y Scale:** 2.0
- **Copies:** 1
- **Fence Mode:** Clip
**Working with Groups of Elements**

**Hint:** If the padlock next to the X and Y Scale is closed, both fields automatically contain the same value. If you want different X and Y values, click the padlock to open it.

5  Move the pointer until the fence contents are located inside the DETAIL and enter a data point to place the scaled fence contents.

6  Reset.

**Stretch Element**

This tool is in the Manipulate toolbox. Use it when you only want to move those endpoints and vertices that lie within a fence.

This results in the element segments being extended to maintain geometric relationships. Ellipses, circles, and cells remain unaffected unless they are completely inside the fence, in which case they'll be moved.

The tool settings let you define a fence, which eliminates the need to place one in advance. Using this tool, you could place a fence to include a window or door and move the feature along a wall. You can also change the size of the feature by including only the start or end in the fence.

**Named Fences**

When you place a fence with the Place Fence tool, you have the option of saving it as a named fence. Named fences let you store and recall fences with names that you define. To see a list of saved fences in the active model, expand the tool settings. Double click a name to activate the fence.
When a named fence is selected, the fence element highlights. The fences are stored as regular elements that can be manipulated with any of the modification tools.

![Image of fences]

**Note:** If you delete a named fence, only the entry in the named fence list is deleted. The graphics remain in the file. To delete the graphics, use the Delete Element tool.

**Hint:** Check the Settings > Snaps > AccuSnap setting “Enable For Fence Create” so you can use AccuSnap during fence placement.

### The Element Selection tool

The Element Selection tool is used to select multiple elements for processing. When more than one element is selected with this tool, it is referred to as a selection set.

You can select individual elements or multiple elements by using a block, shape, circle or line. Dragging the Selection set tool left to right selects only those elements inside and dragging right to left switches to an overlap mode. You can select the shift key to toggle the both modes. You can invert the selection set, selecting those that are currently selected.

When you select an element using Element Selection, MicroStation displays edit handles at the element’s vertices. Handles are not shown when you select by dragging a rectangle or use the Block, Shape, Circle, or Line selection methods. If the Disable Edit Handles icon on the right is enabled, edit handles are not shown for any selected elements.

**Reviewing and editing**

Extended settings in the tool settings allow you to select elements by one or more attributes such as level, color, line style, line weight, type, and class.
For existing selection sets, the attributes of the selected elements appear in a highlighted group at the top of each tab.

To add elements by attributes to an existing selection set, simply select an attribute that is not highlighted. If an element exists with that attribute, it will be added to the set. To remove elements with specific attributes from the current set, simply select the attribute from the highlighted list at the top of each tab.

**Exercise: Selection by attributes**

2. Select Element Selection with the following tool settings:
   - Method: Individual
   - Mode: New
3. In the expanded tool settings, select the color tab.
4. Scroll to, and click on color 2.
   - All elements that are color 2 are selected.
5. Click on other tabs and note the attributes of the selected element, grouped at the top.
6. Click Clear when you are done.

### Selecting edit handles

Enable Select Handles to show edit handles on the selected elements. This switch can be activated after the elements have been added to the selection set. The Disable Handles icon must be inactive to use Select Handles.

**Exercise: Select handles to extend the road**

1. In the expanded Element Selection tool settings, on the Level tab, and then click on the following levels to select the elements on those levels:
Prop Alignment
Roadway Shoulder

In the status bar, you can see that nine elements are selected.

2. Zoom in on those elements.

3. In the tool settings, click the Select Handles icon.

4. Press and hold the Ctrl key.

5. Click on each of the three handles at the upper construction limit line.

The handles change color.

6. Drag to modify the handles to the lower construction limit line.

Only the elements that are part of the secondary selection set are extended.
7 Disable the Select Edit Handles icon.
   The secondary selection set is disabled, but the original is still active.

8 Click Clear in the tool settings.

→ **Exercise: Add and remove set members by attribute**

1 In the extended Element Selection tool settings, select the Level tab, and then click on Boundary RW to select it.
   The right of way lines are added to the selection set.

2 Select the Color tab.

3 Click on the color 71.
   The blue roadway shoulder elements are added to the set.

4 Select the Line Style tab.

5 Click on style 3.
   The blue roadway shoulder elements are removed from the set.

6 Click Clear to release the selection set.

**Graphic groups**

Graphic groups are collections of elements that can be manipulated together sometimes but separately at other times.

When the Graphic Group lock is enabled, they are treated as a group. When the lock is disabled, all elements are treated individually.

The Graphic Group lock can be toggled by clicking the lock icon on the right side of the status bar and clicking Graphic Group.
Working with Groups of Elements

The Groups toolbox can be accessed from the Main toolbox or by pressing 6 when the focus is at home.

![The Groups tools from the Main toolbox and the Groups toolbox](image)

Creating graphic groups

Use the Add to Graphic Group tool to do the following:

- Create a graphic group.
- Add elements to an existing graphic group.
- Combine two or more existing graphic groups into a single graphic group.

To use it, select the tool and follow the status bar prompts to add elements to the group. Turn the Graphic Group lock on to work with the group and turn it off to work with the elements individually.

**Hint:** Selection sets can be used to create graphic groups and named groups.

Named Groups

Named groups are the most flexible method for grouping elements. When an element is part of a named group it is referred to as a member. Named group options allow you to define how members will respond when manipulated or selected.

**Exercise: Create a named group**

1. Open the model named Survey.
2 Select Add to Graphic Group.

3 Click Create New Named Group in the tool settings.

4 In the Create Named Group dialog, enter the name Building Info.
   The description is optional.
   Leave the Select all members when any member selected check box unchecked. If this check box is checked, when one element in the named group is selected using the Element Selection tool, all members will be selected.

5 Click OK.
   The named group is listed in the tool settings.

→ Exercise: Add members

1 Continuing in the survey model, set the following tool setting:
   Member Type: Active

2 Select each building and accept with a data point.

3 Click the magnifying glass in the tool settings to open the Named Groups dialog.
   Elements can be added to a group individually, or the Element Selection tool can be used to select multiple elements.

4 Select Element Selection, expand the tool settings, and select the Level tab.

5 Click on the level Survey Exist Driveway.
   The driveway elements are selected.

6 In the Named groups dialog, highlight the Building Info group.
7 Click Add Elements.

8 In the tool settings, set the Member Type to Passive.

9 Following the status bar prompt, enter a data point to add the selected elements to the group.

10 Clear the selection set.

11 Close the Named Groups dialog.

**Member types**

The Member Type options let you define how other members of the group are affected when one member is selected or manipulated. When the Graphic Group lock is off, both active and passive members can be operated on individually. When it is on, active members are operated on as a group, but passive members are still operated on individually.

➔ Exercise: See the difference between active and passive members

1 Continuing in the survey model, select Move from the Main toolbox.

2 Enter a data point on one of the buildings and move it.

   The single building moves.

3 Reset.

4 Click the locks icon in the status bar, and turn the Graphic Group lock on.

5 Enter a data point on one of the buildings and move it.
All elements in the group move.

6 Reset.

7 Enter a data point on one of the driveway elements and move it.
   This element moves independently, even though the Graphic Group lock is on, because it is a passive member of the group.

8 Reset.

9 Undo all three move operations.

Making Measurements

MicroStation’s measuring tools function like other tools. You enter data points in response to the status bar prompts. For accurate measuring, ensure that you use AccuSnap to snap to elements. Tools in the Measure toolbox let you determine distances between elements.
The Measure toolbox can be accessed from the Drawing task, from the Main toolbox, or by pressing D when the focus is at home.

Measuring distance

The Measure Distance tool is a general purpose tool that provides methods of measuring the distance between points, the distance along an element, a perpendicular distance from a selected element, or the minimum distance between two existing elements.

Exercise: Measure the distance between two points

1. Continuing in the survey model, select Measure Distance with the following tool setting:

Distance: Between Points

2. Following the status bar prompt, snap to the lower left corner of the lower building and accept with a data point.
3 Following the status bar prompt, snap to the right corner of the lower edge and accept with a data point.

The distance between points is reported in the status bar and in the tool settings.

4 Reset.

**Hint:** In the tool settings, double click on the resulting distance. Once highlighted, right click to open the pop-up menu. Selecting Copy will place the distance on the system clipboard. Alternatively, you can press Ctrl + C to copy the selected value to the clipboard. This functionality is available throughout MicroStation.

To measure a distance along an element, select the Along Element option. Identify the element and enter a data point. MicroStation will calculate the distance between the element’s start and end points.

→ **Exercise: Measure the distance along a flowline**

1 Continuing in the survey model, select Measure Distance, with the following tool settings:

   ![Tool Settings](image)

   **Distance:** Along Element

2 Following the status bar prompt, snap to one end of the flowline on the upper right side of the design.

3 Accept with a data point.

   Dynamic shading follows the element in the direction the pointer moved.
Making Measurements

4. Following the status bar prompt, AccuSnap to the other end of the flowline.

5. Enter a data point.
6. Read the measured distance in the status bar or the tool settings.
   This is the distance between the two points, as measured along the element.
7. Reset.

Another Measure Distance method is Minimum Between. Using this method, MicroStation finds the shortest straight line distance between two selected elements. In addition, it displays where the shortest distance occurs between the selected elements.

Measure Length

The Measure Length tool determines the total length of a selected element. The tool settings will also show the angle and elevation of the selected element. To use it, select the element you want to measure and then select the Measure Length tool.

Measure Radius and Measure Angle

These two tools make straightforward measurements when you select the elements to measure.

Depending upon the type of element selected, the Measure Radius tool reports a variety of radius and diameter measurements. For example, selecting an ellipse or elliptical arc, the tool settings will show the measurements for the primary and
secondary axes. To use it, select the tool and then select the element you want to measure.

The Measure Angle Between Lines tool reports the resulting angle in both the status bar and tool settings. To use it, select the tool and then select the elements you want to determine the angle between.

**Measure Area**

The Measure Area tool includes options for several different calculations.

Set Method to Element to measure the total area enclosed within the perimeter of a closed element.

The Points method lets you dynamically define a closed polygon. The area within the boundaries of the polygon will display in the status bar and tool settings.

➤ **Exercise: Measuring the area of the building**

1. Continuing the Survey model, select Measure Area.

2. Set the following tool settings:
   
   *Method*: Element
   
   *Area Unit*: square m

3. Enter a data point on the upper building.

   The area and perimeter are reported in the tool settings.

4. Select File > Close.
Using Patterns to Add Definition

Designs sometimes must designate specific areas, identify components or denote elevations. You can use the patterning tools for this. The Patterns toolbox can be accessed from the Drawing task or by pressing R when the focus is at home.

Patterning adds material and texture to elements to help express a role or function. For example, architectural wall sections might show insulation or concrete, while area on maps may show marshes or woods. Patterning is a view attribute, which can be toggled on and off in the View Attributes dialog.

Hatch Area

Hatching is the repetitive placement of lines at a specific angle and spacing.

The tool provides a variety of settings to control the appearance as well as placement of the hatch lines.

Pattern by single element, flood (enclosed area), union, intersection or difference between elements, an area defined by entering points, or using a fence

Two useful methods of patterning are by element and flood. The Element method patterns the interior of an identified element. The Flood method patterns the area enclosed by a set of elements.
The Snappable Pattern option

The Snappable Pattern option in the patterning tools’ settings lets you use MicroStation’s standard snap modes to snap to the resulting pattern elements.

In the following exercise, redline modifications require you to use Pattern tools to highlight areas of interest in a map.

→ Exercise: Creating an area hatch pattern
   1. Open the model named Wards.
   2. Set the active level to Ward 4 boundary.
   3. Select Hatch Area.

   ![Pattern tool settings](image)

   4. Set the following tool settings:
      - **Mode**: Element (First icon)
      - **Spacing**: 100
      - **Angle**: 30

   5. Enter a data point on the topmost Ward 4 boundary at the map’s upper right to identify it as the shape to be hatched.

   ![Map section with pattern applied](image)

When you identify the shape, it highlights.
Using Patterns to Add Definition

6  Enter a data point to accept the hatch pattern.

7  Reset.

Delete Pattern

Use Delete Pattern to delete patterning while restoring the original element components that were used to create the pattern.

Exercise: Delete a pattern

1  Continuing in the Wards model, select Delete Pattern.

2  Move the pointer over a Ward 4 hatch line.

3  When it highlights, enter a data point.

   The hatching is deleted.

Crosshatch Area

Use Crosshatch Area to place intersecting hatch lines. This tool offers the same tool settings as the Hatch Area tool, with two additional fields to enter the spacing and angle of the second set of hatch lines. Lock the lock icons to enter the same value for both fields.

If the additional fields are left blank, MicroStation will place the second set of hatch lines perpendicular to the first set.
Exercise: Creating an area crosshatch pattern

1. Continuing in the Wards model, select Crosshatch Area with the following tool settings:

   Method: Flood (Second icon)
   Spacing: 150 150 (enter 150 in the first field, lock the padlock, and press Enter)
   Angle: -135 -45
   Associative Pattern: Unchecked

   The method you are using to identify the element to pattern this time is the Flood method. This fills the enclosed area with pattern, like the flood fill tool common in painting programs.

2. Enter a data point on the same boundary to identify it as the shape to be crosshatched.

3. Enter a data point to accept.

Associative patterning

The Associative Pattern setting for patterning tools creates patterns or hatches that are linked to the original element geometry. If Method is set to Element, the hatching will update when the original element is manipulated or modified.
➔ Exercise: Create non-associative and associative patterns

1. Continuing in the Wards model, select Modify Element from the Main toolbox.

2. Enter a data point on a vertex of the crosshatched ward and move the pointer to modify the vertex.
   The pattern does not continue into the added area.

3. Undo twice.

4. Select Crosshatch Area and check the Associative Pattern check box.

5. Enter a data point inside a shape in ward 4 to identify it as the shape to be crosshatched.

6. Enter a data point to accept.

7. Select Modify Element.

8. Enter a data point on a vertex of the crosshatched and move the pointer to modify the vertex.
   This time the pattern continues.
9 Select Edit > Undo, or press Ctrl + Z.

Pattern Area

Pattern Area is the repetitive placement of a symbol to fill an area. The symbol used is a cell element, which is simply a small drawing of a frequently used symbol.

➔ Exercise: Add a grass pattern using a cell

1 Continuing in the Wards model, make land the active level.

2 Select Pattern Area, with the following tool settings:

   Method: Flood (Second icon)
   Pattern Definition: From Cell
   Scale: 500
   True Scale: Checked

Now you must select the cell to use.

3 Click the magnifying glass next to the Pattern field.

4 In the Cell Library dialog, select File > Attach File.

5 Navigate to the \Workspace\System\cell folder, select sample2.cel, and then click Open.

Hint: Use the Up one Level icon shown with the previous step to move through the folder structure.

6 Scroll to the cell named Grass and click on it.

7 Click the Pattern button in the Active Cells section at the bottom of the Cell Library dialog, and then close it.
Using Patterns to Add Definition

Now the cell can be used with the Pattern Area tool.

8 Enter a data point inside one of the wards.
   The outline highlights.

9 Enter a second data point to accept the area pattern.

Additional methods

There are four other methods to use when patterning elements. The icon resembles the outcome of the operation. Click the desired icon, set the rest of the tool settings, and follow the status bar prompts to pattern.

- Union fills the total area inside multiple elements.
• Intersection fills the intersecting area of multiple closed elements.

• Difference fills the difference between multiple closed elements. The first element is the one that is filled. The secondary elements are subtracted from the area of the first.

For these methods, you identify the elements involved with a data point. To select more than two elements, press the Ctrl key and click the element.

• Points fills an area that you define by entering data points.

**Tips and Tricks**

• If you have several shapes that need to be combined, put them into a selection set, and then use the Construct Region tool from the Groups toolbox with the method set to Union.
Module Assessment

- The Measure Length, Measure Area, and Measure Volume tools all support selection sets. This lets you measure multiple elements at the same time. Put them into a selection set and then use the tool, following the status bar prompts.

- To change the color of an associative hatch, just re-hatch the element using new symbology settings. The old hatch will be automatically replaced with new elements, using the current attributes.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

Working With Existing Elements Assessment
Modifying Existing Elements

Module Overview

This module explains how to use MicroStation’s modification tools to edit existing geometry.

Module Prerequisites

- Knowledge of MicroStation’s interface
- Some knowledge about MicroStation elements
- Knowledge about viewing in MicroStation
- Knowledge about AccuDraw
- Knowledge about element attributes
- Knowledge about MicroStation tool usage

Module Objectives

After completing this module, you will be able to:

- Modify existing element properties
- Change element attributes

Introductory Knowledge

Before you begin this module, let’s define what you already know.
Questions

1. True or False: You can make multiple copies with the Copy Element tool.
2. Which tool would you use to create the following pattern from an original element?

![Pattern Diagram]

3. How many previous commands can you undo in a MicroStation session?
4. To place an AccuDraw compass on a snap point, which shortcut should you use?

Answers

1. True. The tool has an option to make multiple copies.
2. Use Construct Array, Rectangular method, with a rotation of 45 degrees and 5 by 5 elements.
3. The number is unlimited to the extent of the undo buffer.

Basic Modification tools

Several tools can be used to modify the spatial geometry of existing elements.

The Modify toolbox can be accessed from the Main toolbox or by pressing 7 when the focus is at home.
**Modify Element**

Modify Element is an all-purpose modification tool that is used to change the spatial coordinates of an elements geometry.

With this tool, you can do the following. The tool settings will change depending upon the element or vertex selected.

- Move the end point of a line
- Modify rounded segments of complex elements
- Scale an arc while maintaining its sweep angle
- Scale a block about the opposite vertex
- Change a circle's radius or the length of one axis of an ellipse

**Exercise: Modifying lines and arcs**

1. Continuing in MicroStation_Essentials_V8i.dgn, open the model named Horizontal Alignment.
2. Select Modify Element.

   Note that there are no tool settings available. This tool presents tool settings based upon the element you choose to modify.
3 Enter a data point near the end of the centerline.

4 Move the pointer.

The end closest to the data point used to select the element to be modified. Since this is a line, no tool settings are necessary to move the end point to a new location. All you need to do is enter a data point to relocate it.

5 Reset.

6 The next part of the centerline is an arc. Click on it.

There are now tool settings available.

7 Move the pointer.

The arc can be moved in any direction, which causes the radius to change.

8 In the tool settings, note the method Radius about Center and move the pointer.

This modifies the arc’s radius without changing the center point.

9 In the tool settings, change the method to Radius preserve Ends.

The method modifies the arc by changing the radius, but keeps the end points in the same place.

10 In the tool settings, change the method to Angle and move the pointer.
This modifies the arc’s sweep angle.

11 Reset.

**Exercise: Modifying polygons**

1 Continuing in the Horizontal Alignment model, with Modify Element active, enter a data point on one of the building’s vertices.

2 Note the tool settings.
   
   You cannot only move the selected vertex to a new location, you can change the vertex type, including the radius of a rounded vertex. There is an orthogonal option to keep the vertex at right angles to the sides.

3 Set the following tool settings:
   
   **Vertex Type:** Rounded
   
   **Rounding Radius:** 100
   
   **Orthogonal:** Checked

4 Move the pointer upward and enter a data point.

5 Reset.
6. Enter a data point on the back of the building and move the pointer.

Now you are only modifying the height or orientation of the block so there are no tool settings. You can use AccuDraw to maintain vertex angles.

7. Reset.

**Hint:** When used with AccuDraw, the Modify Element tool provides the greatest degree of flexibility. For example, when selecting a circle AccuDraw switches to the Polar coordinate system, the compass moves to the center, and it aligns to the view axis.

**Break Element**

Break Element is used to remove unwanted portions of elements and has 4 options to alter its operation.

- The first option is Break by two points. Enter point 1 then point 2.
Basic Modification tools

- Option 2 is Break by point. Element breaks at a single point.

- Option 3 is Break by drag lines. Simply pick point 1 and 2 of a virtual line intersecting an element.

- Option 4 is Break by element. Any element that intersects another element, one of the elements can be used as a cutting element.

On closed shapes, the first data point identifies the element and start of the break, while the second establishes the direction and end point of the break.

It also lets you break, or cut, an element at a defined point.

To use it, select the tool and identify the element at the point where the break is required.
Basic Modification tools

**Extend Line**

This tool lets you dynamically adjust the end point of a linear element while maintaining its direction.

To use it, select the tool and set the tool settings. Check the Distance check box and set it to a negative value to shorten the line or a positive value to extend it. If you use From End, the extension or shortening happens to the end nearest the identification point. Follow the status bar prompts.

**Trim to Intersection**

This tool is used to extend or shorten lines, line strings, or arcs to their intersection with another element. Depending upon the element geometry, one or both of the elements can be modified to create the necessary intersection.

To use it, select the tool, identify the first element, identify the second element, and then accept the modification.

Check the Select cutting element first check box so that the first element you identify is the cutting element, and the second element is the element that is extended or shortened. When this tool setting is on, after you select the cutting element, you can select multiple elements by dragging a selection line across them to simultaneously extend and/or shorten them.
Trim to Element

This tool is used to extend or shorten two elements of any type to their intersection.

Depending upon the existing geometry, the selected element will be modified to create the necessary intersection.

→ Exercise: Use other element modifiers

1. Continuing in the Horizontal Alignment model, set the following in the Attributes toolbox:
   
   *Level: Plan Prop Alignment*

2. Select Place SmartLine.

3. Snap to the end of one right of way, and then to the end on the other side to place a line.

4. Reset.

5. Select Move Parallel from the Main toolbox, with the following tool settings:
   
   *Distance: Checked and set to 150*

   *Make Copy: Unchecked*
Basic Modification tools

6 Enter a data point to move the line.
7 Select Modify Element.
8 Modify the ends of both right of ways to the ends of the survey line.
9 Select Trim to Element.
10 Click one of the remaining lines, and then click the survey line to extend the line.
11 Repeat to extend all the lines.

This method works, but there are easier ways to extend or shorten multiple elements.

**Trim Multiple**

Use this tool to remove unwanted portions of elements to their intersection with a cutting element.

Tool setting modes let you change how the tool operates.
Basic Modification tools

- Trim and Extend lets you trim and extend one or more elements at their intersection with the cutting element.
- Trim is the default mode. Identified elements that intersect with the cutting element will be trimmed.
- Extend mode lets identified elements that can be extended to intersect with the cutting element(s) be extended.

To use it, use the Element Selection tool to select the cutting element(s), and then select the Trim Multiple tool. You can also select the Trim Multiple tool, and then identify the cutting element(s). Press the Ctrl key to select multiple cutting elements.

In the tool settings, set the Mode to Trim and Extend, Trim, or Extend. Then, identify an element to trim/extend. You can also drag a selection line across multiple elements to trim/extend.

As soon as you identify the elements to trim/extend, they are instantly modified to their intersection with the cutting element(s).

Construct Circular Fillet

This tool is used to place a tangent radius between two elements. Set the truncation option and a fillet radius in the tool settings. Fillets can be placed between arcs and circles in addition to lines.
Basic Modification tools

Construct Parabolic Fillet

This tool is used to construct a curve element between two lines. To use it, select the tool, select the first line, select the second line, and accept the fillet.

Construct Chamfer

This tool places a straight line element between two elements creating a beveled edge. The chamfer is defined by specifying two distances that locate the endpoints of the new beveled edge element, relative to the intersection point of the two modified lines.

Exercise: Constructing circular fillets

1. Open the model named Modifying Existing Elements, description, Essentials geometry.
2. Select the Construct Circular Fillet tool, with the following tool settings:
   - Radius: 0.2109
   - Truncate: Both

You’ll place a fillet at the upper left.
3 Select the first and second line segments by entering a data point on the left side of the bracket (green arrow) and then one on the top (red arrow).

MicroStation highlights the selected lines and replaces the sharp corner with a rounded one.

The fillet is placed and both lines are truncated.

4 Change Truncate to First in the tool settings.

You’ll place a fillet in the lower right bracket area.
5. Enter a data point on the left side of the right bracket and then one on the base.

MicroStation truncates the first element selected, and not the second.

6. Change Truncate to None in the tool settings.
   You’ll place a fillet in the lower left base area.
7 Enter a data point on the left side of the base and then the top of the base.

MicroStation constructs the fillet and performs no truncation at all.

During the next exercise, you will place a chamfer on a bracket.

**Exercise: Construct a chamfer**

1 Continuing in the Modifying Existing Elements model, select the Construct Chamfer tool with the following tool settings:

   *Distance 1*: 0.2109

   *Distance 2*: 0.4219

   You’ll place a chamfer in the upper right.
2 Select the first and second chamfer segments by entering data points on the top and then the side.

MicroStation replaces the sharp corner with a beveled one.

Changing Element Attributes

Using Element Selection

Resizing elements

A quick way to resize an element is to modify the location of Element Selection edit handles. To do so, do the following.

1. Select the element using the Element Selection tool.
2. Select a handle and drag to a different location.
3. Enter a data point when the element is the correct size.

Hint: To constrain the existing angles and preserve geometric relationships, press Alt on the keyboard while dragging the handle.

Changing attributes

Select the element or elements and then set new attributes in the Attributes toolbox. All selected elements will inherit the new attributes.

→ Exercise: Change selected element attributes

1 Click the Previous Model icon at the lower left of the application window to return to the Horizontal Alignment model.
2. Select Element Selection with the following tool settings:
   
   **Mode**: Line
   
   **Method**: Add

3. Drag a line across the roadway lines you extended.

4. In the Attributes toolbox, set the following:
   
   **Color**: 1
   
   **Style**: 0

   The element attributes are changed.

5. Click Clear in the Element Selection tool settings.

To change an active attribute to match the property of a selected element, drag the element into the Attributes toolbox and drop it on the corresponding icon. For example, to set the active line weight to match an existing element, use the Element Selection tool to select the element, then drag it to the Active Line Weight icon in the Attributes toolbox and drop it.

**Using Element Information**

This dialog is used to review or modify the properties of an element, such as its type, attributes, or even its geometry.

The selected element, or elements, are listed in the top frame. Tabs appear in the bottom frame and change depending on the type of element you select. Information displayed on each of these tabs pertains to the element whose list
Changing Element Attributes

entry is selected in the top frame. If you select the <Selection> entry, any changes made in the dialog will apply to all the selected elements.

Exercise: Change element attributes using Element Information

1. Continuing in the Horizontal Alignments model, turn on display of the levels Survey Exist Contour Major and Survey Exist Contour Minor.
2. Fit View.
3. Select Element Selection, expand the tool settings, and select the Level tab.
4. Scroll to and select the level Survey Exist Contour Minor.
5. Click the Element Information tool in the Primary Tools toolbox.
6. On the General tab of the Element Information dialog, click in the field next to Weight, where you see 2.
7. Click the arrow and change the weight to 0.
8. Close the dialog.

The line weight of the contours is changed.

Note: If a field and its setting are grayed out in the Element Information dialog, the value is read-only and cannot be modified.

Change Attributes toolbox

The Change Attributes toolbox can be accessed from the Main toolbox, or by pressing 5 when the focus is at home.
Change (Element) Attributes

Use the Change Attributes tool to specify new element attribute settings. It is useful if you need to make repetitive changes to many different elements. It is also is efficient for changing the level of an element to a level that is currently turned off without changing any other attributes.

To use it, select the tool, check the check box for each attribute you want to change, identify the element, and then accept the change.

- If Use Active Attributes is checked, the currently active attributes will change when you change or match attribute settings. By default, this is unchecked so that the active attributes are not affected.
- Uncheck Change Entire Element if you want to change part of a complex element, but not the whole element.

Match Element Attributes

To set the active element attributes so they match those of an existing element in a design, use Match Element Attributes tool.
Tips and Tricks

To use it, select the tool, check the check boxes for the attributes you want to match, and then click the element.

Note: If an attribute is set to ByLevel, you must check the Level check box to obtain a match.

SmartMatch

Match All Element Settings, or SmartMatch, is used to change all active element attribute settings, including those specific to particular element types, so that they match the attributes of a selected element. To use it, just select the element, and then select the tool.

Exercise: Change the major contour lines

1. Continuing in the Horizontal Alignments model, select SmartMatch, and then click on one of the contour lines you just changed.
   The attributes in the Attributes toolbox change.

2. Select Element Selection, click the Level tab in the expanded tool settings and click the level Survey Exist Contour Major.

3. Select Change Element Attributes, with the following tool settings:
   Use Active Attributes: Checked
   Level, Color, Style, Weight: Checked

4. Enter a data point in the view.

5. Click Clear in the Element Selection tool settings.

Tips and Tricks

- You can use the Stretch Element tool from the Manipulate toolbox to manipulate breaks. For instance, you can place a fence to include a window break, and move the window along a wall. You can also change the size of the window by including only the start or end of the break in the fence.
• You can turn AccuSnap off permanently by selecting Settings > Snaps > AccuSnap and then un-checking the “Enable AccuSnap” check box. To quickly suspend AccuSnap while in the middle of a tool just hold the Ctrl + Shift keys down.

• You can drag and drop into Attributes toolbox to match element attributes. To set a single attribute, simply drag and drop the element onto the desired picker (level, color, weight or style).

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

Mastery Exercise: Create elements and modify them

1. Use Place SmartLine and Copy Parallel to create an arrangement similar to the following.

```
    |     |
    |     |
    |     |
```

2. Use a Modify tool to create the following from those lines.

```
    |     |
    |     |
    |     |
```
3 Use Place SmartLine, Place Arc, and AccuDraw to draw an arc the size indicated and a line.

Use a Modify tool to modify the arc to the size indicated.
Annotating Designs

Module Overview

MicroStation has a variety of tools with which you can annotate geometry. You can place single or multi line text, dimensions, and revision clouds.

This module will show you how to annotate existing designs, use many of MicroStation’s annotation tools, and adhere to text and dimension standards.

Module Prerequisites

- Knowledge of MicroStation’s interface
- Some knowledge about MicroStation design elements
- Knowledge about viewing in MicroStation
- Knowledge about AccuDraw
- Knowledge about element attributes
- Knowledge about MicroStation tool usage

Module Objectives

After completing this module, you will be able to:

- Set text attributes
- Use text tools to place text
- Correctly dimension elements
- Place revision clouds
- Add text containing informative fields
Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1. What happens when you turn off display of a level?
2. Name the steps for using a MicroStation tool.

Answers

1. Turning levels on or off changes the display status of the elements that reside on the level.
2. 1. Set the correct level and any other element attributes that are necessary.
    1. Select a tool.
    2. Adjust the tool settings.
    3. Follow the status bar prompts and use the tool.

Text Attributes

Text elements are useful for including labels other than dimensions in a design. As an element, text is unique in that it has two distinct sets of attributes. There are element attributes such as color and text attributes such as font, slant, and justification.

Fonts

Fonts that are used to define the typeface of text elements are stored in external files that are referenced by MicroStation. This helps with the management of fonts and helps to keep design file size reasonable. MicroStation can use and display TrueType fonts, MicroStation fonts, and AutoCAD SHX fonts.
Text Attributes

Justification

As with most other elements, text is positioned in the model with a data point, which in this case, is referred to as the origin, or insertion point.

The way the text is aligned about the origin is controlled by the text’s justification.

Text size

Text size is determined by its height and width, which can be different values.

Line spacing

Line Spacing is the distance between individual lines of text in multi-line text. This value also specifies the distance text is placed away from an element when the placement method is set to Above, Below, or Along. Line spacing is commonly set to 1/2 to 2/3 of the text height.

Setting attributes

You can set the text attributes that you want in the tool settings at the time of placement, or they can be set using a text style. A text style is a named collection of text attributes that is created by an administrator.

Text styles

Text styles are named sets of text attributes, such as font, width, height, and color, that allow you to place text within a model in a consistent manner. Text elements can be placed with or without a text style, but text elements placed with a text style are automatically updated if the style is modified.
Using Text Tools

Exercise: Examine text styles

1. Continuing in MicroStation_Essentials_V8i.dgn, open the model named Annotating Designs, description, Essentials geometry.

2. Select Place Text.
   In the tool settings, the text style is set to (none).

3. Select the style Arial Bold and note how the tool settings change.
   The Bold icon is also activated in the Text Editor that opened when you selected the tool.

4. Select the style Italics and note how the tool settings change.
   The Italics icon and the color change in the Text Editor.

5. Select the style (none) before you continue.

Using Text Tools

The Text toolbox can be accessed from the Drawing task, or by pressing A when the focus is at home.

Place text

The most common tool for placing text is Place Text.

The word processor text editor opens when you select a text placement or editing tool. Input from the letter keys and arrow keys on the keyboard is treated as text input until you press the Esc key, select another tool, or click the (Utilities > Key-in) Key-in browser where you can type in MicroStation commands.

MicroStation’s word processor operates like any other text editor. You can set a variety of attributes such as bold, italics, and underline by either clicking the appropriate icon or using standard keyboard shortcuts such as Ctrl + B, Ctrl + I and Ctrl + U.
Text can be copied and pasted from other applications into the word processor and all formatting will be retained.

**Hint:** The word processor will also open if you double click on a text string with the Element Selection tool when it is in Individual mode.

The color and other attributes of text are set by a text style if one is selected in the tool settings. When you are not using a text style, text will be placed using the color that is active in the word processor text editor and the settings set in the tool settings.

**Placement methods**

There are different methods by which you can place text. By Origin lets you place the text in a drawing using the location of the justification setting and a data point you enter. By Origin places text at the angle that is active in the file (Active Angle) and using the active text settings.

**Exercise: Label elevations placing text By Origin**

1. Continuing in the Annotating Designs model, click the Expand arrow in the Place Text tool settings if you cannot see all the settings.
2. Set the following Place Text tool settings, leaving any default settings as they are:
   - **Method:** By Origin
   - **Height:** 18
   - **Width:** 18 (lock the padlock to make both the same)
   - Click the Annotation Scale icon so it is depressed
   - **Font:** scroll up to 41 ARCHITECTURAL (Press 4 on the keyboard to skip)
   - **Justification:** Left Top
3. Type the following into the text editor:
   - East Elevation
   - Note that the text is attached to the pointer by the upper left corner because of the Left Top justification setting.
4. Enter a data point under the top elevation to label it, and then reset.

The reset clears the text editor.

5. Type the following into the text editor:
   North

6. Press Enter to start a second line of text and type the following:
   Elevation

   A single line of text is a text element, while multi-line text is referred to as a text node. Text nodes are complex elements, like cells, which means that they are made up of multiple elements.

7. Change the following tool setting:
   Justification: Center Center

   The text is now attached to the pointer at the center.

8. Enter a data point under the second elevation to label it, and then reset.

Other placement options

- Fitted text is stretched to fit between two data points that you enter.

   The vertical alignment of the text is determined by the justification setting.
• Once View Independent text is placed, it stays at the same orientation regardless of how you rotate a view.

• Fitted V(iew) I(ndependent) combines fitted and view independent features.

• On Element places text on an element. The element is broken to accommodate the text.

• Along Element places text along an element, either above or below. Each character is placed as a single text element that is a component of a graphic group. There is a lock you can toggle that lets you operate on elements that are part of a graphic group individually or all together.

• Word Wrap lets you define a block and contains text within the box. If a word exceeds the limit of the box, the word drops to the next line.
Using Text Tools

- Above/Below Element places text above or below an element. How far it is placed from the element depends on the Line Spacing value.

⇒ **Exercise: Label an elevation using the Below Element method**

1. Continuing in the Annotating Designs model, type the following in the Word Processor:

   South Elevation

2. Change the following in the tool settings:

   Method: Below Element

3. Enter a data point on the bottom of the last elevation.

4. Enter a data point to accept.

   The name is placed under the building.

The distance that text is placed from the identified element when using the Above, Below, On, and Along methods depends on the Line Spacing setting. The larger the value, the further away from the element the text is placed.

**Annotation scale**

This defines the scale for text and dimensioning in a file. When you specify an annotation scale, the text you are placing is scaled by that amount. Administrators will usually create text styles at a scale of 1 to 1 for plotting. Then you enable the Annotation Scale lock when placing the text in a file so that it appears the correct size.

If you were creating a 1m = 200m scale design, any text that you place would have to be 200 times bigger than normal so that it looks correct. With Annotation Scale set to 200:1, you do not have to worry about calculating the size of the text.

**Note:** Click the AccuDraw icon in the Primary Tools toolbox to toggle AccuDraw off so you can see the effects of the next exercise.
Exercise: The effects of using annotation scale

1. Continuing in the Annotating Designs model, change the following Place Text tool setting:

   Method: By Origin

   The Annotation Scale lock was on when you previously placed text. Let’s see what happens when you turn it off.

2. In the tool settings, disable the Annotation Scale lock by clicking the icon.

   ![Annotation Scale lock enabled, left, and disabled, right]

3. The text South Elevation remains in the Word Processor if you did not reset; if you did, retype it.

4. Enter a data point to place the text outside the border.

   It is so small that you cannot see it. The scale of this model is 1:100. You need to scale 1:1 text up 100 times so that it looks correct.

5. Zoom In so you can see the small text.

6. Select Scale from the Main toolbox, with the following tool settings:

   Method: Active Scale

   X and Y Scale: 100

7. Click the text you just placed, and enter a data point to scale it.

8. Fit View.

   It now appears correct. It is easier to use the Annotation Scale lock so that text is always placed at the correct size.

9. Click the lock icon in the status bar and click next to Annotation Scale to turn the lock back on.

10. Delete the extra text.

Place Note

This tool is used to place text with leader lines and arrows, as well as callouts without leaders.
Tool settings control both the appearance and placement of the notes.

To use it, select the tool, and select the Place Note icon in the tool settings. Type the note text you want to place in the word processor. If there is no text entered, only the leader line and arrow are placed. Enter a data point to position the terminator arrowhead. Enter a data point.

- If Location is set to Automatic or Semi-Automatic, this data point indicates the location of the end of the leader line and text, and ends the note.
- If Location is set to Manual, you can enter more data points to define additional vertices of the leader line. Reset to end the note.

To place a callout, select the Place Callout icon in the tool settings, set any additional tool settings, type the text in the word processor, and enter a data point to place the callout.
Enter data fields

Enter data fields are empty text place holders that are positioned in the file, but filled with text characters later. Each enter data field is placed with a full set of text attributes that will be applied to the text characters upon entry into the data field.

The default character used to represent a data field is an underbar ( _ ) and each underbar is a placeholder for a single character of text. Select Place Text, enter any text you want and then an underbar for each enter data field you want.

BSI_ _
BSI_ _
BSI_ _
BSI_ _
BSI_ _

Enter data fields will display as underbars unless the Data Fields option is disabled in the View Attributes dialog. When this icon is disabled, the enter data fields will not display but can still be used with the following specialized tools.

- Fill In Single Enter Data Field is used to select and fill in an enter data field.

- The selected enter data field can either be empty or contain text. To fill one, select the tool and then click the text containing the field. In the Text Editor, enter the text you want to fill the fields with, and then enter a data point.

- Auto Fill In Enter Data Fields is a useful tool to fill in empty enter data fields in a selected view.

- When selected, MicroStation cycles through each enter data field in a view and selects them in the order in which they were created. Select the tool,
enter a data point in the desired view, then enter the text in the Text Editor and press Enter.

BSI100
BSI200
BSI\[\_\]
BSI\[\_\]
BSI\[\_\]

**Copy/Increment Text**

Use Copy/Increment Text to copy an existing text string that contains numbers.

As MicroStation creates each copy, the number is incremented according to the Tag Increment value defined in the tool settings. Click the tool, click the text, and each data point places an incremented copy.

RM101
RM111
RM121
RM131
RM141

*RM101 copied with an increment of 10*

**Find/Replace Text**

Located on the Edit menu, Find/Replace Text lets you search for all, or portions of, a specific text string in either a DGN or DWG file. Once the text is found, it can be replaced with a different string. You can replace single instances, those within a fence, or all instances.

To use Find/Replace Text, select *Edit > Find/Replace Text*. The options in the Replace Text dialog work just like those of most Windows applications’ Find and Replace text functions.
Changing Existing Text

Rather than replacing text that is not correct, you can edit and change it several ways.

Edit Text

The Edit Text tool lets you edit existing text.

When a text string is selected for editing, it appears in the word processor. In addition to changing the alpha-numeric, a variety of text attributes can also be changed. Once the changes have been made in the word processor, enter a data point in the view to change the text.

➔ Exercise: Edit text string content

2. Enter a data point on the text string South Elevation.
3. In the word processor, highlight the word South and replace it with Southeast.
4. Enter a data point.

Hint: Double click a text element with the Element Selection tool active to activate the Edit Text tool and open the word processor text editor.

You can change more than alpha-numeric attributes using Edit Text.

➔ Exercise: Edit color and style

2. Enter a data point on the text string you just edited.
3. In the word processor, set the font to the TrueType font Arial Narrow, and click the Bold and Underline icons.
Matching and changing text

The Match Text Attributes tool sets the active text settings to match those of a selected text element.

The Change Text Attributes tool changes the attributes of existing text elements. You can change text strings or nodes individually, or using a fence or selection set.

Exercise: Change text attributes

1. Continuing in the Annotating Designs model, select Change Text Attributes, with the following tool settings:
   - **Text Style:** Unchecked
   - **Font:** Check and set to Arial
   - **Height:** Check and set to 20
   - **Width:** Check and set to 20
   - **Underline:** Check and set to Disable

2. Enter a data point on the text string you’ve been working with.
   - Note that the bold attribute is exclusive to the word processor.

3. Select Match Text Attributes.

4. Enter a data point on the text North Elevation, and then enter a data point to accept.
   - The active text attributes are now set to these attributes.

5. Select Change Text Attributes, and note the active attributes.

6. Enter a data point on the text, and the original attributes return.

Text Fields

Fields are text strings derived from the attributes of an element, the properties of a model or the properties of a file and are placed with the Place Text tool.
Fields based on element attributes are updated to reflect changes whenever a change to the element causes the attribute to change. Models have an option to update fields automatically.

Exercise: Add a file property field to the title block

1. Continuing in the Annotating Designs model, Window Area around the border’s title block.

2. Select Place Text, with the following tool setting:

   - **Method**: By Origin
   - **Text Style**: Style (none)
   - **Height and Width**: 13
   - **Annotation Scale**: Enabled

3. Right click in the Word Processor text editor.

4. Select Insert Field.

5. Select Model Properties in the Field Type dialog, and click OK.

6. In the Fields Editor dialog, click the Name field.

7. In the String Format section, set Case to First Capital.

   ![Fields Editor dialog](image)

   You see a preview of what the text will look like at the dialog’s lower left.

8. Click OK.
Place the text in the Model field in the title block.

The string reflects the model name.

Select File > Save Settings.

→ Exercise: Change file properties to update the field

1 Continuing in the Annotating Designs model, open the Models dialog.
2 Right click the name Annotating Designs, change it to Annotating, and press Enter.
3 Select Utilities > Key-in to open the Key-in browser where you can type in commands.
4 In the field at the top, type the following, and then press Enter:

FIELD UPDATE SELECT

5 Enter a data point on the Annotating designs field.

The text field updates.

A field can appear anywhere within a text string and can span multiple words or lines within multi-line text.

Text field background

In order to distinguish fields from text that is entered directly, fields have a gray background. Its display can be toggled in the Preferences dialog.

→ Exercise: Hide the field background

1 Continuing in the Annotating Designs model, select Workspace > Preferences.
2 Select the Text category.
3 Enable the Hide Field Background check box and click OK.
4 Select File > Save Settings, and then File > Close.
5 Reopen the file.

The field backgrounds no longer display.

You can place fields that update when elements are modified. Use the field type element properties to create these types of fields. You then identify the element you want to use so that the applicable properties can be determined. Select from them to create the field.

Fields reflecting element area and element color, line style, and weight

The Spell Checker

This feature lets you search the text in the text editor, or search an entire design file, for spelling errors.

To check the text in the text editor, select the icon in the word processor tool bar.

To check the active file, select the tool from the Text tools. You can check individual words, use a fence to fence a portion of the file, or check the whole file.
Revision Clouds

A revision cloud is a closed element commonly used to call attention to design revisions or markups (redlines). Tools for placing them can be found in the Drawing Composition tasks’ Annotation task, or select be Tools > Detailing Symbols > Cloud by Points.

➔ Exercise: Add a revision cloud

1. Continuing in the Annotating Designs model, set the following in the Attributes toolbox:

   - **Color**: 3
   - **Weight**: 1

2. Select Tools > Detailing Symbols > Cloud > Cloud by Points with the following tool setting:

   - **Arc Angle**: 100

   Arc Angle defines the sweep angle of the arcs used to form the cloud element.

3. Follow the status bar prompts to place a cloud around the edited model name in the title block.

   You can also create a revision cloud by modifying or copying an existing closed element using the Cloud By Element tool.

4. Fit View.

The Arc Radius option lets you define the radius of the arcs used to construct the cloud element. If the option is unchecked, the radius of the arc elements is defined by the first two data points you enter when creating the revision cloud.

Dimensions

Dimensions are critical for accurate designs. They are necessary to show the size of, and relationships between, elements or overall models.
To understand dimensions, examine the components of a dimension element.

![Dimension diagram](image)

**Dimension styles**

Dimension definitions can be created by administrators and saved in named styles in the Dimension Styles dialog. Similar to text styles, these pre-defined styles let you place dimensions in a consistent manner.

**Dimensioning tools**

The Dimensioning toolbox can be accessed from the Drawing task, or by pressing F when the focus is at home.

**Element Dimensioning**

The Dimension Element tool is used to dimension a line, line string, multi-line, shape, arc, or circle.

Associations can be made between the dimension and elements so that, if the element changes, the dimension updates automatically. A variety of tool settings determine the placement and appearance of the dimension element.

**Exercise: Use element dimensioning in the reception area**

1. Continuing in the Annotating Designs model, select Settings > Snaps > AccuSnap.
Dimensions

2 Disable the Pop-up Info check box so you can see the dimensions more clearly.

3 Zoom in to the area indicated.

4 Select Element Dimensioning, with the following tool settings:

   * **Dimension Style:** mm Dimension
   * **Annotation Scale icon:** Enabled (depressed)

   The tool has different tool settings depending upon the type of element you are dimensioning.

5 Enter a data point on the outer arc of the reception desk.

Note the tool settings. They have changed to reflect the fact that you are dimensioning a circular element. The active mode is Dimension Radius. The position of the dimension changes dynamically as the pointer moves.
6 Enter a data point to the right of the arc to place the dimension.

![Diagram showing a dimension placed to the right of an arc]

**Note:** Don’t worry if your value is different than shown, as the example files sometimes change.

7 Enter a data point on the dashed grid line that runs vertically, to the right of the reception desk.

The tool settings reflect that you are dimensioning a linear element. The position of the dimension changes dynamically as the pointer moves.

![Tool settings icon]

8 Enter a data point to place the dimension.

![Diagram showing a dimension placed vertically]
Alignment

Alignment options control the alignment of linear dimensions.

<table>
<thead>
<tr>
<th>Alignment</th>
<th>Aligns linear dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Parallel to the view x- or y-axis. (X is the design plane x-axis.)</td>
</tr>
<tr>
<td>Drawing</td>
<td>Parallel to the design plane x- or y-axis. The model's rotation determines the alignment axis for a particular dimension. (X is the design plane x-axis.)</td>
</tr>
<tr>
<td>True</td>
<td>Parallel to the element being dimensioned. The extension lines are at right angles to the dimension line.</td>
</tr>
<tr>
<td>Arbitrary (2D only)</td>
<td>Parallel to the element being dimensioned. The extension lines are not constrained to be at right angles to the dimension line.</td>
</tr>
</tbody>
</table>

Association

The Association option associates the dimension you are placing with the points on the element being dimensioned. If the element is then modified, the dimension updates to reflect the change.
The Association lock must be enabled to place associated dimensions. Turn this on in the extended tool settings or by clicking the lock in the status bar and selecting it from the menu.

**Exercise: Placing associated dimensions**

1. Continuing in the Annotating Designs model, select Place Block, with the following tool settings:
   - **Method**: Orthogonal
   - **Fill Type**: None

2. Place a block behind the desk to represent a cabinet.

3. Select Element Dimensioning, click the arrow in the tool settings to expand them, and enable the Association check box.

4. Enter a data point on one side of the cabinet, and another to place the dimension.

5. Select Modify Element.

6. Enter a data point on the cabinet.

7. Move the pointer upward to extend the cabinet, and enter a data point.
   - The associated dimension updates when you establish the new end point.

If using the Element Dimensioning tool, place the dimension normally. The Element Dimensioning tool creates all possible associations automatically if the Association Lock is on. Snapping is unnecessary. If using dimensioning tools other than Element Dimensioning, snap tentative points to the element or elements being dimensioned to create associations.
Changing any association point by modifying the element updates the attached dimensions.

**Note:** Avoid placing associated and non-associated dimensions in the same model.

### Linear dimensioning

Use Linear Dimensioning to dimension the linear distance between two points.

When using these tools, alignment and location can be set in the tool settings. Options that affect placement and appearance are also available in the tool settings.

⇒ **Exercise: Placing a string of dimensions between columns**

1. Continuing in the Annotating Designs model, Zoom Out so you can see the side of the floor plan.

2. Select Dimension Linear, with the following tool settings:

   * **Dimension Style:** M Dimension
   * **Mode icon:** Linear Size (first icon)
3 Enter a data point at the end of the uppermost grid line, and then enter a data point on the next one down.

4 Enter a data point to the right to define the length of the extension line.

Linear Size dimensions the linear distance between two points. Each dimension is computed from the endpoint of the previous one and is chained together.

5 Enter a data point at the next grid line down.

6 Enter a data point at the last grid line.

7 Reset.
Exercise: Placing stacked dimensions

1. Continuing in the Annotating Designs model, set the following Linear Dimensioning tool setting:

   Mode: Linear Stacked

   ![Image of Linear Stacked mode]

   This mode dimensions the linear distance from an origin, and stacks the dimensions.

   You’ll focus on the lower side of the building.

2. Following the status bar prompt, enter a data point on the fourth grid line to the left, and then enter a data point at the next grid line to the right.

3. Enter a data point to set the length of the extension line.

4. Enter a data point on the grid line at the right corner.

5. Reset.

Note: The tool starts the next dimension perpendicular to the last dimension placed. Resetting twice resets the tool from the beginning.

The Select Multiple Elements option lets you dimension multiple elements by passing a line through them.
Exercise: Dimension multiple elements

1. Continuing in the Annotating model, Zoom Out so you can see the entire upper side of the building.

2. Select Dimension Linear, with the following tool settings:

   - Select Multiple Elements icon: Enabled
   - Linear Size: Enabled
   - Start and End Extension: arrow

   ![Linear Dimensioning tool settings]

   Note the change in the start and end extension settings labels. The color changes to blue, indicating that this attribute is different than the one defined in the dimension style you are using. The * next to the style name indicates that it has been altered.

   You are prompted to select the start of the selection line.

3. Enter a data point to the left of one of the grid lines and drag it to the right to include all the grid lines.

4. Enter a data point to define the length of the extension lines and place the dimension chain.

5. Reset.

6. Click the Reset Style icon in the tool settings of the Linear Dimensioning tool.

   The start and end extension settings return to arrow, as defined in the dimension style. The color difference indicators disappear.
Angular dimensioning

The Angular Dimensioning tool has modes that help you to dimension angles.

The tool settings have options to define its performance and the appearance of the dimensions. To use it, select the tool, set alignment and location, select the desired mode and then follow the status bar prompts to place the dimension.

Ordinate dimensioning

Ordinate dimensions are used to label distances along an axis from an origin. You can enter positive and negative values.

Modifying existing dimensions

Change Dimension

Existing dimensions can be changed to reflect new settings using the Change Dimension tool.

Exercise: Changing the active dimension settings

2. In the Dimension Styles dialog, highlight the dimension style mm Dimension.
3. On the Symbology tab, change the following:
   Dimension Lines > Color: 3
4. Select Change Dimension.

5. Enter a data point on the last dimension string you placed.

6. Enter a data point to accept.

The dimensions assume the new attributes.

You can use the tools in the Modify toolbox to modify dimensions.

<table>
<thead>
<tr>
<th>To:</th>
<th>Use this Modify tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add an extension line</td>
<td>Insert vertex</td>
</tr>
<tr>
<td>Remove an extension line</td>
<td>Delete vertex</td>
</tr>
<tr>
<td>Move an extension line</td>
<td>Modify</td>
</tr>
<tr>
<td>Modify length of an extension line</td>
<td>Modify</td>
</tr>
<tr>
<td>Move dimension text</td>
<td>Modify</td>
</tr>
<tr>
<td>Edit text in a dimension element</td>
<td>Edit text</td>
</tr>
</tbody>
</table>

Exercise: Remove an extension line

1. Continuing in the Annotating model, select Delete Vertex.

   Note the status bar prompt.
2 Enter a data point on any extension line, as shown, and enter a data point.

The extension line is removed and the distance is recalculated.

3 Reset.

Note: You can also use tools from the Tools > Dimensions > Misc Dimensions toolbox to work with dimensions.

You can use the Match Dimension Attributes tool to match existing settings, and then update using Change Dimension.

Dimension Audit

The auditing tool searches all dimensions and reports any problems. Dimensions are tested for overridden text, dropped dimensions, and loss of associativity by toggling the criteria option icons. The report displays in the Report field at the bottom of the dialog.

Audits can be performed using all of the criteria together, or on any single or combination of criteria.

- Find Overridden Text (second icon) finds dimensions whose text has been edited.
• Find Dropped Dimensions finds dimensions that have been dropped to elements.
• Find Non-Associative Dimension finds dimensions that are no longer associated to the elements they are dimensioning.
• Find Lost Associations finds dimensions that have associations that have failed.

Any problem dimension is highlighted in the file and the area is zoomed to in the active view.

➔ **Exercise: Audit the dimensions**

1. Continuing in the Annotating model, select *Utilities > Dimension Audit.*
2. In the Dimension Audit dialog, enable only Find Non-Associative Dimensions.
3. Click Dimension Audit Find.
4. Click the Expand arrow in the dialog and note the report.
   To page through problems, click the Next Item arrow in the dialog.

### Tips and Tricks

• To apply a shadow to text, first make a copy of the text string. Next, change its Transparency to 50. Now move it so it is offset it a little to the left or right and also down. This new text element should be behind the original text, so select *Edit > Bring to Front* to move the original text back on top if needed. This works especially well if your text is any color other than black.

![shadow text](image)

• If you have several single lines of text that you'd like to convert to multi-line text, a text node, do the following. Put all the text into a selection set. Copy the text to the clipboard using Ctrl + C or by selecting Edit > Copy. Select Place Text and paste the text into the word processor. When you place the text into the file it will be a text node.

• To quickly edit text, select the Element Selection tool and set it to Individual mode. Position the arrow pointer on the text element you want to edit and
double click. This activates the Edit Text tool. Edit the text and enter a data point to accept.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

[Annotating Designs Assessment]
Module Overview

This module discusses aspects of working with design files.

Module Prerequisites

• Knowledge of MicroStation’s interface
• Some knowledge about MicroStation design elements
• Knowledge about viewing in MicroStation

Module Objectives

After completing this module, you will be able to:

• Save information
• Create files using seed files
• Set working units
• Compress files
• Create Saved Views

Introductory Knowledge

Before you begin this module, let's define what you already know.
Questions

1. What happens when you turn off display of a level?
2. True or False: View controls can only be applied to the view from which the tool was chosen.

Answers

1. Turning levels on or off changes the display status of the elements that reside on the level.
2. False. You can use a view control in any view.

MicroStation Design Files

Design file, or DGN, is the name of MicroStation’s primary data storage file, due to the .dgn file extension. The term design is often used interchangeably with the term design or drawing.

However, a design is a collection of elements that are drawn at full scale. A drawing is a collection of elements and other items assembled for presentation purposes.

Closing Files

You have finished with the file you are in and want to close it. There is still more work to do in MicroStation though, so you don’t want to quit the application. You just want to close the current design file.

- Selecting File > Open lets you select the next file you wish to open. The file you are currently using will close and the new file will open.
- Selecting File > Close will close the current file, returning you to the File Open dialog.

Exercise: Closing the active design file

1. Continuing in the present model, select File > Close from the main menu bar.

   The design file closes and you are returned to the File Open dialog.
You can only open one design file at a time in a MicroStation session. If you find that you need to have two design files open at the same time, you must start a second MicroStation session to open the second design file. It is a good practice to select a different User in the File Open dialog when opening the second session. Note that only one license is used for both sessions.

Saving information

The method MicroStation uses to save information is slightly different from the methods other applications use. When you open a design for modification in MicroStation, the program reads the design's data from the design file stored on the system's hard disk or network device into the computer's local memory (RAM). During the design process, MicroStation periodically writes the changes back (saves) to the open file on the hard drive. This contrasts with other applications that require you to perform a Save operation to permanently save your changes.

Creating a MicroStation design file

To work in MicroStation you must either open an existing design file or create a new one. In the next exercise, you will create a MicroStation design file and give it a name before opening it. You will use the File Open dialog to create the file, but you can create a file from inside MicroStation by selecting File > New.

Hint: A benefit of creating a file from inside MicroStation is that the new file opens immediately.

➔ Exercise: Creating a new file

1. Click the New file icon at the top of the File Open dialog.

2. Type myfile in the File name field of the New dialog.
   Do not press Enter yet. Doing so is the same as clicking OK or Save, which will finish the creation process and close the dialog you are using.

3. Observe the Save as type field.
   It is set to MicroStation DGN Files. This field is used to select the desired file type. The correct extension will be appended to the file name automatically.
4 Observe the Seed field, and then click the Browse button.
It shows the path to the seed file that will be used; in this case, it is called ExampleSeed.dgn.

Other delivered seed files are available. To use one, click Browse, select a file and click Open. Your organization will most likely have its own set of seed files.

5 Click Cancel to continue to use ExampleSeed.dgn.

6 Click Save.
The new file name, myfile.dgn, appears in the File Open dialog.

You can open existing MicroStation files and create new files from your own workstation or any accessible device on your network that has access to a MicroStation license. Your system administrator, CAD manager or project leader will probably set the location of your project’s files.

Now that you have created a new design file, open it and see what is inside.

⇒ Exercise: Opening the new file
1 With myfile.dgn selected in the File Open dialog, click Open to open the file.
You see any elements that were present in the seed file.
2 Select File > New from the main menu bar.

Seed files

A new design file is created by copying an existing seed file, which serves as a template. It contains preset values such as initial element parameters, the type of design to be created (2D or 3D), the working units used and perhaps some initial design elements. An example of the latter would be a seed file containing your company’s border and title block.

⇒ Exercise: Selecting a seed file
1 Click the Browse button next to the Seed field at the bottom of the New file dialog.
2 In the Select Seed File dialog, select 2dMetricGeneral.dgn.
3 Click Open.
4 Type myfile2 in the File name field of the New file dialog.
5 Click Save.

The file opens. You can see that this seed file contains no elements.

Note: If you try to use a file name that already exists, an alert appears, warning you the file already exists. You will overwrite the file if you continue with file creation. When such a window appears, play close attention and make sure you really want to overwrite the file.

As you have seen, seed files can contain geometry or they can be pre-configured with many of the standards common to a particular project. Your CAD manager or project leader will probably customize certain delivered seed files for your use. Having the customized seed files will make it easier for you to adhere to required project parameters.

Working with Files

Attributes settings affect individual elements placed in a design file. Some settings and operations affect everything in the file, or the file itself.

Setting working units

Working units are real-world units to which the design plane is configured.

MicroStation uses true working units that are based on the meter. All measurement information is stored in the metric system and converted to other systems when requested. The conversion is completed with 14 places of accuracy to the right of the decimal point. You use units of measure, selecting the preferred units from a collection of imperial and metric units.

Changing units in a model does not change the physical size of the design geometry. It simply changes the display of measured distances to the units of choice.

Working units are composed of Master Units (MU) and Sub Units (SU), for example, meters and centimeters. Sub units must always be equal to, or smaller than, the master unit.
Working with Files

Working units, and how they are reported, are set in the Design File Settings dialog. Select Settings > Design File, then the Working Units category.

- The Master Unit and Sub Unit options are set by the system and can be edited by an administrator.

The Format and Accuracy settings are used when displaying coordinates, distances, and angles in the status bar and dialogs. Setting these does not affect the accuracy of calculations, only the precision with which the Format options establish which units are displayed. MU displays only the master units. MU:SU displays both master and sub units.

<table>
<thead>
<tr>
<th>Working Units</th>
<th>MU:SU and Distance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feet / Inches</td>
<td>120:10 is 120 feet, 10 inches</td>
</tr>
<tr>
<td>Miles / Yards</td>
<td>26:385 is 26 miles, 385 yards</td>
</tr>
<tr>
<td>Meters / Millimeters</td>
<td>5:25 is 5 meters, 25 millimeters</td>
</tr>
<tr>
<td>Millimeters / Micrometers</td>
<td>0:500, or:500 is one half millimeter</td>
</tr>
</tbody>
</table>

For example, one and a half feet is 1.5 feet, or two meters and 750 millimeters is 2.75 meters.

- Accuracy sets the number of decimal places, or fractional accuracy readout.

**Hint:** You can change working units quickly in the Drawing Scale dialog. Select Settings > Drawing Scale to open it.

**Note:** Any changes made in the Design File Settings and Drawing Scale dialogs must be saved by selecting File > Save Settings.
Compressing files

Compressing a design file reduces its size by purging empty and unused data resources. Select File > Compress > Design to compress a file. Note that this clears the undo buffer, so you will no longer be able to undo and redo.

Storing Geometry

Models

A model is a separate working space, containing separate geometry, within a design file. MicroStation design files can contain multiple models.

Saved Views

A Saved View is a named view definition saved in a DGN file. It is a way to save a specific area of a design along with view attributes, window size and position, and other settings. You save the portion of the design you want to reuse and then attach it to any view window when needed. You can also attach a saved view to another model as a reference.

Hint: Saved Views are often used to set up standardized views for plotting.

You can create a clip volume during the process of creating a saved view or create a saved view from an existing clip volume. A clip volume is used to limit the displayable area of a design. When clip volume is applied to a view, only the area within the defined boundary is displayed.

Exercise: Limit the elements displayed using a clip volume

1. Open MicroStation_Essentials_V8i.dgn.
2. If you are in the same MicroStation session, you can use the Previous Model tool at the lower left of the application window to return to the last model that was open in the file.
3. Open the model named Office Building, description, Essentials geometry.
3 Select the Clip Volume view control from View 2 and select the Apply or modify Clip Volume tool.

4 Set the following tool settings:

*Apply Clip Volume By Element* (first icon): Enabled
*Display Clip Element*: Checked (you will now see the element that defines the clip area)

5 Click on the green shape around the stairwell.

The rest of the elements disappear and only the stairwell elements are displayed.

6 In the Level display dialog, turn off the level named Stairwell.

7 Expand the Clip Volume tool settings by clicking on the downward arrow at the lower right.

This area lets you save a clip volume for future recall.

8 Click Create Named Fence from Clip Volume in the tool settings.

9 Replace the name Untitled with Stairwell and press Enter.

This saves the displayed area so that it can be recalled.

› Exercise: Create a saved view

1 Continuing in the Office Building model, maximize View 2 and Fit View.
2 Click the Saved Views tool in the Primary Tools toolbox to open the Saved Views dialog.

3 Click Create Save View in the Saved Views dialog, and set the following:
   
   **Method:** From View
   **View Type:** Saved View
   **Name:** Stairs
   **Clip Volume:** select Stairwell from the Clip Volume options
   **Associative Clip Volume:** Checked

4 Enter a data point in the view.
   
   A pop-up message indicates the view is created.

5 Click the Restore Down icon at View 2’s upper right to size the view back down.

**Apply Saved View Options**

There are several parameters saved with a saved view. Window size and position, aspect ratio, reference settings, levels, camera position, view attributes, and clip volume. Enable or disable these options when you apply a saved view to retain or discard parameters.

➤ **Exercise: Applying a saved view**

1 Continuing in the Office Building model, open View 8.

2 Scroll to and select the Stairs view in the list of names and click Apply Saved View.

3 Note the tool settings. (Do not click in the view to apply the saved view yet.)
Storing Geometry

When the Window icon is enabled, setting the option menu to its right to Aspect Ratio keeps the saved view proportionate. Selecting Size keeps it the same size, or a 1:1 ratio. Selecting Size and Position keeps the exact size and position.

Enable View Attributes so that the saved view’s view attribute settings are maintained, rather than accepting those that are active in the view to which it is being attached.

The other options work the same way. If the icon is enabled the saved view will maintain its own parameters as opposed to accepting those that are active in the view to which it is being attached.

**Exercise: Attach the saved view**

1. Click the Window icon and set the option to Size and Position.

2. Enter a data point in View 8.
   The saved view is attached and the view window resizes so that it is the same size and in the same position as it was when the saved view was created.

3. Close the Saved Views dialog.


**Exercise: Test the associative clip volume**

1. Continuing in the Office Building model, select the Scale tool from the Main toolbox with the following tool settings:
   
   \[
   X \text{ Scale}: 4.00 \\
   Y \text{ Scale}: 4.00
   \]
Ending a MicroStation Session

When you make changes to settings that you want to permanently store, you must save them to disk. To do this, select Save Settings from the File menu on the main menu bar. A shortcut exists for this command as noted in the File menu, Ctrl + F.

Save Settings saves the current settings in the active design file. These settings include those that you set in file settings dialogs, as well as the view configuration. The view windows will look exactly the same in size, position, and content when you reopen them if you Save Settings before you close a file.

Tips and Tricks

- When making many design changes in a file, it may be helpful to place a bookmark so that you can undo changes back to a particular point. Referred to as a mark, you can set it by selecting Edit > Set > Set Mark. This puts a marker in the undo buffer so that you can undo your work back to that point by selecting Edit > Undo Other > To Mark. You can have multiple marks in one file, so you can do some work, mark it, do some more, mark there and so on.
• You can change the label that is displayed with working units. Select Settings > Design File and select the Working Units category. Simply select the unit label, type in what you want, and click OK.

• The File menu on the main menu bar has a history of files you have opened at the bottom. This makes it easy to locate a specific file you used previously.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.
Module Overview

This module explains how to use the data in different files for reference purposes.

Module Prerequisites

- Knowledge of MicroStation’s interface
- Some knowledge about MicroStation elements
- Knowledge about viewing in MicroStation
- Knowledge about AccuDraw
- Knowledge about element attributes
- Knowledge about MicroStation tool usage
- An understanding of the way an overlay system works

Module Objectives

Upon completion of this module, you will be able to:

- Attach and control reference information
- Create and use models
- Attach and control images with Raster Manager

Introductory Knowledge

Before you begin this module, let's define what you already know.
Questions

1. What is a model?
2. How do you open one?
3. Why might you want to look at another model at the same time as the one on which you are working?

Answers

1. A model is an independent container within a DGN file that stores graphical information and specific settings.
2. Select the model name in the View Groups dialog at the bottom left of the application window. You can also open the Models dialog from the Primary tools toolbox and double click the model name.
3. You might want to make measurements, check element attributes, make sure features match, or print the contents of that model along with those of your active model.

References

A DGN file is composed of models. When you place elements with MicroStation tools, the elements are added to the active model. A model can be either 2D or 3D and is stored as a separate object within a DGN file.

A reference is a model that is attached to, and displayed along with, the active model for various purposes. When you use a design file that was created by someone else, you generally want to look at it without modifying it. For example, you may attach a collection of survey points as a guide for placement of additional geometry. References let you do this.

Attaching references

You can reference models from the active DGN file, or from other DGNs that may currently be in use by other users. Similarly, other users can reference the model that you are working on. You can also attach DWG files as references.
When working with references, the active file, the one that you are in, is called the master file. Elements in a reference display as though they were in the master file.

➔ **Exercise: Select a file to attach**

1. Open the model named Streets.
2. Select the References tool from the Primary Tools toolbox.
3. In the References dialog, click Attach Reference.
4. In the Attach Reference dialog, select MicroStation_Essentials_V8i.dgn. Do not click Open yet. Let’s examine the dialog.

The default attachment method is called Interactive. With this method, additional settings are set in the Reference Attachment Settings dialog. The Attachment Method option menu on the right side of the dialog lets you select the method.

When you use the other attachment methods the Reference Attachment Settings dialog does not appear. The default attachment settings, or the attachment settings used for the last reference attached, are used instead. Once a method is selected, it remains in effect until it is changed.
The Save Relative Path check box in the Attach Reference dialog is important.

A reference attachment that identifies the location of the file resides by its full, or absolute, path is not portable across projects and networked systems. If the attached file is not found in the exact location, the attachment will be missing. The best way to ensure portability when attaching references is to enable Save Relative Path. This causes the relative path to the file to be saved with the attachment data in the DGN file so the file can be more easily located.

Exercise: Save the relative path

1. Continuing in the Attach Reference dialog, check the Save Relative Path check box.

   Leave the Attachment Method set to Interactive so that you can set additional settings in the Reference Attachment Settings dialog.

2. Click Open.

Attachment settings

- The first option in the Attachment Settings dialog is the model you want to attach.

- Since the same model can be attached many times, the Logical Name field under the Model options helps you to distinguish between them.

- The Orientation section is where you set the view of the model that you will see.
Coincident, the default, aligns the reference with regard to design plane coordinates of the file to which you are attaching it.

Coincident World aligns the reference with regard to both Global Origin and design plane coordinates.

You can choose to attach a particular Standard View orientation (Top view, Front view, etc.) if any are present. This is mostly for 3D work.

You can choose to attach a particular Saved View or Named Fence if these are present.

- Scale (Master:Ref) sets the ratio of the master units in the active file to the master units in the attached model. Use this if the reference elements need to be scaled. For example, 2 to 1 would make the referenced elements twice as large as elements in the master.

**Exercise: Attach the hydrography model**

1. Continuing in the Streets model, set the following attachment settings in the Reference Attachment Settings dialog:

   **Model:** Hydrography

2. Click OK.

   You now see the elements that are in the Hydrography model.

**Note:** You can also drag files from Windows Explorer and drop them into the references dialog to attach them.

Attachment settings toggles define settings for the reference. The icons correspond to columns in the References list box and information panel. If an icon is pressed, the setting is on. Click the icons to toggle the settings.

These are the more commonly used toggles:
References

- The first one is Display. If it is on, the reference is displayed. This is on by default. If you need to hide a reference, use this toggle to cancel its display rather than detaching it.

- The second is Snap. If it is on, you can snap to elements in the selected reference. This is on by default.

- The next is Locate. If it is on, you can select elements in a reference for construction purposes. This is on by default.

- Treat Attachment as Element for Manipulation lets you manipulate whole references with the standard element manipulation tools. It is not on by default.

- True Scale uses units in the active model and those in the referenced model to calculate an appropriate scaling factor so that the reference scale reflects a true real-world scale. This is on by default and is discussed later in the module.

Updating reference elements

If changes to a reference are made while the file is attached, you will be able to see those changes immediately.

➤ Exercise: See changes to a reference immediately

1. Right click on the Hydrography model and select Exchange from the pop-up menu.

   The model opens. Use Exchange to switch models when you need to make changes to that particular model.

2. Expand the Element Selection tool settings.
3. On the Level tab, select the level river-fill.

4. In the Attributes toolbox, set the active color to 97, a dark blue.

5. Click Clear in the tool settings.
   The river fill is now dark blue.

6. Click the Previous Model icon at the lower left of the application window to return to the Streets model.
   The change you made to the reference is seen immediately.

**Manipulating references**

Although you cannot manipulate elements that are in references, you can snap to them and even copy them into the active model. You can also manipulate the reference as a whole.

**Manipulation tools**

Tools at the top of the References dialog let you manipulate a reference. They work like the element manipulation tool that have the same names; Move, Copy, Scale, Rotate, and Mirror.

Highlight the name of the reference you want to work with in the References dialog, click the tool, and follow the status bar prompts to manipulate the reference.

**Note:** Tools for working with references can also be found in the References toolbox. Select Tools > Reference to open it. It contains the tools in the References dialog and more. Remember that if you enable Treat Attachment as Element for Manipulation, you can manipulate references with the standard element manipulation tools.

**Reload Reference**

Reload Reference reloads and redraws a reference, which lets you see changes that have been made to a referenced model since it was last attached or reloaded.
MicroStation checks to see whether the file size or file time has changed for the referenced model before reloading. If these have not changed, the file is not reloaded.

Reference clipping and masking

The Clip Reference tool uses a boundary, such as an element or fence, to clip a reference. The area of the reference outside the boundary is not displayed.

The Mask Reference tool covers a portion of a reference that is inside a boundary. More than one clipping mask can be specified.

The Use References Dialog List option

One of the reference tools’ tool settings is Use References Dialog List. This option lets you select the reference you want to manipulate from the References dialog. If you are not sure of the name of the reference you want to manipulate, you can disable this option and enter a data point on an element from the reference you wish to manipulate.

Reference exchange and activation

You can switch into a referenced model if it is necessary to change something. You can also edit “in-place” using the Activate option. If someone else has the file open, you see an Alert that gives you an option to open the file read-only.

Exercise: Reference activation

1. Continuing in the Streets model, with the Element Selection tool active, right click the Hydrography model in the References dialog and select Activate from the pop-up menu.

The elements in the active model are grayed out and you can see the elements in the Hydrography model clearly. Use this method when you need to snap to elements in the model, but do not want to leave the present model.
There is an Activate Status column in the References dialog. When a reference is activated, there is a dot in the column. When a reference is activated, it is locked to other users. If you activate, remember to deactivate when you are done.

2 Right click the reference and select Deactivate.

It stays locked until you release the file by double clicking on the dot that appeared in the Activate Status column when the file was activated.

3 Minimize the References dialog.

**Reference levels**

You can turn reference levels on and off independent of the levels in the master file.

➤ **Exercise: Turn off the fill levels**

1 Continuing in the Streets model, click the Level Display tool in the Primary Tools toolbox.

2 In the Level Display dialog, select the Hydrography model in the list at the top of the dialog.

The names of referenced models are listed showing the model name first, then the file name. When you click one, the levels contained in that model are those listed in the dialog.

3 Click on the creek-fill and river-fill levels to turn them off.

The elements on those levels disappear.

4 Close the dialog.

**Transparency and priority settings**

References have transparency and priority settings that you can apply.
Exercise: Apply transparency to a reference

1. Continuing in the Streets model, click the View Attributes tool in the view control toolbox.
2. Click the Transparency icon.
   The transparency attribute is now allowed in this view.
3. In the References dialog, click Attach Reference.
4. Attach MicroStation_Essentials_V8i.dgn; the Limit model.
   The map is hidden by the limit boundary.
5. In the References dialog, right click the column headings and select Transparency from the pop-up menu to add the column to the dialog.
6. With the Limit model highlighted in the References dialog, click in the Transparency column and select 50.
   Hidden elements show through the limit boundary.

The Priority column has to be added too. Setting a value column makes elements in references with higher priority display in front of elements in reference with lower priority.

Detaching references

Be sure you want to detach a reference file before you do so. The scale, rotation, location, etc., of the reference are not saved when you detach the file. You will have to specify these settings again if you decide to re-attach it.

Exercise: Detach a model

2. Click OK in the Alert dialog.
Reference nesting

Live nesting lets you see a reference that is attached to a reference. A benefit of live nesting is that any changes to these sub-attachments are dynamically updated in any file to which their master file is attached.

Suppose you have a DGN file called X.dgn. A.dgn is a reference to X. A.dgn has two references of its own, 1.dgn and 2.dgn.

If A is attached as a reference to X with nesting disabled, only A will be listed in the References dialog hierarchy as a reference.

If A is attached as a reference to X with nesting enabled and set to a depth of one, it can be expanded in the hierarchy to show its references, 1.dgn and 2.dgn.

If 1.dgn and 2.dgn had references of their own, you could change the nesting depth to 3 to see those.

When you attach a reference, there are three options for nesting in the Reference Attachment Settings dialog. These are also available in the Attachment Settings dialog that opens when you double click on a listed reference. You can change this setting after a file is attached in this dialog.
To recap the Nested Attachments setting:

- No Nesting means that references attached to the model you’re attaching won’t be seen in the active model.
- Live Nesting means that references attached to the model you’re attaching will be seen in the active model.
- Depth controls how many levels of references attached to other references you will see.
- Copy Attachments copies references attached to the model you’re attaching into the active model. They are now directly attached.

**Exercise: Enable live nesting**

1. Open the Hydrography model.
   
   You are going to attach a reference to this reference file.

2. In the References dialog, click Attach Reference.

3. In the Attach Reference dialog, select MicroStation_Essentials_V8i.dgn, and attach the Parks model.

4. Return to the Streets model.

   You can not see the elements in the Parks model yet.

5. In the hierarchy frame, right click Hydrography and select Settings from the pop-up menu.

6. From the Nested Attachments options, select Live Nesting. Set the Depth to 1.

   The Depth field determines how many files deep you can see. Set to 1 you can see the references that may be attached to the Hydrography model. Set to 2 you will be able to see any references attached to those references.

7. Click OK.

   The parks that you attached to the Hydrography model are now visible.

8. In the References dialog, click the Show Hierarchy tool.

9. In the hierarchy frame on the left, click the + preceding the file name to see attached models.
In the right frame, you can see the Hydrography model’s references. You can control the display, snap and locate settings for the nested references. Just right click and select Settings from the pop-up menu, or select the reference in the right frame and toggle the check marks in those columns.

Display, snap, and locate columns

Resolving different working units

MicroStation uses working units to accommodate different systems of measurement. When working units differ between files, the relationships must be determined and then references scaled accordingly. True Scale makes the adjustments automatically. True Scale aligns the units one to one with the units in the active model.

If a reference model was created using feet and inches, but the working units in the active model are Metric, you will need to reconcile the different units so that elements are the right size. True Scale reads the units in which the reference model was created and adjusts the scale based on the active model’s working units.

Hint: It is a best practice to have the True Scale toggle on when attaching references. If there is any question, consult your administrator.

Exercise: References and the Fit View tool

1. Open the model named Refborder.
2. In the References dialog, click Attach Reference and attach MicroStation_Essentials_V8i.dgn, the Area Plan model.

Most view controls work the same with references as with the active design. However, Fit View, includes options specifically for reference files.

3. Fit View.
4. Change the following tool setting, and then click in the view:
   
   Files: Reference
References

Only the reference elements are fit to the view.

5 In the tool settings, change Files back to All, and then click in the view.

Fit View retains the last selected option. By returning to All you are assured that when you next fit the view, everything in the view will be included.

The title block and the site plan are not in alignment. You will fix this using reference tools.

Exercise: Move the reference onto the sheet

1 With areaplan.dgn highlighted in the References dialog, click the dialog’s Move Reference tool with the following tool settings:

*Move Boundary with Reference*: Enabled
*Use References Dialog List*: Enabled

When this is enabled you select the desired files in the References dialog, rather than by identifying them in the view. If you leave Move Boundary with Reference checked, the outline of the selected reference file is attached to the pointer to help with placement.

2 Following the status bar prompts, move the site plan into the center of the sheet and enter a data point.

MicroStation uses working units to accommodate different systems of measurement. When working units are different between files, the relationships must be determined and then references scaled accordingly. True Scale makes the adjustments automatically.
Exercise: Attach a reference with different units

1. Continuing in the Refborder model, attach MicroStation_Essentials_V8i.dgn, with the following attachment settings:
   - **Model**: Building Plan
   - **True Scale (Toggle)**: Off

2. Fit View.
   - The floor plan is referenced at the wrong scale. The plans have different units, and you did not use True Scale to rectify that.

3. Detach the Building Plan model.
4. Reattach MicroStation_Essentials_V8i.dgn, Building Plan model, with the True Scale toggle on.
5. Fit View.
   - The file is now referenced at a proper scale.

Exercise: Position the building using multiple views

1. Continuing in the Refborder model, open View 2, and then select Window > Tile.
2. In View 2, Fit View and then Zoom In on the red building footprint.
3 In View 1, Window Area around the upper left corner of the Building Plan model.

Using both views lets you see the current location and the destination.

4 With the Building Plan model highlighted in the References dialog, click Move Reference.

5 Snap to upper left corner of the column at the upper left corner of the building in View 1.

6 Move the pointer to the upper right corner of the building footprint in View 2 and enter a data point.

7 Reset.

The reference is moved. Now you must rotate it.
8 Maximize View 2.

9 Click the Reference dialog’s Rotate References tool and set the following tool setting:

   Method: By Points

10 Snap to the upper right corner of the red building footprint and accept as the pivot point.

11 Enter a data point at the lower right corner of the footprint to start the rotation.

12 Rotate the reference boundary until it fits in the footprint, enter a data point to accept, and then reset.

Models

Each DGN file contains one or more models that stored as a separate object within the file. A model is a separate working space inside one DGN file. Think of a
DGN file as a box that can contain different objects, the models, any of which you can view individually.

Every model has its own set of eight views. The model whose views are displayed at a given time is the active model. Every model can have its own working units. Levels, however, are shared throughout the entire DGN file.

**Hint:** Think of models as containers. References are the pipes that connect them letting the water, or information, flow between them.

**Types of models**

- A Design model holds geometry and can be either 2D or 3D. A model can also be placed as a cell. In MicroStation, you can create an unlimited number of models in a DGN file.

- A Drawing model is a subset of a 2D or 3D design model, used to apply annotations, dimensions, callouts, and other embellishments. A drawing model can be only 2D.

- A Sheet model is used for composing finished, deliverable, sheets. MicroStation lets you create an unlimited number of sheet models per DGN file.
Creating models

Create models in the Create Model dialog. To open it, click the Create a new model icon in the Models dialog.

Type options

- Design creates a design model. A design model has its own set of eight views and serves as a container for design geometry. The 2D/3D option for all types lets you choose whether the design model is 2D or 3D. Design models have a black background.
- Drawing creates a drawing model. This is like a design model, but a drawing model can be only 2D. These models have a gray background.
- Sheet creates a sheet model. This lets you attach references to create a drawing. These models have a white background.
- Design From Seed creates a design model using the set of eight views from a model in the file you select as the seed file. The actual background color will come from the seed model.
- Drawing From Seed creates a drawing model using the set of eight views from a model in the file you select as the seed file. The actual background color will come from the seed model.
- Sheet From Seed creates a sheet model from a model in the file you select as the seed file. The actual background color will come from the seed model.

Ref Logical field

Sets the logical name for the model. The logical name identifies the model when it is attached to another model as a reference. As with reference files you may
attach different views of the same model, and this field helps you to differentiate between them.

**Annotation Scale**

Choosing a value from this list sets the scale factor for text and dimensioning in the model.

**Update Fields Automatically check box**

If this is enabled, any text fields placed in the model are automatically updated when a file is opened. There is no need to issue a key-in to update them. It is a best practice to enable this option.

**Can be placed as a cell check box**

If this is enabled, it is possible to attach this file to another file as a cell library and place the model as a cell.

**Create a View Group check box**

If this is enabled, a View Group is created with the model and it is listed in the View Groups dialog at the bottom left of the application window. You can then open the model from the Models dialog or the View Groups dialog.

**Display Sheet Boundary check box**

(Sheet models only.) If this is enabled, an element representing the extent of the sheet boundary appears in the new sheet model.

⇒ **Exercise: Create a design model and add geometry**

1. Open the model named Element Creation and open View 8.
2. Zoom Out just so you can see the whole field, and then use Element Selection to select all the elements that comprise it.
3. Select *Edit > Copy.*
   
   This is the geometry you will be using and it is copied to the clipboard.
4. Open the Models dialog, click the New Model icon, set the following, and then click OK:
   
   *Type:* Design 2D
   
   *Name:* Field
Scale: Full Size 1=1
The model opens

5 Select Edit > Paste to add the geometry to the model.

6 Fit View.

Now you can use the model to create a park layout. First, your sheet needs a border.

→ Exercise: Attach a border to the sheet

1 Continuing in the Field model, in the Models dialog, click the New Model icon, set the following, and then click OK:
   Type: Sheet 2D
   Name: City Park
   Scale: Full Size
   Display Sheet Boundary: Unchecked

2 In the References dialog, click Attach Reference.

3 Navigate to the Workspace\System\Borders\Iso folder.
Organizing Design Data

4 Select A1-border.dgn and click Open.
5 Set the following in the Attachment Settings dialog, and then click OK:

   Model: Default
   Detail Scale: Full Size 1=1

6 Fit View.

Now you can arrange the geometry inside the border.

Exercise: Create a park layout using the model

1 Continuing in the City Park model, in the References dialog, click Attach Reference.

2 Navigate to the General project’s \Dgn folder, select MicroStation_Essentials_V8i.dgn, and click Open.

3 In the Attachment Settings dialog, set the following and then click OK:

   Model: Field
   Logical Name: Junior Field
   Scale (Master:Ref): 1 : 2000
   Level: Park - City

4 Toggles: As shown (with Treat Attachment as Element for Manipulation On)

5 Attach the Field model again using the same attachment settings, but use Junior Field 2 for the Logical Name.

6 Attach the Field model again using the same attachment settings, except for the following:

   Logical Name: Adult Field
   Scale (Master:Ref): 1 : 4000
Publishing i-models

An i-model is a format used for in-house project information exchange, such as when project information needs to be reviewed at a milestone. It is not the source content that you create and modify.

An i-model is read-only and is always saved with an .i.dgn extension. It converts information to a simpler representation, with smaller file size and easy navigation. No matter what format the input data is in, the i-model unifies it in a simple form. The process of converting the .DGN or .DWG file into an I.DGN file is called publishing.

How to publish a design file to an i-model:

Select File > Publish i-model. In the Publish i-model dialog, enable the Force republishing of all files check box.

Do this because, by default, a file is not republished if it has not been modified. This option forces the master and reference files to be republished, even if they weren’t modified since the last publish. This is useful when the
Publishing i-models

original files have not been modified, but configuration files or project files that affect the published file were.

Then, click OK. An i-model with an the i.dgn extension is created in the location that appears in the Message Center, usually the same folder as the original file. An i-model is created for each attached reference.

On the left, before publishing Design-Composition.dgn.

A list of files in the folder is shown above, and attached references below

On the right, after publishing. An i-model is created for each reference and those are attached to the i-model.

If the referenced i-model files are deleted from the folder, Design-Composition.dgn.i.dgn will still appear the same
The Create a package option may be used by an administrator to create a named i-model, such as "50 percent milestone", for external use. This i-model can have security applied.

Raster References

A Raster Reference is a link to an external image that resides outside the design file. Use the Raster Manager to attach, display and modify images in various formats. Raster tasks provide tools for working with image files.

Rasters are assigned to the active level when they are attached. You can change the level that a raster is assigned to in the Workspace > Preferences dialog. Select the Raster Manager category and then select the level under Default Raster Attributes.

When attaching a raster in a 2D model, rasters can be on different planes.

• Foreground Plane means they are on top of elements and references.
• Background Plane means they are behind elements and references.
• Design Plane means they share the same space as design elements with display Priority.

These exercises return to the example files delivered in MicroStation's General project.

➤ Exercise: Placing a raster image

1. Set the following in the File Open dialog:
   Project: General
2. Open Raster.dgn.
3. Open the model named Display Priority.
4. Click the Raster Manager tool in the Primary Tools toolbox.
5. In the Raster Manager dialog, click the Attach icon.
6. Navigate to the Examples\General\data folder.
7 Select satellit.tif and click Open.

8 Set the following in the Raster Attachment Options dialog, and then click Attach:

*Action tab > Place Interactively: Yes*

*Image tab > Description: Plane change*

9 Following the status bar prompt, enter two diagonal data points, placing the image over those in the file.

When you place a raster interactively, you select the space it will occupy. If you do not place interactively, you just enter a data point to place the image in the file.

**Attachment settings**

Options in the Raster Attachment Options dialog set attributes of attached rasters.

- The General tab has controls that are analogous to those in the Attributes toolbox.

  Level is the standard MicroStation list box to select a level. You can select any existing level attached to the current DGN.

  Color, Line Style and Weight, set the raster border color.

  Priority sets the display priority at attachment time. The field will not be visible if one of the selected rasters is not on the design plane.

- The Color tab has options that let you change the image’s tint, contrast, brightness, etc.
Plane

Rasters are listed according to the plane that they occupy. You can change the plane that a raster occupies after it is attached. When rasters are in the design plane, they share the same space as design elements. If they are in the background, they will always be behind any design elements. If they are in the foreground, they will always be in front of any design elements.

⇒ Exercise: Change the image’s plane

1. Continuing in the Display Priority model, with Element Selection active, move the pointer over the rasters in the file and note the borders as they highlight.

   The original rasters are all on the Design plane. The new raster is on the Background plane

2. Click the Plane icon that precedes satellit.tif, Plane change, in the Raster Manager.

3. Select Design and click OK.

All rasters now occupy the same plane. They are displayed in the order they are listed in the dialog. You can drag to change the order of listing and so, display.

4. Select Foreground and click OK.

   The raster moves to the front.

5. Move the raster to the background.

Next, you’ll see how to prioritize the display of rasters and elements.

⇒ Exercise: Adding elements and setting display priority

1. Continuing in the Display Priority model, select Place Block with the following tool settings:

   Method: Orthogonal
Area: Solid
Fill Type: Opaque
Fill Color: 7

2 Place the block so that it overlaps all the rasters.

3 With Element Selection active, click the block.

4 Click the Active Element Priority tool in the Attributes toolbox and change the Priority to 200.

5 Click Clear in the tool settings.

   With the higher priority, the block moves in front of all the rasters.

6 Click the background raster.

7 Change the Priority of the raster reference to 300.

   It does not change because it is assigned to the Background.

8 Select the raster to the right of the block and change its Priority to 300.
Note the change in display order.

**Attaching PDF documents**

The Adobe PDF format is available for attaching as a raster reference. The method is the same as attaching any other raster reference, except that when you have a multi-page PDF you must choose a single page for attachment.

**Exercise: Working with PDF attachments**

1. Continuing in the Display Priority model, open the PDF Reference model.
2. In the Raster Manager dialog, select 2DExample.pdf.
3. Select the Raster Manager Scale (Raster) tool, with the following tool settings:
   - **Method:** Active Scale
   - **X Scale:** 1.5
   - **Y Scale:** 1.5
4. Enter a data point.
5. Reset.

You can scale the PDF attachment.

6. From the Raster Manager’s menu bar, select *Edit > Clip* with the following tool settings:
   - **Method:** Block
   - **Mode:** Clip Boundary
7. Draw a block to isolate the top of the PDF.

8. Enter a data point to complete the clip.

You can use the raster tools with the PDF attachment.


Tips and Tricks

- There are two alternate ways to fit a specific reference.

  Open the References dialog box and select the reference(s) you want to fit. Then use the key-in REFERENCE FIT and enter a data point in the view.

  Select an element from the reference you want to fit, or select multiple elements from different references, then use the key-in REFERENCE FIT and enter a data point in the view.

- You can merge elements from a referenced file into the current file. It's important to understand that if a level is off, it won't be merged and if it's on, it will be merged. This is based on the setting in the Workspace > Preferences, Reference category, Copy Levels During Copy being set to If Not Found, which
is the default. So, turn off the reference levels you do not want in the file, then select *Tools > Merge into Master* in the References dialog.

- When attaching a raster, it is automatically assigned to the active level, but you can change this in the Raster Manager dialog. Right click a column heading to add the Level column, and then click in the column to open a dialog where you can select another level.

---

**Module Assessment**

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

[Organizing Design Data Assessment](#)
Module Overview

This module will help you to become familiar with the options that let you produce quality printed output.

Module Prerequisites

- Fundamental knowledge of the Microsoft Windows operating system.

Module Objectives

Upon completion of this module, you will be able to:

- Control the printable area of a model
- Determine print scale, paper size, and other variables
- Produce quality printed output, images, or PDF files

Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1. How do you place a fence?
2. How do you open and close view windows?
3. How do you activate a model?
4 What are working units?

**Answers**

1 Select the Place Fence tool, set the tool settings and, enter one, two or several data points depending upon the method that is selected.

2 Two methods are using the view toggles in the View Groups toolbox at the bottom left of the MicroStation application window, or selecting Window > Views > #.

3 Select the view group associated with the model in the View Groups toolbox or click the Models tool in the Primary Tools toolbox and then double click the model.

4 Real-world units to which the design plane is configured.

**Printing Basics**

Printing can be as simple as setting up a view window or placing a fence around the area of interest and clicking the Print icon. Typically, the result will be printed output of what you see on the screen.

The steps to create a print from MicroStation are as follows:

1. Open the Print dialog.
2. Select the print area.
3. Select a printer.
4. Set printing parameters, such as sheet size and scale.
5. Preview the print.
6. Click the Print icon to create output.

**Selecting the print area**

The initial print area is determined when you first open the Print dialog. If the active model is a sheet model, the print area is obtained from it. If no sheet exists, but there is a fence, the fence defines the print area. If no sheet or fence exists, the print area is the first open view window (lowest View number.)
Exercise: Examine print area

1. Set the following in the File Open dialog:
   - Project: General

2. Open MicroStation_Essentials_V8i.dgn and open the model named Pipe Support.
   - You see a sheet model.

   - In the General Settings section of the Print dialog, the Area is set to Sheet because you are in a sheet model.

If you open a design model, the area will change to View and the active view number will be reflected. If there is a fence in the file, the Area will be set to Fence. You can change the print area at any time using the Area option menu.

Setting the output color mode

You may need to print in grayscale or monochrome rather than using actual element colors. You can set a color printer to print in grayscale or monochrome using the Color options in the Print dialog.

- If you select Monochrome, output is black and white
- If you select Grayscale, colors are output as grayscale
- If you select True Color, the actual colors in the model are used

Note: The colors in the model do not change; the print reflects the color change.

Exercise: Preview the color modes

1. Continuing in the Pipe Support model, select Grayscale from the Color option menu.
When you choose a different output, you can see the result in the preview window.

2. Select Monochrome from the Color option menu.
Output is black and white.

3. Select True Color to use the DGN file colors.

**Selecting a printer**

MicroStation lets you work with the Windows printer driver or Bentley drivers. Bentley drivers are files that supply all the necessary information to create a print or plot, in a particular plotter language format. The option menu in the Printer and Paper Size section of the Print dialog lets you switch between the two types of printers.

**Drivers**

Selecting Windows driver loads the Windows printer driver configuration file. The Configure Window Printer icon is also available.

When you select Bentley driver the Bentley printer driver configuration file that you last used is loaded. You can select another one by clicking the Select Printer Driver Configuration File icon, the magnifying glass, in the Printer and Paper Size section of the Print dialog.
Hints: Use the jpeg.pltcfg, png.pltcfg or tiff.pltcfg files to create image output. Use pdf.pltcfg to print a PDF of the model.

Administrators can set a configuration variable to define a default printer driver configuration file that is selected each time the Print dialog is opened. In that case, you do not have to decide.

**The Full check box**

When you are using the Windows printer, you can enable the Full check box to maximize the portion of the sheet that is used. For example, when printing to a sheet that is $381 \times 279$ mm the maximum print size may actually be less. If full sheet is enabled, the print size will be the size of the entire sheet, or $381 \times 279$ mm. Some geometry may be clipped by the printer if it falls into the area around the edge of the paper that the printer cannot print.

When you toggle this setting, you can see the area change from total area to usable area or vice versa.

With the Full option enabled the total area will be printed. The actual usable area is smaller.

You also see the scale and size of the print change in the Print Scale and Position section of the dialog.

**Setting the printing parameters**

Settings in the Print dialog let you select the sheet size, set the scale for the print, and position the print on the selected sheet.

**Setting the paper size, orientation, and destination**

Using settings in the Printer and Paper Size section, you can do the following.

- Select a predefined paper size. Choices for page sizes are determined by the type of printer that you select.
Printing Basics

- Choose between Portrait and Landscape orientation.
- Select the output destination for the print.

Send to printer is available only when using a Windows printer driver.

Create plot file is available with the Windows printer driver and is the only option when using a Bentley printer driver.

Create metafile is available only when using a Windows printer driver. Output goes directly to a Windows enhanced metafile (.emf).

Exercise: Select a Bentley driver, the paper size, and orientation

1. Continuing in the Pipe Support model, set the following in the Printer and Paper Size section of the dialog:
   
   **Bentley Driver:** Click the magnifying glass, select pdf.pltcfg, and click Open
   
   **Paper:** ISO A3
   
   **Orientation** (under Usable area): Landscape

Setting the print scale and position

Using settings in the Print Scale and Position section of the Print dialog, you can set the required dimension or scale, and position the print on the sheet.

- Set the dimensional size of the printed output.
- Set the scale of the printed output as a ratio of working units to printer units. When setting the scale you are defining the number of design units (in working units) that equal each paper, or printed output, unit (in printer units).
- Set the X and Y origins to position the printed output on the selected page.
- Maximize the printed output or center it on the page.

Setting the height or width of the printed output

As an alternative to setting the scale for the print, you can set the X (width) and Y (height) size dimensions for the print.
When you first open the Print dialog, the printed output is maximized on the selected paper size. That means that either its width (X) or height (Y) is scaled to match the selected paper size, with the aspect ratio determining the remaining dimension. Within the limits of the selected paper size and the X origin and Y origin you can set the scale, the X (width), or the Y (height), of the printed output.

The settings for the width and height (the Size fields) and Scale are interlocked to preserve the aspect ratio of the print area. Changing one setting results in corresponding changes to the others. You cannot set the Size or Scale settings to something that would place part of the printed output outside the area of the selected paper size.

**Setting scale units**

A printer’s units and your design file units are not always the same. To change the printer’s units, in the Print dialog, select *Settings > Units* and then select different printer units from the menu.

You are setting the scale for the design as a ratio of its working units to the printer units. This setting will remain until the units are changed again.

Consider, for example, that your design file has Master Units (MU) of meters, while your printer’s units are centimeters. Creating a 10 meter to the centimeter scale output would require no changes to the printer units. You would enter 10 in the Scale field to make the printed output scale 10 design meters per cm of paper.

To create a 1:20 scale output, you could first change the printer units to meters, to match the design file’s master units. You would then enter 20 in the Scale field. The printed output would be 20 design meters per cm of paper, or 1:20.

**The Scale Assistant**

For more complicated scale values, you can use the Scale Assistant to help you set the correct scale. You can define the scale criteria either as Design to Paper, or Paper to Design. This is another setting that an administrator can pre-define for you. Then enter the required paper and design values in the fields below. The scale will be calculated from these.
Exercise: Change the printer units

1. Continuing in the Pipe Support model, note the ratio of inches of paper to centimeters of the design in the Print Scale and Position section of the Print dialog.

2. Select Settings > Units > cm in the Print dialog.

   This sets the printer units to be the same as the design file’s master units. Now one centimeter of paper will include centimeters of model.

   The size of the design does not change, but the scale criteria along with the size and origin change to reflect the new print unit setting.

Setting the print rotation

Use the Rotation option menu to select an orthogonal rotation.

- If you select None, no rotation is applied.
- If you select Rotate 90 cw, a rotation of 90° in the clockwise direction is applied.
- If you select Rotate 90 ccw, a rotation of 90° in the counterclockwise direction is applied.
- If you select 180, a rotation of 180° is applied.

If your administrator has configured your printing preferences so that you can use the Rotation entry field, you can specify any rotation in the 0-360 degree range as long as you are not using the View print Area. If working in 3D, you can use the field to rotate only prints that are not rendered and do not contain a camera definition.

Setting the print position

If the size of the print is smaller than the selected page size, you can control its positioning on the page.

By default, when you open the Print dialog the printed output is maximized. That means it is drawn to the largest scale that will fit on the selected paper size. Auto-center is also enabled by default so the printed output is centered on the page.
When you adjust the margins by setting an origin, Auto-center turns off because you are actually specifying the location for the content on the sheet.

You can turn on Auto-center to center the printed output, or click the Maximize icon to maximize the printed output on the page, at any time.

**Attaching pen tables**

Pen tables are text files that let you remap design file element characteristics for printed output. These are things like color, weight, or the order in which elements are printed. Once a pen table has been created you simply attach it when it is time to print.

To load an existing pen table, select Attach from the Print dialog’s PenTable menu. Select the pen table you want to attach in the Select Pen Table File dialog and click Open. The effect of the pen table can be seen in the preview window. When you apply a pen table, only the printed output is affected. The elements in the design do not change.

**Previewing the printed output**

The Print dialog’s preview window is good for quickly checking printing parameters.

During the set up process, you may use view controls such as Window Area or the zoom tools to redefine the view to be printed. After adjusting the view, you must update to ensure that the preview is displaying the new printing region. Click the Update from View icon to do this.
Printing Basics

For more accurate previewing, you can open a resizable Preview window. This lets you check how the printed output will appear more thoroughly, and is useful for checking fine detail. To open it, click the Preview icon in the Print dialog.

Creating the print

Once you have established settings in the Print dialog you can click the Print icon to create the print. What happens at this stage depends on your system configuration and your selected printer driver. For a standard configuration, with no modifications to printer driver files or configuration variables, the print will either go directly to a printer, or will be saved to disk for later submission.

You can submit printed output to any printer on your network, whether or not it is physically connected to your system. MicroStation lets you use different methods to submit printed output.

- Send the printed output directly to the system printer whether attached to your system or on a network.
- Send the printed output directly to a locally connected printer through the parallel port without first creating a print file.
- Create a print file on disk and copy this to the printer at a system prompt.

Send output directly to the system printer

To send the printed output directly to the system printer, establish the desired settings in the Print dialog, select the Windows driver, and click the Print icon.

Send output to a printer through a parallel port without creating a print file

To do this, establish the desired settings in the Print dialog and click the Print icon. In the Name field of the Save Print As dialog, enter the name of the parallel port, for example, lpt1: or lpt2: and then click OK.
Send a print file to a printer through a parallel port

Select Windows Start menu > Run, enter cmd in the Open field of the run dialog and then press <Enter>. At the system command line, enter:

```
copy /b <print_file> <port>
```

where:

- `print_file` is the print file to be sent.
- `port` is the parallel port on your system to which the printer is connected; for example, `lpt1:` or `lpt2:`.

The `/b` switch specifies that the file is binary.

**Exercise: Print to PDF**

2. In the Save Print As dialog, navigate to a location you will remember. By default, it is saved to the current project’s \out folder.
3. Save the print as Pipe Support.pdf.
4. If Adobe Reader is installed on your system, open the file.

Creating Complete Scaled Sheets

Because MicroStation designs can be printed at any scale, one model can be used in a number of sheets. For example, one model may be used in an overall plan at 1:100 and parts of it in other views or details at 1:10, 1:20, and 1:50. With manual drafting, each view or detail must be drawn separately. Using MicroStation, you only draw the model once. It can then be referenced to other sheets at various scales. You can use a whole model, or just a portion.

Working with borders

With manual drafting, you scale a model to fit the border. In MicroStation, you can do this using scaled references. Or, you can scale a border to fit a model. Borders can be attached as references or they can be placed in the model as a cell, just like any other symbol.
An advantage of referencing a border is that only one file or model needs to be updated if there is a change to the standard title block or border.

When putting together a sheet, you can place a full scale border and scale the model, or scale the border to fit a full scale model.

**Using a 1:1 scale border**

With manual drafting, there is a full size drawing sheet into which you place scaled views of models. In MicroStation, you draw the original model at full size and then scale it, as a reference, to fit the border.

For this method, you first create a sheet model, with the sheet layout set to full size. You reference a standard border at full scale into this model. Within the confines of this border, you reference the designs at the required scales. All text and dimensioning is placed in the model at full size.

When you install MicroStation with the default options a number of sample border files are delivered to the ANSI, Architectural, and ISO sub-folders of the \Workspace\System\Borders folder. In each border DGN file there is a default model, in which the title block is drawn at full scale.

When printing, you print the sheet at full size. The border and text will print at their actual size, while the elements will print to the scale at which they were referenced to the sheet model.

➤ **Exercise: Compose a sheet using a 1:1 border**

1. Continuing in the Pipe Support model, open the Models dialog.

2. Click Create a new Model, set the following in the Create model dialog, and click OK:
   
   * **Type**: Sheet 2D
   * **Name**: Print Sheet
   * **Ref Logical**: 1:1 border
   * **Scale**: Full Size 1=1
Size: ISO A1

3 In the References dialog, attach Workspace\System\Borders\ISO\A1-border.dgn, with the following attachment settings:

   Model: Default (this is a Full size 1=1 model)
   Detail Scale: Full Size 1=1

4 In the References dialog, attach Workspace\Projects\Examples\Building\dgn\BSI300AE9-Atrium.dgn with the following attachment settings:

   Model: Composite
   Orientation > Standard Views: Front
   Detail Scale: 1:100
   Nested Attachments: Live Nesting Depth 4
**Toggles:** As shown

Detail Scale to 1:100 means the ratio of the units in the active model to those in the attached model (Scale (Master:Ref)) changes to 1:100. The toggle lets you use the Manipulation tools to work with the reference.

5. Click OK and enter a data point to place the reference at the top of the sheet.

6. In the References dialog, attach BSI300AE9-Atrium.dgn, with the following attachment settings:

   *Model:* Floor Plan
Orientation: Coincident

Detail Scale: 1:200

7 Select Move from the Main toolbox.

8 Move the reference to the left side of the sheet.

9 In the References dialog, attach BSI300AE9-Atrium.dgn, with the following attachment settings:

Model: Atrium Ground Floor

Detail Scale: 1:50

10 Fit View to see the reference.

11 Select Move from the Main toolbox and place the reference on the right side of the sheet.

12 Select File > Close.
Scaling a border to fit elements

Creating completed scaled sheets that include a border requires extra planning and set up prior to printing. If you place text elements in a model and it is scaled, then the text elements also will be scaled.

An alternative to using a 1:1 scale border is to create a sheet model that is scaled to surround the required part of the model or the required elements.

Do this by setting the Annotation Scale to the required value when creating a sheet model. When you place text or dimension with the Annotation Scale lock on, the text and dimensioning is scaled so that it prints at the correct size. For example, if a border were 12 times its normal size, all text also would have to be 12 times its normal size. This sheet model has an annotation scale of 1 to 1. No matter how the model is scaled, the text will always maintain this ratio.

Note: An advantage of referencing a border is that only one file or model needs to be updated if there is a change to the standard title block or border.

Now you can reference the elements that you want to print at a scale of 1:1.

In such a case, when the final printed output is created, you would use the scale of 1:12 to reduce the border and text back to their normal size. At the same time, the elements will be reduced by the same ratio. You print the sheet model at a scale that returns the border back to its normal size, at the same time scaling the elements, text, and any dimensioning that was placed using an annotation scale.

The sample borders delivered with MicroStation each have a Default model, in which the title block is drawn at full scale. This model then is referenced to other models for various scales.
Simply select the desired scale model when attaching the border as a reference or when placing it as a cell. The description for each model indicates the size required for any text in order to produce standard size text in the printed output.

Tips and Tricks

• To add levels to your PDF output, in the Print dialog, load pdf.pltcfg and select File > Edit Printer File Configuration. On the Base Properties tab, expand the Driver Properties section. Set Enable Optional Content to On. Always check with an administrator before changing configuration settings.

• You can open a resizable print preview window that allows more accurate previewing by selecting File > Preview in the Print dialog.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. Assessment is used to determine what an individual knows or can do.

Complete the assessment to see what you have gained from reviewing this module.

Creating Printed Output Assessment
Appendix - AccuDraw Shortcuts

AccuDraw tries to anticipate your next move, but it cannot always predict your intentions, so there are keyboard shortcut key-ins. By pressing the appropriate key, you direct AccuDraw to perform a specific operation. Pop-ups confirm single letter shortcuts below the input field.

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Show Shortcuts: Opens the AccuDraw Shortcuts window</td>
</tr>
<tr>
<td>~</td>
<td>Bump Tool Setting: Move tool settings to the next value to set</td>
</tr>
<tr>
<td>A</td>
<td>Lock Angle: Toggles the lock status for the Angle value</td>
</tr>
<tr>
<td>B</td>
<td>Base Rotation: Rotates the drawing plane to the last non-content rotation, that is: Top, Front, Side, View, or Auxiliary. Select the shortcut again to return the drawing plane to its previous rotation</td>
</tr>
<tr>
<td>C</td>
<td>Center Snap: Activates Center snap mode</td>
</tr>
<tr>
<td>D</td>
<td>Lock Distance: Toggles the lock status for the Distance value</td>
</tr>
<tr>
<td>E</td>
<td>Cycle Rotation: Rotates between three main planes: Top, Front, and Side (3D only). This also works when your original plane is an ACS or context rotation, so you do not have to use RX, RY to rotate to a 90 degree plane</td>
</tr>
<tr>
<td>Enter</td>
<td>Smart Lock: Smart Lock</td>
</tr>
<tr>
<td></td>
<td>- In Rectangular coordinates, locks X to 0 if the pointer is on the drawing plane y-axis or sets Y to 0 if the pointer is on the x-axis</td>
</tr>
<tr>
<td></td>
<td>- In Polar coordinates, locks Angle to 0°, 90°, -90°, or 180° if the pointer is on a drawing plane axis or otherwise locks Distance to its last entered value</td>
</tr>
<tr>
<td>F</td>
<td>Front Rotation: Rotates the drawing plane to align with the axes in a standard Front view</td>
</tr>
<tr>
<td>GA</td>
<td>Get ACS: Retrieve a saved ACS</td>
</tr>
<tr>
<td>GK</td>
<td>Go to Keyin: Opens or moves focus to the Key-in browser</td>
</tr>
<tr>
<td>GS</td>
<td>Go to Settings: Opens or moves focus to the AccuDraw Settings dialog box</td>
</tr>
<tr>
<td>GT</td>
<td>Go to Tool Settings: Moves focus to the tool settings window</td>
</tr>
<tr>
<td>HA</td>
<td>AccuDraw on Hold: AccuDraw on Hold temporarily disables AccuDraw</td>
</tr>
<tr>
<td>HS</td>
<td>AccuSnap Toggle: AccuSnap Toggle toggles the state of AccuSnap off or on</td>
</tr>
<tr>
<td>HU</td>
<td>AccuSnap Suspend: AccuSnap Suspend stops AccuSnap until the next tool is selected</td>
</tr>
<tr>
<td>I</td>
<td>Intersect Snap: Activate the Intersect snap</td>
</tr>
<tr>
<td>K</td>
<td>Snap Divisor: Opens the Keypoint Snap Divisor settings box to set the Snap Divisor for Keypoint snapping</td>
</tr>
<tr>
<td>Key</td>
<td>Command</td>
</tr>
<tr>
<td>-----</td>
<td>------------------------</td>
</tr>
<tr>
<td>L</td>
<td>Lock Index</td>
</tr>
<tr>
<td>M</td>
<td>Point Keyin (multi)</td>
</tr>
<tr>
<td>N</td>
<td>Nearest Snap</td>
</tr>
<tr>
<td>O</td>
<td>Set Origin</td>
</tr>
<tr>
<td>P</td>
<td>Point Keyin (single)</td>
</tr>
<tr>
<td>Q</td>
<td>Quit AccuDraw</td>
</tr>
<tr>
<td>RA</td>
<td>Rotate ACS</td>
</tr>
<tr>
<td>RE</td>
<td>Rotate Element</td>
</tr>
<tr>
<td>RQ</td>
<td>Rotate Quick</td>
</tr>
<tr>
<td>RV</td>
<td>Rotate View</td>
</tr>
<tr>
<td>RX</td>
<td>Rotate about X</td>
</tr>
<tr>
<td>RY</td>
<td>Rotate about Y</td>
</tr>
<tr>
<td>RZ</td>
<td>Rotate about Z</td>
</tr>
<tr>
<td>S</td>
<td>Side Rotation</td>
</tr>
<tr>
<td>Space</td>
<td>Change Mode</td>
</tr>
<tr>
<td>T</td>
<td>Top Rotation</td>
</tr>
<tr>
<td>V</td>
<td>View Rotation</td>
</tr>
<tr>
<td>WA</td>
<td>Write to ACS</td>
</tr>
<tr>
<td>X</td>
<td>Lock X</td>
</tr>
<tr>
<td>Y</td>
<td>Lock Y</td>
</tr>
<tr>
<td>Z</td>
<td>Lock Z</td>
</tr>
</tbody>
</table>
Design Labs

What to Design

The total floor area of a floor framing plan for a small, self-contained, area is 206 square meters. However, the total space available for development is less than 154 square meters. The dashed lines define circulation space, which must remain clear. Starting with a new file, you must draw the floor plan and lay out workstations in the area.

Each work station will consist of a cubicle with an L-shaped computer table with dividing partitions, a utility casing post, which can be shared among stations, and a chair.
What to Design

The sketch shows all parts of the cubicle and the dimensions. Using this, complete the space utilization design.

Parameters

- The room must contain at least 18 work stations, but place as many work stations as you can fit into the available space.
- Provide aisles to give access to work stations. Aisles must be at least 70 centimeters wide.
- Avoid the columns in the center of the floor space.
- Here are 2 arrangements for clustering work stations.
How to Design

1. Create a new file for the floor plan.
2. Draw the outer and inner walls and doors.
3. Draw the circulation area, which is centered on the room.
4. Draw square circulation zones, which should be centered horizontally and spaced evenly vertically.
5. Design the first L shaped workstation.
   Consider using Place SmartLine and AccuDraw.
6. Draw the cabinet.
7. Draw the equipment cable access portal.
8. Draw the utility casing post.
9. Draw the chair.
   Next, solve the space utilization plan. Fit cubicles in various cluster layouts.
10. Use Copy, Move, Rotate, and Mirror to place at least 18 cubicles, keeping aisle spacing and walking areas clear.
**Review the Design**

This lab creates a P & ID diagram.

**How to design**

1. Create a new file.
2. Following the schematic, create cells for the various features.
What to Design

3   Place the created cells in the proper locations.
4   Draw the connecting piping.
What to Design